IDE (CD-RW) - CDA with SF 4.5 work under WinXP - solution+reason

mattlok wrote on 11/30/2001, 1:57 AM
Before I begin. This is specifically for CD-Architect 4.0a-g working with SoundForge 4.0 - 4.5

Do not ask about CD-Architect working SoundForge 5.0 because they are not truly supported to work together
but if you can actually get those two to work, then let me know :)


- Users using IDE (CD-RW) for CD-Architect with SoundForge 4.5 works well under Windows 95/98/ME,
but when updates to a more current operating system (Windows XP) - CD-Architect with SoundForge 4.5 no longer recognizes or sees the IDE (CD-RW). Therefore rendering the program (CD-Architect) useless for any "CD burning" of any kind.


Under Windows XP, Windows XP utilizes its own drivers for burning CDs or DVDs allowing any CD-RW or DVD-RW of almost any model or brand to be used with out having to constantly update device drivers "PER SOFTWARE" because it shares the drivers with all software that is PROGRAMED under WINDOWS XP COMPLIANCE. Just like DIRECT X - Plug-ins that share with other software programs. Currently almost all of the CD-RW/DVD-RW programs like CD-Architect, Nero Burning, Golden Hawk, Adaptec EZ CD Creator, etc. have their own drivers independently for each program and has to be updated constantly everytime a new CD-RW comes out into the market. Therefore you could have 2 out of the 4 programs recognize your "NEW" CD-RW only because only 2 programs have the current drivers needed while the other 2 don't which in-turns means you have to buy another upgrade. This is probably one of the main reasons why Sonic Foundry stop supporting CD-Architect. Thanks to the new architecture in Windows XP, majority of CD-RW/DVD-RW companies can program upcoming software to just look for your current CD-RW/DVD-RW without having to find drivers. Just like Direct-X. I'm sure some of you remember the bad days of playing DOS games in Windows and always had to find drivers for every single game.
Overall it means that we don't have to fish for drivers anymore for every CD-R/DVD-RW software, it's up to Microsoft and the CD-RW/DVD-RW to come up with it. Quick hint, you can actually burn CDs in "Windows Explorer" just by dragging your files from your "C: drive" to your "CD-RW drive - D:, E:, etc)

Technical Reason:

In short, CD-Architect, Nero Burning, Golden Hawk, Adaptec EZ CD Creator, etc. programs are looking for an "ASPI MANAGER" which no longer exist the why these programs used to know because it has been re-allocated and named differently specifically for Windows XP. Keep in mind non-of these programs are coded (programmed) under Windows XP compliance with the acception of Nero Burning who are using a bit of a different method.


Here is a quick solution that will tie you over until these companies start adding in addition programming for Windows XP.
Before I begin. "Lounge Lizards" methods work pretty good but only under certain circumstances.

This method you DO NOT NEED any backwards compatiblity.

FIRST A WARNING - If you couldn't get your IDE (CD-RW) to work with CD-Architect under Windows 95/98/ME, this won't fix it either. Reason: Probably becasue your burner does not support Disc-At-Once which is needed for certain CD-RW programs.



Goto this link:


Download this file:
w2kaspi.exe (603 Kb self-extracting file for Windows 95/98 or NT)


After you are done downloading, double-click on that file you have just downloaded and install it. Follow the instructions and ALWAYS CHOOSE TYPICAL INSTALL. After the installation REBOOT.


Goto this site and print the content so you can follow the instructions easier. Or keep a bookmark and a browser up and handy.


Goto the section "ASPI Drivers for Windows NT and 2000" and read it over at least once so you know there is something ahead but don't act upon it yet unless you are an advanced user. Don't worry about the technicals, that I will try to guide.


Goto to your task bar at the bottom and "click start", then "click run". A dialog box will appear, beside the word "OPEN:" there is a command box. Click once in the box and you should see your cursor.
Then type "regedit" and "click OK"


A Windows Explorer like window appears. On the left side of the Window goto the "HKEY_LOCAL_MACHINE" and click on the "plus sign" NOT THE FOLDER. You should see a bunch of other folders expand. Now click the "plus sign" beside "SYSTEM", click the "plus sign" beside "CurrentControlSet", click the "plus sign" beisde "Services", click the "plus sign" beside "AspiXNT", and now finally just click on the "FOLDER" of "Parameters" so it is highlighted.


On the right side of the window, click on the word "ExcludeMiniports" so it is highlighted. Then goto the top of the where you see "FILE - EDIT - VIEW - FAVOURITES - HELP" and click on "EDIT", a menu will drop and then click on "Modify". A new dialog window should appear and under the heading "Value Data" there is a command box below it. Click on that box and delete the word "ATAPI". The box now should be empty. Now you can click "OK". Goto back to the top and click "FILE" and a drop down menu appears and click "Exit".


Do not run CD-Architect yet. REBOOT.

STEP 10.

Run SoundForge, then run CD-Architect. A dialog box should appear asking you if CD-Architect would like to detect ATAPI. Click "Yes". Then another dialog box appears and says something about the registry won't take effect until you restat the computer. Exit all the programs and REBOOT.

From this point on, everything should be just as you had it on your old system. And in some cases if you are using the ATAPI MMC Compatible, it should remember your settings after you set it for the first time round.

This fix also applies to other programs as well that require an ASPI MANAGER.

Fix For: CD-Architect, WinCDR, etc.


P.S. I'm not SF technical staff, just sharing information. Don't frown at me if you can't get it to work because all of our studios now work among other labels and artists from around the world.

Label Director
Four01 Recordings


mattlok wrote on 11/30/2001, 12:09 PM
Also, you do not need a fresh install of Windows XP. You can do this at anytime.
YellowSmileY wrote on 12/4/2001, 2:20 PM
Wow, this is GREAT...

I thought I was going 2 lose the best CD burning app I ever found
after I installed XP.

Now it's working perfectly again.

Thanks Mattlok!!
mattlok wrote on 12/5/2001, 11:48 AM
Message to: YellowSmileY

Hey no problems, I understand the frustrations.
Just spread the word on this new solution.


Label Director
Four01 Recordings
mattlok wrote on 12/10/2001, 11:00 AM
This method is also a solution for people with Windows 2000 Pro/Server.

Label Director
Four01 Recordings
mattlok wrote on 1/11/2002, 3:38 PM
Please remember that this method ONLY works for those who had a working CDA 4.0g and SF 4.5 in Windows 98 using their existing CDRW.


mattlok wrote on 1/11/2002, 3:41 PM
For Newer CDRW that don't work in both Windows 98 and XP under CDA 4.0g and SF 4.5

USE VEGAS VIDEO 3.0 it has CDA built-in that fixes almost the problems.
mattlok wrote on 2/9/2002, 9:52 PM
I Just want to say thanks to user: ajcb15 for the props. I this will help others who have the same problems.


King_alf2001 wrote on 2/15/2002, 4:21 AM
I try to fix following the instruction, but doesn't work
SF4.5+CDA worked fine under Win ME, but not w/XP Pro

I've a Plextor 16/40/10 (IDE), Athlon 1100 khz, IBM 40 Giga, 768 MB Ram

Under Win ME, I could select CDA drive settins using Atapi MMC compatible, and the other two device parameters (one was the CDR Plextor, the other was _056 or something similar, as don't remember name)

SF+CDA are exceptional in my opinion and I don't want lose them.
I would like use XP, however, as it seems to work better than ME.
But If I cannot fix in next two days this, I'll come back to ME.

Mattlock can you help me?

YellowSmileY wrote on 2/18/2002, 5:08 PM
try running SoundForge 4.5 under Win98/ME compatibility mode.

that worked 4 me....
King_alf2001 wrote on 2/19/2002, 5:05 AM
<try running SoundForge 4.5 under Win98/ME compatibility mode

Can you explain step by step?
Have to select something in Windows XP to run SF in win98/ME mode?
If answer is YES, what I have to do?

Thanks for help
mattlok wrote on 2/19/2002, 6:23 PM
Hi Alf,

I'm not sure about your system, but I have the exact Plextor burner as wel as the 12x version and the 24x version and all 3 works perfectly fine. This method also only works on the final release of Windows XP, not on the beta version. Also you need to be on administrator mode to edit the registration codes.

Either that or you must have missed a step or mis-type a value in the register key.

You have to be more precise on where or what part does not work...

I have someone who already mis-read my instructions and only skimmed through it realizing that it was his burner and not my instructions. But in your case Alf I know that burner works since I still use it in CDA. Oh yeah one more thing Alf, make sure you have CDA 4.0g, otherwise it will not work at all.

See Ya,

Label Director
Four01 Recordings
YellowSmileY wrote on 2/20/2002, 1:09 PM
Ok, first of all, double check to make sure U followed MATTLOK's instructions perfectly.

If U did, then just do this:

-Open Windows Explorer and go 2 the directory where Sound Forge 4.5 is installed
(c:\program files\sonic foundry\sound forge????)

-Find the file FORGE32.EXE and RIGHT CLICK on it

-Choose Properties

-Click the COMPATIBILITY tab

-It should have a box with the text "Run this program using:" Click that box and scroll down to the one that says "Windows 98/ME"

-click OK to save the settings

-Start up Sound Forge 4.5 and then CD Architect. It should ask you if you would like to enable ATAPI drives or something like that....just click yes...and then go 2 the ADVANCED window to detect ur ATAPI drive.

I don't know why, but this is the ONLY way I can detect my CDRW (by running the program under Win98/ME compatibility). But it works great...just like before.

Let me know if it works or if U had any problems....
Nanook wrote on 3/2/2002, 4:48 PM
Hi Mattlok,

I'm running Win-XP on a Gateway 700XL. Have used SF 4.5 for years on my Win-98 machine with no problems. Did everything you stated and still no luck. When I go to opne SF a dialog box opens asking me: DRIVE SELECTION and Sonic Foundry Simulator is in the box. I have tried numerous settings within the PROPERTIES box but no luck.

My CDR is a Lite-On LTR-24102B

Any suggestions?

Thanks, Nanook
Nanook wrote on 3/3/2002, 9:23 AM

OK, did everything Mattlok sugessted and all seeme fine. I then go to SF and then CD Art and click on DISC to burn a CD and a dialong box openes stating _Sound Forge Executable has encountered a problems and needs to close_

Any idea what might of went wrong?

Thanks, Nanook
mattlok wrote on 3/4/2002, 3:29 PM
Hi Nanook,

I think the burner you are using is not supported. I don't know anyone who has gotten that burner to run whether it was on Win98 or Win XP. Sorry!

PLease all users and new users, this solution is not for New CD-RW to work under Win XP. This solution is to allow migration from Win98 to WinXP from existing compatitibility. Anything beyond that is strictly on your own risk. Please read the ENTIRE outline carefully. It gives an explanation to why not all CD-RW works and that this is NOT a solution to make it work. If your CD-RW is not supported then try using VEGAS VIDEO 3.0 Pro as an alternate solution. Even the demo version will work.

Label Director
Four01 Recordings
Nanook wrote on 3/5/2002, 12:57 PM
Hi Mattlok,

Is there any other program that will allow you to create and save wav files in CD Arch and still burn them with track marks with no gap between tracks?

Thanks, Nanook
JoeD wrote on 3/10/2002, 7:32 PM
CDP burn

go here:

Open cdarch, make a project, save it when complete (.cdp file), then close and open cdpburn and burn the project.

it's not perfect, but it gives the unnecessarily screwed cdarch owners a fighting chance.

I have that same burner (lite-on) on one system and it worked ok.
Burn at 8x speed max though.

pilotpete wrote on 3/14/2002, 7:55 PM

I thought I was home free when I got the screen asking me if I wanted to detect atapi drives, but when I clicked "yes" I got a message saying my permissions were issuficient and to contact my administrator. When I loaded XP Pro I made all users administrators, any clue to what gives??? I've been using my TDK VeloCD 12X with sf 4.5 and cda 4.0 with the atapi update under win 98 with zilch problems, my only win 98 headaches are with other "non-audio" software.


YellowSmileY wrote on 3/18/2002, 3:27 PM
>I thought I was home free when I got the
> screen asking me if I wanted to
> detect atapi drives, but when
> I clicked "yes" I got a message
> saying my permissions were issuficient

I ALWAYS get that message. Just ignore it.
When UR at the SELECT DEVICE winndow, click "ADVANCED..." and then select ATAPI 0 or ATAPI 1 and find your burner. Mine works fine...

Also, make sure ur using CD Arch 4.0g...that probably makes a difference.