Image Sequence Contrast (in 32-bit mode)

neonmedia wrote on 4/14/2014, 7:24 AM
Need to operate in 32-bit mode because Vegas seems to assume MP4s are studio level and to recover computer level MP4s is to operate in 32-bit mode.

The stills output looks bizarre (JPGs PNGs EXRs), washed-out, but it imports correctly as a stills sequence while continuing to look washed out when dragged directly onto the timeline directly. If the contrast is fixed externally it then imports with excessive contrast. This is much more than a computer vs studio levels problem.

I've read elsewhere this problem only happens in 32-bit mode in Vegas, and was wondering if there's some magic setting in preferences to fix.


farss wrote on 4/14/2014, 7:45 AM
Which 32bit mode?

videoITguy wrote on 4/14/2014, 9:54 AM
Note the information shown below. I have kept the thread titles intact so you can do more searching and review this issue in depth.
Subject: RE: complex video/religion question: 8-bit 32bit full
Reply by: vtxrocketeer
Date: 2/21/2014 9:48:25 AM

Whenever I switch from 8- to 32-bit color depth (full range) for the FIRST time in a project, the "View Transform" defaults to ACES RRT. This makes my flat footage look immediately cooked: colors go wonky and blacks and whites are fairly clipped.

Verify the behavior and settings that I described. Then switch "View Transform" to "off." Do you get 'back' your nice and flat image? Hopefully, you do.

I don't work with 4k, but I always cut in 8-bit color depth to maintain smooth preview. If I need full 32-bit, it's the very last thing I switch before I color correct and grade, usually by spot-checking since I can't (usually) get full preview rate at this setting.


Subject: RE: Render to preview window footage mismatch
Reply by: Colin Basterfield
Date: 3/20/2014 4:55:51 PM

OK, I have enough (hopefully) humility to fess up to the following...

On my project properties, I had my View Transform set to ACES RRT (sRGB), and my 32-bit floating point value set for Pixel format. They are now set to Off and Video Levels respectively.

I haven't used the software a for a while, not since I used my PD170 last, a while ago now, so didn't remember changing any of those values before, perhaps when I allowed the import to match the settings it did it automatically, but maybe not.

So thank you all for humouring me. :-)

musicvid10 wrote on 4/14/2014, 10:13 AM
"Need to operate in 32-bit mode because Vegas seems to assume MP4s are studio level"
-- Nope, quite the opposite. Vegas' preview, unlike Premiere, displays full RGB scale, so your REC 709 source levels display as 16-235, not at player levels. Sounds like everything is correct and as-expected.

"to recover computer level MP4s is to operate in 32-bit mode"
-- Only 8-bit source shifts levels in 32-bit mode, and this is not the preferred method if and when it is needed. 32 bit projects are confusing unless you have a lot of experience, and are unnecessary for your workflow afaict.

"The stills output looks bizarre (JPGs PNGs EXRs), washed-out,"
-- That's because the stills are in RGB image space. Apply a Computer->Studio RGB Levels filter to only the stills track(s), and all will be well. That's assuming you are rendering to a REC 709 codec.

To summarize:
-- Work in an 8 bit project.
-- Allow the mp4 video to look flat in the preview. It will render and play back correctly, everything else being correct.
-- Apply the Studio RGB filter to the stills only. They will now look flat in the preview as well.
-- If the render is to be mp4 or another "YUV" codec, leave everything else alone.
robwood wrote on 4/14/2014, 12:43 PM
i work with image sequences in Vegas... it doesn't handle all formats correctly in 32-bit (either mode).

besides the sRGB / rec709 problem, 32-bit can also cause Vegas to read img-seq's as linear instead of log (u get crazy low readings on the scopes when this happens). go back to 8-bit, problem gone...