m2t thumbnails PLEASE!

pjrey wrote on 7/21/2008, 2:57 PM
i didn't know where else to ask.. vegas is showing thumbs JUST fine for my m2t's EXPLORER is not! i am running vista 32 bit ultimate...
before sp1 thumbs for my m2t files were showing just fine.. now, for the life of me, i cannot get a video thumb of my files...

i can play them with wmp11 or with wmp-classic.. just fine.. and i am able to view (and edit) them within vegas 8 as well...

what did sp1 do to break the thumbs i wonder...

if i take my VIDEO.m2t and rename it to VIDEO.AVI, i get a thumb of my video...
i have gone into the registry and looked at root/avi
and matched it to my m2t (this is what i did originally in PRE-sp1 to get it to work) and it worked fine then, NOW IT WONT.. waaahhhhh..
please, if someone knows something i don't, please share, this has been an ongoing issue! i want to resolve it... help me figure this out one
im surprised more people arnt curious/bothered by this...

i do not wish to use 3rd party apps (they are not needed)
windows can do this naively, its just a matter of HOW!
thanks again
your help is much appreciated!



blink3times wrote on 7/21/2008, 3:16 PM
There seemed to be something about this on HV20.com

pjrey wrote on 7/21/2008, 4:32 PM
thanks for the link, but already been there... if you look at the dates its all pre sp1, and that would have worked... since sp1 something happened...
i have not tried the last post quick dll file...
the strangest thing is that i am able to view the thumb if i rename them, i can even rename them back to m2t and the image stays... that is one workaround, create a bat file to rename extension to avi/ or mpg, then back again...
seems a little silly...
something is up here, and i want to figure it out!
blink3times wrote on 7/21/2008, 5:54 PM
If it's any consolation... I have been down this road too. STILL haven't got m2t thumbs. If you find answer, let me know.
pjrey wrote on 7/21/2008, 8:35 PM
the kicker is, i searched for ages! then finally got it going too!!! then sp1 took it away from me, like a robber in the night!
so, i am traveling this road one more time... hopefully its the last! come onnnn.. how hard can this be...
if i find out, i will post here! you do the same!
1,2,3 TEAM!
darg wrote on 7/22/2008, 11:10 AM
It works for me in the explorer but is there a possibility to get thumbs in the explorer window of Vegas? This would be far more helpful than in Windows Eplorer only.

Axel, San Jose
jrazz wrote on 7/22/2008, 6:30 PM

Did you get my email I sent you via your website about two weeks ago? I tried your email I had on file for you but it was no longer working.

j razz
pjrey wrote on 7/23/2008, 8:22 AM
darg, i only can get thumbs in VEGAS (not explorer though, but PROJECT MEDIA) i want to see the thumbs in windows explorer! it was possible, it is possible again... just figuring out how!
jrazz, i wrote you with my current email!
winrockpost wrote on 7/23/2008, 1:33 PM
I have sp1 and show in windows explorer if i have view icons as medium or large, but never have gotten them in vegas explorer which really blows
darg wrote on 7/23/2008, 1:36 PM
It works for me in Windows Explorer, anyhow it was working before in the Project Media Window and it looks like that the Explorer Window of Vegas is not affected by this. I was hoping that I can get thumbs in the Explorer Window of Vegas.

pjrey wrote on 7/23/2008, 6:09 PM
i cant believe that it is this difficult...
why is it i can rename the extension to avi, and thumb shows.. i then rename back to m2t and it stays... for good, even after reboot...
can somene please share with me?
the root/avi and root/m2t are the same...
what else should i be checking
my camera is the canon xh-a1
thank you


EDIT: are you two viewing m2t files or just avi?
winrockpost wrote on 7/24/2008, 5:29 AM
mt2 from z1, in windows explorer not vegas explorer, also shows fine in adobe browser. Not renaming anything I just have to have view icon as med or large
winrockpost wrote on 7/24/2008, 5:38 AM
Right-click on computer
2) click on properties
3) Click on Advanced System Setttings
4) Click on the Advanced Tab
5) Look for Performance
6) Click on the settings button within the Performance section
7) Click on the Visual Effects tap
Scroll through the list and look for Show Thumbnails Instead of Icons

pjrey wrote on 7/24/2008, 6:55 AM
winrock, i got that far.. (obviosly, if i stated that renaming it mpg creates a thumb)
its just that i am having problems with m2t files showing!!!! thanks for posting though

i have searched low and high...

winrockpost wrote on 7/24/2008, 6:58 AM
sometimes it is the obvious
good luck
pjrey wrote on 7/24/2008, 7:54 AM
i agree..
but the fact that i can already see thumbs, means that the option is already enabled...

pjrey wrote on 7/24/2008, 9:38 AM
i think i gottt it!!!
C:\Windows\System32\reg.exe ADD "HKCU\Software\GNU\ffdshow" /v "mpg2" /t reg_dword /d "5" /f

i typed that in the RUN line.. and POOOOF! .m2t files are showing thumbnails!!!!
anyone else who is trying this out! use the above line!!!
(must have ffdshow obviously)
ritsmer wrote on 12/4/2008, 9:49 AM
However, sometimes this command does not change the value to 5, so if it does not work, then manually (use regedit) set HKER_CURRENT_USER/software/GNU/ffdshow mpg2 to the value 5. (most probably the value will be 0 before this)
Zulqar-Cheema wrote on 12/5/2008, 3:30 AM
I don't seem to have that entry in my Reg, /ffdshow

can I add as a normal text and then put the values in?
ritsmer wrote on 12/5/2008, 7:14 AM
ffdshow is DirectShow and VFW codec for decoding/encoding many video and audio formats.
You can google and download it. It is also a part of the klite codec pack.
When you install it be sure that you check "show videofiles as thumbnails" (or something like that) - and after this - if m2t files are not shown as thumbnails - change the above key value to 5.

Remember also that you can adjust the size of the thumbnails using TweakUI (downloadable from Microsoft). I have mine at 180x180 which presents my videos well on the family plasma.
Zulqar-Cheema wrote on 12/7/2008, 4:29 AM
Thank you, I did check the mt2 show files, but that never happened so had to change the reg file as above.