MainConcept AVC/AAC - An error occurred ....

Susan Stephens wrote on 10/19/2011, 6:08 PM
I just installed the Vegas Pro 11 (64 bit) trial on my machine.

I cannot render using MainConcept AVC/AAC (*.mp4). I've tried several of the built in templates. I've tried various sources (AVCHD, MP4, AVI), and the render always generates the same error. I've tried with the GPU acceleration on and off. I tried uninstalling and reinstalling the Vegas Pro 11 trial.

The rendering window will pop up and run for 2 seconds, and then I get the following error:

"An error occurred while creating the media file untitled.mp4.
The reason for the error could not be determined."

The frame never changes in my preview window. I am able to successfully render in other formats (such as Sony AVC/MVC and QuickTime 7). I have plenty of hard drive space, and according to the task manager plenty of RAM.

System info:
Windows 7, Service Pack 1
i7 processor
64-bit operating system
ATI Radeon HD 5700 Series graphics chipset (driver version 8.892.0.0)
Catalyst Version 11.9

I've been using Vegas 9.0. So far I like what I see in Vegas 11, but this is a big problem that I need to solve before upgrading.



eightyeightkeys wrote on 10/19/2011, 6:19 PM
I had the exact same error....except mine also included MainConcept m2t.

After many attempts at it, I realized that my own render templates from V10 would not work. Error after error. "The reason for the error could not be determined."

I had to start from a fresh V11 template...tweak it, save it...then it worked.
Red Prince wrote on 10/19/2011, 6:50 PM
Untitled.mp4? Does that mean you tried to render a project you did not save first? Try saving the project first and see if it renders after that.

He who knows does not speak; he who speaks does not know.
                    — Lao Tze in Tao Te Ching

Can you imagine the silence if everyone only said what he knows?
                    — Karel Čapek (The guy who gave us the word “robot” in R.U.R.)

Susan Stephens wrote on 10/19/2011, 10:48 PM
Thanks. I tried every template and then started over with a new one. I ended up changing Encode mode to Render using CPU only. I already had the GPU acceleration turned off in the preferences, but that setting in the Custom Settings window made all the difference. I ran a couple of tests with Main Concept MPEG-2, and the GPU "acceleration" was actually 25% slower. Maybe I'll revisit that later.

Still, I like the image stabilization and new titler. I think I'll continue trying out V11 on a little project I'm getting ready to start.
John_Cline wrote on 10/19/2011, 11:24 PM
I, too, have found that most of my custom render MPEG2 and MP4 templates from Vegas v10 did not "migrate" well to Vegas v11. (I also found this to be true when I upgraded from v9 to v10.) I only use a handful of render templates anyway, so I just recreated them starting with one of Vegas' stock templates and it's been fine.
Beatdemon wrote on 6/16/2012, 6:38 PM
Thought I would post here as well. There is another thread regarding this issue here:

The only way the MainConcept codec will render for me is using the CPU. The GPU fails every time. I have a brand new NVidia GForce GTX 670, and another user with the GTX 680 is reporting the same issue. I'm using the new templates in Vegas 11 also, no old v.10 templates here.

The aforementioned user did report that the Sony AVC Codec allows him to render with GPU, so there is definately something funky going on with the MainConcept/NVidia 600 series.