Make Movie results in no audio in MP4 choice

TroyTheTech wrote on 12/12/2014, 7:20 AM
I recently upgraded from VMS11PE to VMS13PE and find that if I render projects manually (choosing the codec, the bitrate, etc) everything is fine.

But I was trying out the 'automated' Make Movie wizard - and when choosing MP4 (which is pre-set to create a 720p resolution output) it produced a file that had no audio track at all...

The audio works fine if I choose something else, such as AVCHD, or if I render it manually (as stated above) into the MP4 container/wrapper.

Should I submit this as a bug somewhere, or am I missing something?


Steve Grisetti wrote on 12/12/2014, 7:29 AM
What model of camcorder is your source video coming from and what format is it in?

Have you ensured you have the latest version of Quicktime from Apple, per the program's requirements?
TroyTheTech wrote on 12/12/2014, 8:08 AM
@Steve, thanks for the reply

The video sources are from recording within a PC (recording the screen via a screen recording program), in various formats, mainly AVC/h.264 with AAC audio. All of these have worked in the past. Quicktime is the latest (7.7.6) at this time.

- Testing with other codecs (MJPEG in AVI wrapper with PCM audio) the choice of MP4 in the Make Movie wizard works fine.
- Testing with the very same files as the first post again (AVC/h.264 with AAC audio) video files and MANUALLY rendering (configuring the resolution, etc in the rendering settings) it works fine.
- The only thing that does not work is the MP4 choice in the Make Movie wizard with those same files (AVC/h.264 with AAC audio)

Odd.... since other audio codecs work with the MP4 choice in the the Make Movie wizard, perhaps it is something in the wizard that is pre-configured, not working well with AAC audio?
TroyTheTech wrote on 12/12/2014, 8:38 AM
Well, I did some more testing and I'm finding tons of other videos in that same recording format I was utilizing (AVC/h.264 and AAC audio in the MP4 wrapper) and they work with the Make Movie wizard and choosing MP4...
It must be something in those few recordings.

Thank you for your reply and beginning to assist me however, Steve. Take care