MBL 2.5 has bug with VP13

CJB wrote on 4/25/2014, 10:35 PM
FYI for MBL users:

Red Giant's Magic Bullet Looks 2.5.0 currently has an acknowledged bug in it when processing images for VP13. It works fine with 8 bit color space but when you chose 32 bit (either video levels or full range) it will only process a portion of the image with serious scrambling of the display within MBL. I received confirmation of the problem this afternoon and it has been submitted to the engineering team. There is no estimate of the time frame for a update.

FWIW previous versions still work fine.

Comments

Grazie wrote on 4/26/2014, 1:11 AM
Wow, that's a real shocker!

OK in previous Version - 2.0. Vegas Preview using 32bit:


Very obvious issues for Version - 2.5 Vegas Preview using 32bit:


And this is the scrambled Edit Interface for this update Version - 2.5 Vegas Preview using 32bit.


Not good . . . .

Grazie

Grazie wrote on 4/26/2014, 1:14 AM
@dancerchris - It's not even correctly processing the portion of the screen. You can see major corruption of the colours in that which it HAS revealed.

Hmmm....

Grazie

Grazie wrote on 4/26/2014, 1:55 AM
Well, I've opened a TICKET and sent reports and JPGs to backup our findings. If I don;t receive an acceptable response within 5 working days, I shall escalate this up the food-chain.

Thanks DC - let's hope this isn't going to be ANOTHER 2-year wait as RG and SONY appear to ignore each other - again.....

Grazie

Grazie wrote on 4/26/2014, 2:34 AM
And this is what it SHOULD look like. This is in 2.0.1 using 32bit:

Spectralis wrote on 4/26/2014, 10:53 AM
I've experienced a problem with MBL in Photoshop CS6 x64. After I apply the MBL FX and return to PS it outputs a black image every time. I'll contact RG support about it.
CJB wrote on 4/26/2014, 11:13 AM
@Grazie: Hmmm. I'm not seeing your embedded files. What do I need to set besides the switch in my "Forum Settings"?
Erni wrote on 4/26/2014, 12:26 PM
Same bug in Vegas Pro 12 :(

Erni
tim-evans wrote on 4/26/2014, 1:08 PM
I saw this problem within 2 minutes of installing Looks 2.5 and opening a recent project in Vegas 12 . It wasn't apparent to me what was causing the problem - just that there was a major bug with this update.

Hard to believe such a problem could get through beta testing.
Grazie wrote on 4/26/2014, 2:36 PM
@Grazie: Hmmm. I'm not seeing your embedded files. What do I need to set besides the switch in my "Forum Settings"?eh?

Can anybody SEE my embed pictures?

G

WillemT wrote on 4/26/2014, 2:49 PM
No problems here - Firefox.

Willem.
Grazie wrote on 4/26/2014, 2:56 PM
Thanks WT!

G

CJB wrote on 4/26/2014, 4:29 PM
If you roll back to the version before 2.5 (you can have both installed at same time) it will work correctly with both 13 and 12.
CJB wrote on 4/26/2014, 4:30 PM
@Grazie:

I'm using Chrome, can't see them.
MUTTLEY wrote on 4/26/2014, 5:57 PM
I might be wrong on this, haven't played too much and still using V12 (middle of project) but for me it installed 2.5 as a separate plug in. In other words there are two Magic Bullet entries under plug-ins. Only mention this as someone brought up rolling back which if it installed like I think it did on mine you might not have to, just use the other one.

- Ray
Underground Planet
PeterWright wrote on 4/26/2014, 7:15 PM
All visible here Grazie - IE 11 in Win 7
set wrote on 4/27/2014, 3:54 AM
@Grazie: Hmmm. I'm not seeing your embedded files. What do I need to set besides the switch in my "Forum Settings"?

If you open this web via Google Chrome app of iPad2, the images will not opened. Just sharing...
But Win desktop version of Google Chrome open normally.
Spectralis wrote on 4/27/2014, 4:38 AM
I can see the images in this thread using Chrome on PC.

Perhaps the rendering problem I'm seeing with MBL 2.5 in Photoshop is similar to that in Vegas Pro. I never had this problem in PS with the previous version of MBL.