MPEG-4 Codec Help

mike_in_ky wrote on 7/17/2008, 10:57 AM
I have been using VMS 3.0b successfully for years and am now using the trial version of VMS Platinum 8.0d with plans to upgrade within the next week or so.

I shoot video using my Samsung SC-D365 Mini-DV video camera. It has 2 ways to store video - 1) with the Mini-DV tape and 2) on its Memory Stick. The Memory Stick option is quite convenient for the type of clips I shoot and so it's my choice technique. The file format used in storing video in the Memory Stick is Samsung MEPG-4 (AVI type). Unfortunately, when I try bringing in a file into the Time Line in both 3.0b and 8.0d, audio is the only thing that comes across - no video! Seems like a codec issue. The files play correctly in Windows Media Player. (NOTE: If I use the Mini-DV tape, I have no problems capturing the video and audio from the Firewire interface and getting it into VMS.)

What's interesting about this issue is several weeks before my hard drive died (last week), I was surfing the net and ran across a website saying it had the "ultimate video codec." Since this issue has existed for me since I got the Samsung camera (May 2006), I figured what the heck. So, I downloaded the codec and installed it. Presto, it worked! I was able to add these files to the Time Line in Sony Movie Studio 3.0b and the video came across with the audio! Also, the files still played properly on Windows Media Player and another player that I use (NERO). Once on the Time Line, I was able to edit the files and add effects to them, etc. I even bookmarked the site where I got the codec. Unfortunately, it all went away when the hard drive died. I had not backed up those files as I routinely do. I can't remember what the site address was. I've been surfing looking for it. It was a free codec and my guess is it will work with version 8.0d, too. Prior to finding and installing that codec and presently, I have to reformat each clip before being able to import into VMS. It's a pain as you might expect.

I've discussed this problem with Sony Customer Support personnel and even sent in a couple of example clips. They agreed VMS would not import the files and suggested I propose this issue for a fix in a future revision of the VMS and I did that last night.

Does anyone in the Forum know where I can get an MPEG-4 codec that would allow me to import this file type and get video and audio? If you feel it is not a codec issue, what do you think will solve this problem.


Eugenia wrote on 7/17/2008, 1:20 PM
Install this one first:
If that didn't work, install this one as well:
Let me know if now works for you.

Also, you might want to wait for VMS Platinum 9, because according to a recent article online, it will come out soon.
mike_in_ky wrote on 7/17/2008, 4:22 PM

It worked...thank you for the recommendation. I tried installing the codec referenced in the first link, but that didn't solve the problem. So, I then installed the codec referenced in the second link. Then I was able to bring the Sansung MPEG-4 files into the Time Line with both video and audio coming across. I was able to edit the Time Line, etc. I then made sure that the files continued to play properly in Windows Media Player and NERO and they did. The next thing I did was to uninstall both codecs and then reinstall only the one referenced in the second link. And all works. I do not have the firsts codec installed. In your instructions, it sounded like both needed to be installed. Any followup on that issue?

Thank you for your advice.

I will await the arrival of 9.0 before I upgrade, especially if the upgrade pricing is in line with what it is for 8.0.


P.S. My wife's middle name is Eugenia....thought that was interesting.
Eugenia wrote on 7/17/2008, 4:27 PM
You can have both installed if you like. It's up to you.
mike_in_ky wrote on 7/17/2008, 4:49 PM
Thank you.

Retired wrote on 11/27/2008, 9:36 AM

I downloaded the link you suggested but didn't understand a thing about how to make the codes work or what options to check will installing. Pleas help.

mike_in_ky wrote on 11/27/2008, 5:26 PM

It's been a while since I installed the codecs Actually, I ended only needing to use the 2nd one that Eugenia recommended to solve my problem, but you may need to install both. Both files are ".exe". So after you download them, execute one at a time by double-clicking on the file to launch it. Follow whatever instructions they may provide in the execution. I'm not sure whether or not you need to tell the installer where you want the codec to be placed on your hard drive. As I recall, I double-clicked each one program, one at a time. I think as a precaution I restarted my computer after each install just in case it needed to be done...may not have to do it, however. After installing each one, I launched VMS and then tried dragging one of the troublesome files to make sure that video and audio were placed into the appropriate tracks on the Timeline. That was it, it solved my problem.

Let me know how it goes.