MS15 platinum won't let me render with 10 bit color but Pro 16 does

anoymous1234567890 wrote on 3/9/2019, 4:52 PM

To introduce this problem I am planning on getting the Panasonic AG-CX350 that recently came out so I can record in 4k and 10 bit color, 4:2:2 (up to 30fps), and the Hybrid Log Gamma and 60fps (in 4:2:0) are extras I will play with. To make sure my editing program (VMS15 Platinum) will accept these files and export them correctly I downloaded a sample video from a similar 10 bit 4k camera (Panasonic GH5 if you are curious).

 

I have a source file and here's the info from media view:

------------

Format                      : MPEG-4
Format profile           : Base Media / Version 2
Codec ID                  : mp42 (isom/mp42)
File size                   : 24.7 MiB
Duration                    : 8 s 533 ms
Overall bit rate mode : Variable
Overall bit rate           : 24.3 Mb/s
Encoded date            : UTC 2019-03-09 22:02:12
Tagged date              : UTC 2019-03-09 22:02:12

Video
ID                          : 2
Format                      : HEVC
Format/Info               : High Efficiency Video Coding
Format profile           : Main 10@L5.1@Main
Codec ID                  : hvc1
Codec ID/Info            : High Efficiency Video Coding
Duration                    : 8 s 509 ms
Bit rate                    : 24.1 Mb/s
Width                       : 3 840 pixels
Height                      : 2 160 pixels

Display aspect ratio        : 16:9
Frame rate mode             : Constant
Frame rate                  : 59.940 (60000/1001) FPS
Color space              : YUV
Chroma subsampling      : 4:2:0
Bit depth                   : 10 bits
Bits/(Pixel*Frame)          : 0.049
Stream size                 : 24.5 MiB (99%)
Language                    : English
Encoded date                : UTC 2019-03-09 22:02:18
Tagged date                 : UTC 2019-03-09 22:02:18
Codec configuration box : hvcC

---------------

Here's what I get in vegas movie studio 15 platinum when I try to export it in 10 bit color: As you can see chroma subsampling is greyed out, well I get that as my source material is 4:2:0 but why is it only showing me 8 bit color and greyed out? All other rendering options for video give me no option for chroma subsampling nor color bit depth. Is this a problem with my settings somewhere or is 10 bit color exporting in VMS15 platinum simply not possible?

Now, when I tried the trial of Vegas Pro 16 I CAN render in 10 bit color with the same file but ONLY with a few codecs' options like Intel QSVC or Mainconcept HEVNC. Nvidia's NVEC does not give me the option to choose color bit depth - it just takes the options away.

 

Now, is what I'm trying to do with 10 bit color just not possible with VMS15 platinum or am I doing something wrong?