MXF support gone from Vegas Pro 9.0e???

Guy S. wrote on 7/12/2010, 1:02 PM
Is it my imagination, or is the .mxf wrapper not supported in Vegas Pro 9.0e?

I began editing a project at home on Vegas Pro 8.1. It had trouble with some of the files shot on my Panasonic GH-1 so I rendered those files to .mxf and that solved the problem.

But when I brought the project into work, Vegas Pro 9.0e listed the two .mxf files as missing when I opened the project. I let Vegas search for the files - and it found them and finished opening the project. But immediately after opening an error message popped up telling me that the files were missing.

The .mxf files were not visible in Vegas 9.0e's explorer window, so I opened the project in 8.1 on the same computer and the project loaded just fine - .mxf files and all. I also found that the files showed up in 8.1's Explorer window.

I clicked back to 9.0e and selected Render As and could not find an option to render as mxf.

Any idea as to what might be going on here?



Jay Gladwell wrote on 7/12/2010, 1:08 PM

Nope, it's not gone. Render as > Save as type > Sony .MXF... it's right there.

kkolbo wrote on 7/12/2010, 2:39 PM

If this is on your machine at work and it is under network control ...

I had this problem with every V9 upgrade on the computers at work. I found that I had to do a complete uninstall and reinstall as admin for each upgrade. When I did, .mxf was right back where it should be.

reberclark wrote on 7/12/2010, 3:37 PM
MXF on 9e here - no network, tho.
Guy S. wrote on 7/12/2010, 4:04 PM
I'm set up as a local admin on my workstation and am prompted for my admin ID whenever I install anything, and/or whenever a program tries to install an update. I installed both Vegas 8.1 and 9.0 myself...

I will nevertheless reinstall 9.0 just to see if that helps. In the meantime, here's what I see in version 9.0e right now:

Thanks for the help, I'll keep you posted.

jabloomf1230 wrote on 7/12/2010, 4:51 PM
MXF is on my PC as a render option. Although many people can upgrade from one build of Vegas to another, without uninstalling the old build, others have to do the uninstall first, or they get a partial install (as kkolbo has already stated).

You obviously have a 64 bit OS at home. What do you have at work? If you have Win x64, does it give you the same result with 64 bit Vegas as with 32 bit Vegas?
Guy S. wrote on 7/12/2010, 5:35 PM
I'm running Win 7 64 at home on a Core i5 and Vista 64 Business at work on a 2x Xeon dual core at work.

OK, so I logged out, then back in as an admin and started Vegas 9. MXF was magically there. I then uninstalled and reinstalled. After reinstalling I logged out, then back in under my user account. I registered Vegas (which required my admin login). After Vegas started, no MXF option.

I then ran Vegas as an admin and MXF was there.

For security reasons I need to run my programs as a user, not as an admin. Guess I'll need to contact support to see if there's a workaround. Thanks for all the help, I will keep everyone posted.

Guy S. wrote on 7/16/2010, 1:13 PM
Issue has been solved by Sony Tech support and our crack IT team:

The issue was indeed permissions, but I was unable to restore them using the registry editing procedure outlined by Sony Tech. Knowing the root of the problem, however, our IT folks were able to find a very simple fix:

We logged on as an admin and deleted the Sony software folders in my user folder. I logged back in as a normal user and opened Vegas. Upon opening, Vegas created new folders in my user profile; MXF support was restored and it was simple matter of importing my window layouts and redoing my project and program preferences.

Once we verified that the problem was with the permissions granted to my user account, it took maybe 5-minutes to fix, and that includes redoing my preferences.
megabit wrote on 7/16/2010, 1:27 PM

Which folders exactly did you delete?


AMD TR 2990WX CPU | MSI X399 CARBON AC | 64GB RAM@XMP2933  | 2x RTX 2080Ti GPU | 4x 3TB WD Black RAID0 media drive | 3x 1TB NVMe RAID0 cache drive | SSD SATA system drive | AX1600i PSU | Decklink 12G Extreme | Samsung UHD reference monitor (calibrated)

megabit wrote on 7/18/2010, 12:53 AM

I'd be grateful if you elaborated on which folders should be deleted.

I'm suffering from my Vegas installation eating up memory when simply playing MXF timeline (and ONLY MXF) - not to mention render it, when the RAM usage can go up so quickly the whole system would freeze before a longer render is done.

As usually, SCS support didn't help me at all (even though the email exchange was lengthy, the thread has been closed as "Solved" before any solution was provided. And I do have serious reasons to suspect that the following 3 problems have to do with mishandled access rights:

1. the 64bit Vegas installation ending prematurely
2. Vegas not even seeing/handling MXF files when installed by the "real" built-in Administrator account,
3. Premature ending of the 64bit Vegas 9 installation script when run by a user with administrative privileges, but Vegas having memory leaks with mxf (described above).

I hope I could try your solution, before I decide to re-install my OS/apps from scratch...


AMD TR 2990WX CPU | MSI X399 CARBON AC | 64GB RAM@XMP2933  | 2x RTX 2080Ti GPU | 4x 3TB WD Black RAID0 media drive | 3x 1TB NVMe RAID0 cache drive | SSD SATA system drive | AX1600i PSU | Decklink 12G Extreme | Samsung UHD reference monitor (calibrated)