Andy E wrote on 4/14/2009, 9:25 AM
This would seem to indicate a different problem from the 8.1 template name change that John mentioned in his post.

If it's on the VirtualDub second pass, then the outbound render from Vegas has worked. Equally, the Deshaker filter uses its log file to store its first pass analysis. If it's about to start the second pass the log file access is ok, so it seems to me that the problem is another as yet unidentified issue.

I'm just testing the version with logging in it and will release it tomorrow, all being well.


Edit: To be absolutely certain there are no problems with the log file, click on the "Configure Deshaker Filter" button and change the log file location. There is a button marked "..." that allows you to change location and name of the file.
Andy E wrote on 4/15/2009, 11:35 AM 15th April 2009. Bug fix/Change release.

Fix: No longer permits a null VirtualDub compressor setting.
Fix: No longer permits a null outbound template.
Fix: Render cancel is now handled.

Change: Logging (log4net) added.
Change: About box added.
Change: Filters out generated media and stills from selected events.
JJKizak wrote on 4/16/2009, 6:03 AM
I tried the but I still get the same error message. One thing I forgot to mention was with the John Meyer script I get VirtualDub video on the first, second, and third pass (black 30 frames) and I do not get any "VirtualDub video window" with the New Deshaker. I also tried several log file paths.
Andy E wrote on 4/16/2009, 6:15 AM

In the folder where Sony Vegas Pro 8.0c is installed, there should be at least one log file named New Deshaker.log. If you can post the contents of that log file or email it to me, that should help nail where this is going wrong.

Edit: On re-reading your last post, it appears from the evidence that VD isn't getting to run at all. Something amiss with the generated command line methinks....
Laurence wrote on 4/16/2009, 7:47 AM
On my PC with Vista 64, it gets to exactly 50% then stops doing anything.

I get the following error message:

Error during script execution at line 1, column 5: Variable 'From' not found

Also this error message:

Despite planning for all possible contingencies
ritsmer wrote on 4/16/2009, 8:01 AM
Hi Andy -

Downloaded, installed and tried everything works just great (on good olde XP )

Thank you for the updates and improvements.
Andy E wrote on 4/16/2009, 9:26 AM

I think you must have the same issue as JJK - you're both running Vista 64 and I can't replicate the error on XP.

Once someone gets me the logfile entries, I'll be able to confirm my suspicions as to the problem.

Laurence wrote on 4/16/2009, 12:54 PM
Where do I find the logfile?
johnmeyer wrote on 4/16/2009, 1:16 PM
Maybe this dialog will help. As I reported earlier, I at first had similar problems running Andy's DLL under Vista with Vegas 8.1, but realized I hadn't chosen "Project Settings" for the Outbound Template.

Also, make sure that you download the "" file from Andy's site and copy the Deshaker.vds file. That needs to be on your hard drive, and the dialog below needs to point to that.

Try to match the following dialog and see if you have better luck:

Andy E wrote on 4/16/2009, 1:48 PM
Where do I find the logfile?

The logfile will be in the same folder as Sony Vegas Pro is installed. It's called "New Deshaker.log".

JJK's already emailed me the relevant details from his which already shows that the render out worked ok but that VirtualDub failed to run correctly.


P.S. I'm hoping that the change I made in to prevent a NULL outbound template will already have fixed the problem John reported.
Laurence wrote on 4/16/2009, 2:16 PM
I did a search of my entire C drive and found no file with the name "New Deshaker.log". My unsuccessful attempts with this script were with the latest version: so I'm afraid that it isn't fixed quite yet.
JJKizak wrote on 4/16/2009, 2:50 PM
Do you get the VirtualDub video window during processing with the new Deshaker? I do not but I get it Ok with the old John Meyer script.
johnmeyer wrote on 4/16/2009, 3:12 PM
OK, I just spent the past fifteen minutes doing everything I could to break Andy's fine work. Lot of fun!

Since it doesn't sound like the dialog box idea I described in my previous post actually helped anyone, I went back and re-read JJ and Laurence's posts and it dawned on me that both of them are people who have used my pathetic old, kludgey, multipe script hack. This means, among other things, they have MY version of the "deshake.vds" file that is used to feed stuff to Virtualdub.

However -- and this is important -- Andy has created a new one which is subtly renamed to "deshaker.vds."

So, in the spirit of breaking things, I used the dialog box in Andy's script to point to MY deshake.vds file instead of Andy's new version. Guess what? I ended up with some of the same error messages already reported.

So, as I mentioned in my last email, it is really important to download the "" file from Andy's site (which contains this deshaker.vds file) and put THAT version of Deshaker.vds into a location that you then point to from the script dialog.

I am betting that what I describe above is at least part of the problem being reported here. If it is, Andy you might want to include the Deshaker.vds file with the main download. I'm sure you don't want to create a complete installer, but at least include a readme in the Zip that pops up and reminds the user to use the new Deshaker.vds.

Also, if you have the time, you might want to do a quick check in the VDS file, and if it has my last name in it, throw an error message.
JJKizak wrote on 4/16/2009, 4:48 PM
Johnmeyer & Andy_E:
The New Deshaker files are installed in the Program files (X86) folder, not the Program files folder, both of which are on the "C" drive. Also the New Deshaker VDS file is located in the VirtualDub folder in the "Program Files (x86)" folder. Vegas 8.0c is installed in the "Program Files (x86)" folder and vegas 8.1 is installed in the "Progam Files" folder. The "New Deshaker Log file is accessed by clicking the "Sony Vegas Pro 8.0c" folder. I have deleted your old thumpy script & VirtualDub 1.6.18 even though it did work fine . (moved it to another area) The New Deshaker.vds file in VirtualDub is dated 3/17/2009. The New Deshaker still does not work with the
Dumb question, should the New Deshaker be installed in the "Program files" instead of the "Program Files (x86)?"
johnmeyer wrote on 4/16/2009, 7:58 PM
Dumb question, should the New Deshaker be installed in the "Program files" instead of the "Program Files (x86)?"Andy will have to answer that. I have VirtualDub in a folder called "video" with a bunch of other shareware video utilities. The newdeshaker.dll file is in a junk folder. Deshaker 2.4 (you are using 2.4?) is in the plugins folder inside the video folder I just mentioned.

Finally, I put the deshaker.vds file in the same folder as my old script files, namely the c:\deshake folder.

Now that means my stuff is really spread out. Perhaps there is something that goes on when everything is on one folder.

Also, perhaps there is some permission thing going on. I'm logged on with administrator privileges.

But, that's probably a red herring. I should probably just stay out of this ...
Andy E wrote on 4/16/2009, 11:56 PM
I should probably just stay out of this ...

Most definitely not!

I've PM'ed JJK with this as well but I'm posting it here too just in case this is Laurence's problem as well.

There are two script files that are needed for New Deshaker (and for the original for that matter).

The first is obviously "New Deshaker.dll" - the Vegas script file.

The second is the "Deshaker.vds" file which controls how VirtualDub operates (and allows us to run VirtualDub without any user interaction).

Be absolutely certain that the "Script File" entry in the dialog (see John's screenshot above) points at the second one and not the first one.

John has his in "D:\Deshaker\Deshaker.vds", mine is in "C:\Program Files\VirtualDub\Deshaker.vds" for example.

Also be absoutely certain that you do download VirtualDub from the link above since it contains the versions of VD (1.8.8) and the Deshaker filter (2.4) as well as the amended "Deshaker.vds" that the Vegas script was tested with.

Unfortunately, we have two completely different objects called a "script" and that appears to be where the confusion may lie.

Going forward, I have an installer under test (fairly minimal). I am not keen on bundling VirtualDub with the installation since the VD licence apparently demands distribution of the source as well.

Also going forward, the next major release (to include a VirtualDub-like compression dialog) will dispense with the "Script" entry on the dialog entirely since I'm planning to generate the file "on the fly" and remove it as part of the cleanup upon completion.
Laurence wrote on 4/17/2009, 7:35 AM
Well I think I see the problem then. Vista 64 has two program directories: one for 32 bit programs called "Program Files (x86)" and one for 64 bit programs called "Program Files".

Thus in order for a program to work in Vista 64, all references to a location called "C:\Program Files" would have to be changed to "C:\Program Files (x86)". I can see that there are two lines that need this change but I'm having trouble changing them with the configuration utility.
johnmeyer wrote on 4/17/2009, 8:32 AM
Well I think I see the problem then. Vista 64 has two program directories: one for 32 bit programs called "Program Files (x86)" and one for 64 bit programs called "Program Files".OK, this makes sense. I have dual boot, with Vista on a separate physical drive. When I booted to Vista 64, I didn't bother to copy or install any of Andy's stuff over to this drive, and instead simply ran it off the WinXP drive (which ends up being the D: drive when I boot to Vista). This apparently all gets treated as 32-bit, so I never saw the problem.

Nice sleuth work, Laurence.
Grazie wrote on 4/17/2009, 8:49 AM
. . and standing on the sidelines here reading . . .

I have JM's original Deshake. What do I need to d/l for Andy's? And where do I put it? XP Pro here.

Grazie wrote on 4/17/2009, 9:07 AM
Done. Installed. Menu. . . Experimenting.

I see there is a New Deshaker.dll - and THAT is the one I click on? Well I did and i got the Menu.

Grazie wrote on 4/17/2009, 9:22 AM
OK .. .

1] Set render folder on my H drive and it is showing in the Menu

2] Launch NewDes from the NEW Toolbar Icon and NewDes goes through its paces. Neat!

3] I eventually get a Take 2 but a message saying media is "offline". Oops

4] I note in my Project Media pane that the new file is present in my F drive

So to recap: I am getting an offline file and not in my H drive.

TIA . .

JJKizak wrote on 4/17/2009, 9:33 AM
John Meyer & Andy_E:
It works now except for the final video which is expanded from 1440 x 1080 to 1440 x 2160. Also 720 x 480 expands to 720 x 960.
Andy E wrote on 4/17/2009, 11:59 AM
Thus in order for a program to work in Vista 64, all references to a location called "C:\Program Files" would have to be changed to "C:\Program Files (x86)". I can see that there are two lines that need this change but I'm having trouble changing them with the configuration utility.


I'm guessing you have VirtualDub installed in "C:\Program Files\VirtualDub" rather than "C:\Program Files (x86)\VirtualDub".

Can you copy (or cut) and paste the VirtualDub folder from one to the other? Then click on the browse buttons on the New Deshaker dialog to alter the locations for VirtualDub.exe and Deshaker.vds to "C:\Program Files (x86)\VirtualDub".

Andy E wrote on 4/17/2009, 12:05 PM
So to recap: I am getting an offline file and not in my H drive


If your "render to" folder is H: then that is only used for the temporary renders out of Vegas. The actual "Take 2" file should be in the same folder as the original source video file but under a sub-folder called "deshake".

If you right-click on the "Take 2" file in the Project Media window and click on "Explore containing folder..." what happens? or alternatively click on properties and then the "General" tab and see where it thinks the file actually is.