new graphics card - Choppy/suttery video preview

alrooga wrote on 3/7/2012, 11:14 AM
Hi Everyone, hope you can help.
Recently got a nvidia 560 ti card and any motion in clips is really choppy in the preview, especially when its full screen (2 monitor setup, using the external monitor button). With just a simple scene where the camera is still and someone is walking across the frame, their movement is really stuttery. This is with no fx anywhere and is the case with gpu enabled or disabled. The playback rate is always full 25 fps so its not that.

Its only since i have the new 560 ti, the old 7600gt is fine.

Footage is 5d dslr files. Any one else have this problem?

Comments

paul_w wrote on 3/7/2012, 11:37 AM
5D footage should play fine. Have you set your project properties to the 5D media?



If that doesnt help, maybe try previewing at a lower resolution. Preview Auto or Preview Half seem safe for most.

Paul.
alrooga wrote on 3/7/2012, 1:45 PM
Thanks Paul for your reply. I didn't know about that button but i think project properties are fine.

I notice from your profile you have a multi screen setup. Windowed preview is fine (most of the time) its just when i go full screen (using the 'external monitor' button). The actual preview window is on the second screen and the external monitor (in preview device preferences) is set to the second screen also.

I can't reproduce it consistently, but happens a lot. It could be the quality setting but i've never had this problem before - countless edits up to now with same pc, dslr footage - its only since the new 560ti card i've experienced the problem.

Whats the full screen preview like on your pc?
paul_w wrote on 3/7/2012, 2:01 PM
The 'match media settings' button is important, you should always try and match the media you are using.
Tested it here, i am getting preview setting BEST FULL @ 25 fps. No matter if the external preview monitor is on or off. Its the same.
Tried moving the Vegas preview window onto the same monitor as the external monitor - no difference really.
Our systems are similar, your 920 to my 930 and your 560 to my 570 - its close.

Only thing left i can think of is display drivers - have you installed the very lastest from the Nvidia website? give that a try. Its version 295.73 at this time.

Paul.
Hulk wrote on 3/7/2012, 2:13 PM
Besides matching the media properties exactly make sure if the video is interlaced that you are playing it back interlaced. Or progressive if it is progressive. I don't have video acceleration but I can preview most of my AVCHD projects at Best/Half full frame rate. But if I forget to leave the deinterlacing filter on then I lose my smooth playback. I just have to remember to click the filter back on when I render.
alrooga wrote on 3/7/2012, 2:14 PM
I did do the match button but nothing changed. The setup is close, are you using 5d/7d footage?.

Its not that i don't get 25fps, i do, that doesn't change, but with clips where there is motion , something moving in the frame, its movement is choppy. I don't get it all the time now, i turned on the 'wait for vertical sync' in the preferences and i'm sure that did something.

Its interesting that when you moved the preview window to the external monitor nothing changes. If i have the preview window on monitor 1 (and its active) and monitor 2 as the external full screen preview, the external ones quality is reduced (looks like draft quality). As soon as move the preview window onto the external one (so its hidden), the quality of the external preview gets better....

Anyway, thanks for your help! Let me know if you have any other ideas.
paul_w wrote on 3/7/2012, 2:28 PM
Well setting the match media button to your media will set the vegas project properties to the same as that media. So your 5D is progressive and that should mean your vegas project settings will be shown as progressive too - can you just check that is correct. Also 'Field Order' should show as none (progressive scan).

Yes, testing with both 5D and 7D here. 25fps.

When you said your resolution changes on the external monitor when you place the vegas window monitor on it (hidden) - thats strange. I dont see that here. Stays the same.

Drivers?

Paul.
paul_w wrote on 3/7/2012, 2:37 PM
Another thought: check "Pixel Format" is set to "8 bit" and not to any of the 32 bit modes.

Paul.
alrooga wrote on 3/7/2012, 3:39 PM
Yeah its set to 8 bit, driver is latest release 295.73

Ah, worked out the drop in quality. What do you have your preview set to - auto, half, quater? When i set it to auto or quarter then i get less quality - i guess it scales up whatever size of the preview window is. When i have the preivew window on screen 1 and its set to preview->auto then quality is different, if i change it to preview-half then all ok. If in auto it guess its linked to how bit the preview window is on screen 1.

Have to see how it goes, seems to come and go at the moment.

Thanks for your help.
Hulk wrote on 3/7/2012, 9:15 PM
If you can upload the clip I'll check it on my system and let you know how it goes.
OldSmoke wrote on 3/9/2012, 9:42 AM
I had similar issues. I am using a ASUS ENGTX570 which is an upgrade from a GTX460. I immediately installed the latest NVIDIA driver 295.73 and that is where the trouble started. I am not sure whether this is brand related issue or not but after weeks of testing I found an older NVIDIA driver, version 275.33 not only to be more stable but also rendering times are better. Again, that could be brand related or even a combination of motherboard, graphic card and so on. I tested all versions of NIVIDA drivers that are supported by VP's GPU acceleration and the very first one supported is the 275.33 and it is still the best driver for me; also OC the GPU to 950MHz is stable with this driver. I did all my tests with the sample project provided by SCS and render times vary with different drivers by as much as 15%.

I personally think that there is a comunication breakdown between NVIDIA and SCS in terms of the CUDA acceleration setting with later driver versions as it gets worth with every driver after 275.33. However, that is only true for VP GPU acceleration because when you test later drivers with a 3D benchmark tool then the result is improving the newer the driver.

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)