No compatible codec (V12 build 367)

Maverick wrote on 10/27/2012, 2:43 PM
Based on some info from another thread I thought I'd play around a little to see what the results would look like:

I started a new project and added an event that is 1920x1080 50fps

I then set the timeline to absolute frames and changed the project properties to 1920x1080 24fps. Having noted the number of frames before the change I halved it and stretched the event to that number.

I then attempted to render to Sony MXF HDCAM SR 422 1080-24p setting the framerate to 24.000 (film) and Best.

On clicking OK I was met with No compatible codec was found.

As I said earlier, just playing to see what the final look would be like - experimenting really.

How do I get the codec?


Ron Windeyer wrote on 10/28/2012, 12:21 AM
I may be wrong; if so someone will soon correct me :)

I think you have erred in a number of areas. You cannot change your source media; it is what it is. If it is 50 fps then no use trying to change the project properties - Vegas will either get confused or spit at you.

Also 24 fps is not exactly half 50 fps. You will be out slightly.

What I did was start with a 1920 x 1080 50P project; just for fun I selected the Sony MXF SR422 template @ 24fps. Rendered fine. Imported that file back into Vegas - same length as the original file, Vegas reports it as 24 fps.

So keep the project properties, but render it to whatever you want.

Hope that helps.
Maverick wrote on 10/28/2012, 2:58 PM
Thanks for the reeply.

I started again and after putting the same event on the timeline I chose the same template as above and got the same error regarding no compatible codec.
Maverick wrote on 10/28/2012, 3:03 PM
Just tried the other MXF HDCAM SR templates and they all gave the same 'No compatible codec was found' error.
Ron Windeyer wrote on 10/28/2012, 7:42 PM
That's just wrong. Can't for the life of me see why. I don't think the codec would depend on something else (like Quicktime for instance). Only thing I can think of is try reinstalling...
videoITguy wrote on 10/28/2012, 7:59 PM
MXF literally is only a wrapper - don't mistake it for a codec- it can have many different codecs wrapped.
Ron Windeyer wrote on 10/28/2012, 9:31 PM
Thanks videoITguy - that clears it up a bit.

I don't have anything to do with this; just looking quickly on the net, I see talk about .mov files being enclosed in the MXF wrapper.

That may make Quicktime relevant - what version are you running?
Maverick wrote on 10/29/2012, 8:03 AM
I have QT installed.

I have read that later versions can give errors and that 7.6 is better but I didn't expect the error I was getting.

Before I uninstall and revert back to 7.6 can anyone offer a comment on that?

Ron Windeyer wrote on 10/29/2012, 8:21 AM
I have Quicktime 7.7.2 (1680.56).
What that means I do not know. As I said the MXF thing seemed to work for me.
Certainly others have found that going to 7.6 did fix problems.
Try it if you wish; good luck!
Maverick wrote on 11/2/2012, 2:03 PM
I sent a support question Sony regarding the error and got this reply a few minutes ago:

"An update to Vegas Pro 12 was just released which resolves issues related to this incident."

I had already installed build 394 (having first uninstalled the previous build and rebooting). The same error persists so I have replied as such.
Maverick wrote on 11/13/2012, 10:04 AM
Received a further reply from Sony Support as follows:

Lets have you install the SCS application to a newly created administrator profile. This will require uninstalling the software, creating a new user account, logging off the old user account and logging onto the newly created administrator account, then installing and activating the app on the new administrator account. This allows the software to make the necessary changes needed to the registry. Please consult the Help and Support Center in your Windows operating system for specific directions regarding creating a new user account with full administrator rights.

I have done the above yet still the error persists.