No preview on a system with 2x GTX 1080

megabit wrote on 2/13/2017, 7:22 PM

I'm sure this has already been discussed, but if someone directed me to some info on what's causing the lack of picture in VP 14 Preview Monitor (GUI window) I'd appreciate it. As can be seen in my sig, I have 2 GTX 1080s (used as accelerators) and the Decklink 12G (used with external monitor for full-screen preview). I can only use external preview (either Decklink or on the Windows Secondary Screen through one of the GTX'es) - the internal preview window is always black, unless I remove nVidia card from my Preferences=>Video tab... Thank you,

Piotr

AMD TR 2990WX CPU | MSI X399 CARBON AC | 64GB RAM@XMP2933  | 2x RTX 2080Ti GPU | 4x 3TB WD Black RAID0 media drive | 3x 1TB NVMe RAID0 cache drive | SSD SATA system drive | AX1600i PSU | Decklink 12G Extreme | Samsung UHD reference monitor (calibrated)

Comments

GJeffrey wrote on 2/13/2017, 8:06 PM

The last nividia driver update breaks vegas preview.

https://www.vegascreativesoftware.info/us/forum/nvidia-driver-version-378-49-date-01-23-breaks-video-preview-in-vegas--105348

You may need to revert back to a previous driver.

megabit wrote on 2/13/2017, 8:31 PM

Maybe so, but... I've had this happen with several different driver versions (currently I'm at 376.33). It started when I added the second GTX into my system!

Piotr

Last changed by megabit on 2/13/2017, 8:33 PM, changed a total of 2 times.

AMD TR 2990WX CPU | MSI X399 CARBON AC | 64GB RAM@XMP2933  | 2x RTX 2080Ti GPU | 4x 3TB WD Black RAID0 media drive | 3x 1TB NVMe RAID0 cache drive | SSD SATA system drive | AX1600i PSU | Decklink 12G Extreme | Samsung UHD reference monitor (calibrated)

Skywatcher wrote on 2/14/2017, 6:03 PM

Megabit,

Grazie and I had this problem. If you install the CUDA 8 Toolkit (from Nvidia's website) that will correct the preview issue. Here is the link to the other thread . . .

https://www.vegascreativesoftware.info/us/forum/anybody-running-nvidia-gtx5xx-with-cuda8--105524/

Skywatcher

bitman wrote on 2/15/2017, 12:42 PM

you may want to try the new official Nvidea drivers just out with some fixes: Version 378.66

APPS: VIDEO: VP 365 (21 - build 187), VP 365 20, VP 19 post (latest build -651), (uninstalled VP 12,13,14,15,16 Suite,17, VP18 post), Vegasaur, a lot of NEWBLUE plugins, Mercalli 6.0, Respeedr, Vasco Da Gamma 16 HDpro XXL, Boris Continuum 2024, Davinci Resolve Studio 18, SOUND: RX 10 advanced Audio Editor, Sound Forge Pro 17, Spectral Layers Pro 10, Audacity, FOTO: Zoner, DXO, Luminar, Topaz...

  • OS: Windows 11 Pro 64, version 23H2 (November 2023)
  • CPU: i9-13900K (upgraded my former CPU i9-12900K), Air Cooler: Noctua NH-D15s
  • RAM: DDR5 Corsair 64GB (5600-40 Vengeance)
  • Graphics card: ASUS GeForce RTX 3090 TUF OC GAMING (24GB) 
  • Monitor: LG 38 inch ultra-wide (21x9) - Resolution: 3840x1600
  • C-drive: Corsair MP600 PRO XT NVMe SSD 4TB (PCIe Gen. 4)
  • Video drives: Samsung NVMe SSD 2TB (980 pro and 970 EVO plus) each 2TB
  • Mass Data storage & Backup: WD gold 6TB + WD Yellow 4TB
  • MOBO: Gigabyte Z690 AORUS MASTER
  • PSU: Corsair HX1500i, Case: Fractal Design Define 7 (PCGH edition)
  • Misc.: Logitech G915, Evoluent Vertical Mouse, shuttlePROv2

 

 

Jam_One wrote on 2/15/2017, 1:04 PM
If you install the CUDA 8 Toolkit (from Nvidia's website) ...

...Which means, essentially, installing a "sorta non-game-ready" driver version 376.51 not listed in a game-ready crowd.

Grazie wrote on 2/15/2017, 3:01 PM

I didn't install the CUDA Toolkit.

What I did discover was a "gotcha" on the invidious site. Manually searching did NOT give me a certified option, but this page did: http://www.nvidia.co.uk/Download/Find.aspx?lang=en-us

And I had to choose not the ALL option. Click on the Menu Down arrow and got the CERTIFIED.

Last changed by Grazie on 2/15/2017, 3:05 PM, changed a total of 1 times.

Grazie

PC 10 64-bit 64gb * Intel Core i9 10900X s2066 * EVGA RTX 3080 XC3 Ultra 10GB - Studio Driver 551.23 * 4x16G CorsVengLPX DDR4 2666C16 * Asus TUF X299 MK 2


Cameras: Canon XF300 + PowerShot SX60HS Bridge

Skywatcher wrote on 2/15/2017, 3:12 PM

Thanks Grazie . . . that's good info (I wish I had researched more). I'm not a gamer but installing the wrong 'add ons' makes my system believe its under attack by storm troopers . . .

Skywatcher

Grazie wrote on 2/15/2017, 3:17 PM

Thanks Grazie . . . that's good info (I wish I had researched more). I'm not a gamer but installing the wrong 'add ons' makes my system believe its under attack by storm troopers . . .

Skywatcher


Best post I've read today. Wrong SciFi but I recommend "Phasers On Stun!"

Grazie wrote on 2/15/2017, 3:51 PM

This is the Page:

And this is the Certified list:

Skywatcher wrote on 2/15/2017, 4:10 PM

Thanks Grazie . . . I never noticed the drop down list. its always set to (all) and i just go with it. I'll undo all the gaming stuff and get a certified driver. Good work laddie!!

Skywatcher

Former user wrote on 2/15/2017, 9:09 PM

you may want to try the new official Nvidea drivers just out with some fixes: Version 378.66

I just updated my system (running a GTX560ti) and the new 378.66 driver didn't make any difference for me. I still have no GPU acceleration for anything in VP12...

Grazie wrote on 2/15/2017, 9:56 PM

JDW, I'm sure I must have read your experience with GPU ACCEL with VP12, but after enabling it in Preferences, how, what and where are you expecting to see a difference?

megabit wrote on 2/16/2017, 12:38 AM

Thanks Grazie and others. If you really want to get only the driver portion without any gaming (or other unnecessary) add-ons, go to http://www.wagnardsoft.com/ and:

- download DDU (the ultimate nVidia/AMD software uninstaller / reg cleaner)

- download their newest recommended driver for your specific card (it will come from some special area on vendor's server, and will NOT even contain any rubbish)

That's what I've always been doing - and yet - ever since I put the second GTX 1080 into my system - the Preview Window is empty. Or more precisely: it's empty when the external full screen preview is empty too, once you press the external preview icon (and you don't have your preview device configured to hide the contents of the preview UI window), the picture will appear in BOTH.... It's just internal preview alone which simply doesn't work (also with the 378.66, sorry to report :()...

Piotr

 

PS. One additional, nice function of DDU is setting Windows to NOT upgrade your display driver silently and without you consent, during regular Windows Updates - so after you found what you think is a stable and well-behaving driver version, it will never got updated / replaced automatically. Of course, you can always switch this function off...

Last changed by megabit on 2/16/2017, 1:36 AM, changed a total of 2 times.

AMD TR 2990WX CPU | MSI X399 CARBON AC | 64GB RAM@XMP2933  | 2x RTX 2080Ti GPU | 4x 3TB WD Black RAID0 media drive | 3x 1TB NVMe RAID0 cache drive | SSD SATA system drive | AX1600i PSU | Decklink 12G Extreme | Samsung UHD reference monitor (calibrated)

Former user wrote on 2/16/2017, 5:55 AM

Grazie, when my system had the Windows 10 anniversary update pushed onto it a week ago, it forced the Nvidia driver to a much newer version. That version caused my video playback / preview window (and full screen playback) to no longer work -- with just a black screen. I had to turn off GPU playback acceleration in preferences / video to get the playback functioning again. I tried manually updating the driver to the latest version (at the time) a few days ago in hope that it would fix the issue, but no luck. I then tried this latest version 378.66, but it doesn't fix the playback issue either.

Skywatcher wrote on 2/16/2017, 10:47 AM

Thanks Piotr, great info!

Jam_One wrote on 2/16/2017, 3:17 PM

Two Video Cards Emergency Checklist:

1) SLI --->>> ON !
2) Optimize GPU display performance --->>> OFF !

~ ~ ~

Automatic updates are Evil.
Either on Windows or on Android.
I thought it was obvious many years ago.

Red Prince wrote on 2/16/2017, 3:30 PM

Automatic updates are Evil.
Either on Windows or on Android.
I thought it was obvious many years ago.

It was. And still is.

He who knows does not speak; he who speaks does not know.
                    — Lao Tze in Tao Te Ching

Can you imagine the silence if everyone only said what he knows?
                    — Karel Čapek (The guy who gave us the word “robot” in R.U.R.)