No sound on rendered 5.1 surround sound files

garyrams wrote on 5/26/2016, 1:34 PM
I am using Vegas Pro 12 and I am trying to render a feature film with 5.1 surround sound. It doesn't matter what format of audio I use, after I render the film the rendered audio files have no sound.
I have 6 audio channels that I have routed through 4 buses. Each bus having a different target Bus A Front L/R, Bus B Center, Bus C Rear L/R Bus D LFE only Center.
If I just use the Master Bus (No others) then I get some sort of 5.1 surround sound but it isn't the specification what I want. All the files are the same just different sound levels depending on the position of the sound. I want just the vocals coming out of center nothing else, music out of front L/R, ambient out of rear L/R ad LFE out of center as well.
Obviously I've not done everything correctly otherwise it would be working. But my project settings are for 5.1 and my audio device allows me to pick what speakers I want the sound coming out of. So I'm assuming it's something to do with the buses. The sound levels on the buses are working when I play the project on my timeline. But when I render there is no sound.
What am I doing wrong. Thanking anyone in advance for any help.


musicvid10 wrote on 5/26/2016, 7:56 PM
For starters, the audio going to the buss(es), are discrete PCM, not encoded 5.1.
Therefore, to monitor the timeline will require six dedicated audio inputs, not a 5.1 or 7.1 decoder.
Once you've got that going, the sound from your 5.1 render will not sound like the timeline monitor.
So previewing the encoded 5.1 on my home entertainment system is a necessity, at least for me..
For 99% of uses, the timeline preview audio comes from the surround Master.
Hope that answers part of your question.
garyrams wrote on 5/27/2016, 5:02 AM
Thank you for your reply, much appreciated. I understand what you are saying and the project was created using surround sound speakers etc. At that point there were no buses other than the master. But now the distributor wants 5.1 surround sound but the music should come out of the Front L/R the voices on of the Center only and ambient/Foley rear L/R and LFE center. I thought it would simply mean creating 4 buses and directing the audio channels to the speakers through them and job done. But as stated I now don't get any sound when I render. I still get sound when I run from the time line.
Former users wrote on 5/27/2016, 2:44 PM
I just created a 5.1 project and put unique audio on each track. Then rendered to a 5.1 WAV file without using any bus sends and when I bring the WAV file back to the timeline, it appears to be a correct 5.1 render.

What audio format are you trying to render to? WAV, Dolby, DTS, etc

How are you playing back the rendered audio? What software, hardware, etc

Is your final project a file or disk? What format of file?

If you bring the WAV file (if that is what you are creating) back to a timeline, do you see the multiple tracks?


Left wave forms are original imported tracks on a 5.1 project, right waveforms are the rendered WAV file. Granted, this is a very simple project, but I don't think you need to deal with busses if you are setup for 5.1
ChristoC wrote on 5/27/2016, 4:38 PM
Upload your project .veg file (without any media) somewhere (~ Dropbox) so one of us can open it up and see the mixer setup.
Also tell us exactly the steps and format you are choosing to achieve the Render.
garyrams wrote on 6/1/2016, 2:09 PM
My apologies for the delay in replying to your post ChristoC. This is my first time using the forum and I didn't realise that I wouldn't receive a notification by email when somebody posted a message.
I have attached a dropbox link to a copy of the project file. If you would be kind enough and take a look and see if you can see where I am going wrong I would be most grateful.
garyrams wrote on 6/1/2016, 2:19 PM
My apologies for the delay in replying to your post DonaldT. This is my first time using the forum and I didn't realise that I wouldn't receive a notification by email when somebody posted a message. I have been trying to render to .wav, When I bring the rendered wav back into the timeline I get all 4 wav files just like your project but there is just nothing in the files, there are no sound waves, its just flat, thus no noise.
On your simple project in your preferences what audio device are yo using? Maybe my problem is that I'm just using Direct Sound mapper?
I don't know I'm just lost. Your rendered wav file is exactly what I'm after but for the life of me I just can't get my project to render like your example.
Former users wrote on 6/1/2016, 4:50 PM
I downloaded your veg file and although your project is 5.1, your tracks are not. If you add a new audio track, you get the 5.1 panner.

I didn't use any busses, just the 5.1 panner that shows up in the track header.
ChristoC wrote on 6/1/2016, 5:05 PM

Your problem is that the Bus channels are routed directly to your soundcard inputs, rather than to the Master channel.
When you do a Render, only the Master channel outputs are considered, but there is no signal there....

You are much better off deleting the busses and using the Surround Panners which will now appear in the Track Channels to direct the signal to the appropriate outputs in the Master Channel.
You may need to right-click on each Surround Panner to select a more appriate pan mode = "Constant Power" or "Film" are more useful; You can also select dedicated "LFE only" in the same manner.
garyrams wrote on 6/2/2016, 2:23 AM
Thank you DonaldT. The tracks were 5.1 until I removed all the audio then the panner disappeared. It would appear that what I'm trying to achieve through 5.1 isn't possible, to have just the vocals coming through center and not appearing on Front L/R or Rear L/R. Thanks for taking the time to investigate my problem, much appreciated.
garyrams wrote on 6/2/2016, 2:27 AM
Thank you ChristoC your explanation now makes perfect sense and I should have realised it was the buses causing the problem. I will do a few renders using 'Film' and 'Constant Power' but I think what I'm trying to achieve through 5.1 isn't possible - that being for example just having the vocals coming out of the center channel and not appearing on the Front or rear L/R. Thanks again for your input, really appreciate your help and time.
Former users wrote on 6/2/2016, 9:33 AM
If your voices have a clear track, you can most certainly make them come out of the center only. Just enable that output on your panner for the voice track only. If you click on the little speaker icons, that turns that output off and on.

Basically, you would turn off all speaker icons except for the center one. Do the same for each other output (If you want Front Left, turn off all but the front left)
garyrams wrote on 6/2/2016, 3:11 PM
DONALD You are a genius!! That works perfectly now, exactly what I want. Truly awesome. Thank you so much. Problem solved.
Former users wrote on 6/5/2016, 10:51 AM
Glad I could help. Enjoy!