Opening Project Takes Hours

MUTTLEY wrote on 2/7/2013, 4:37 PM

Gonna be a rough one to explain or remember each and everything I've tried so far but figured I'd post on the off chance someone has had this happen and knows a solution or any random suggestion that hasn't crossed my mind yet.

This only happens with one particular project, Vegas is running great on everything else. A fairly short one but pretty rich with effects, transitions, music, and tons of sound effects. The problem is that it hangs at 45% when opening it back up, to the point where I thought it wouldn't open ever, but if ya leave it in that hanging state long enough, 5 hours or more, eventually like magic it will fully load as if nothing ever happened.

I've tried a thousand different things already to no avail. I've loaded it on an external drive, tried on my laptop, same thing. I suspect that there is a bad piece of media and have gone to considerable lengths to try to figure which it might be. I would systematically take out portions, save under a new file name, close Vegas, re-open, would do the same thing. I have also renamed the folder that everything's in and force it to re-find all the assets, that didn't work. I converted just about every sound effect that wasn't wav to wav and replaced them in the project and that didn't work.

Now this is where it gets a little weird. I have a good number of folders organizing the tons of sound effects I have. I'm going off of memory here but if I recall correctly, I had gone through and renamed each folder one at a time and told Vegas to skip those missing bits instead of finding them. One folder I renamed and skipped Vegas popped right open. Obviously I assumed that the culprit was in that folder, however, I one by one changed the name of the individual sound effects that were in that folder, putting an X at the beginning of the name, and would re-open Vegas to try to isolate the the "corrupt" file I assume is there. When Vegas would say there's a missing file I told it to skip, it continued to stall on each and every one. Change the name of the folder their all in, opens fine, change the name of the audio files hangs forever.

I should also add that I made a new project and dragged and dropped all the literally thousands of sound effects onto the timeline, Vegas did that quick and painless, saved it and re-opened and opened without a hitch.

Right now waiting for it to open again, been over four hours. Thankfully I'm patient and not up against a deadline but sure would love to figure out what the problem is if only just to know.

- Ray
Underground Planet


larry-peter wrote on 2/7/2013, 5:14 PM
Ray, that folder you renamed and skipped - did you ever try manually replacing the audio files one by one from the renamed folder while Vegas was looking for them instead of skipping over them? It seems you could at least get quickly to the file that might be problematic. Or find something really strange like the folder name itself is problematic.
Former user wrote on 2/7/2013, 5:18 PM

One other thing to try, once you get it open do a SAVE AS with media to another folder. Then open it and you can always add new stuff or re-edit.

Dave T2
ushere wrote on 2/7/2013, 6:08 PM
+1 davet2 - good luck
PeterDuke wrote on 2/7/2013, 6:40 PM
I find that after doing a lot of pruning, a lot of redundant media is left in the project media bin. Cleaning this out speeds up project loading. One way to do this is to copy the timeline to a new instance of Vegas.

If this doesn't help then copying parts across at a time might help locate the problem media, if that is in fact what the problem is. However, you might already have done the equivalent of that.
MUTTLEY wrote on 2/7/2013, 9:02 PM

atom12, I'm pretty sure I tried that or something similar and as I said I also converted a bunch of em so they actually were new files. Oddly enough though, none of the files "seem" to be corrupted, one it does finally open it behaves just like any other project and have no problems with the renders.

Dave, that one I did do and tried opening it on the laptop to no avail, behaved the same way.

I opened the project around noon and it's still stuck at 45% now at 9pm. Not freaking out yet as I have a bit of confidence that it'll get there eventually but it sure does grovel.

- Ray
Underground Planet
Former user wrote on 2/7/2013, 9:18 PM
A couple of other suggestions, change the name of the sfx folder that seems to be causing the problem, then wheh Vegas ask to search, point it to the renamed folder. does it hang now?

In the media pool after project opens, remove all unused media.

There is obviously one file that is tying it up by either needing to be converted before it can be used or it is not a complete file (corrupted) and Vegas is fighting it's way through it trying to interpret it and eventually is moving on, not opening that corrupted file so the program runs fine after it gets through it.

I had something similar a few years ago and I think it was the folder itself that was corrupted, not just a file. So you could try creating a new folder, copying each file one by one (don't do a copy all so you don't get the corrupted aspect) and that seemed to fix it, but it has been a while so I wouldn't swear to the details.

Dave T2
JasonATL wrote on 2/7/2013, 9:42 PM
Ray - Total shot in the dark here, but I had a problem with similar symptoms and finally solved it. In my case, the problem turned out to be a card (e.g., SD or CF) reader. Anytime Vegas would try to load a project in which it had to find media, it would seem to query that "drive". With no media in the drive, it would hang. I finally solved it by disabling the card reader (it was internal to the PC) so that Windows would not assign it a drive letter.

In your case, the fact that the same thing happens on your laptop leads me to doubt that the same situation is going on. But, I thought that some laptops have card readers, so I wanted to mention it just in case.

Interestingly, this seemed to happen to me only recently, as if it had something to do with a Windows update or perhaps one of the newer versions of Vegas.

Regardless, good luck!
TheHappyFriar wrote on 2/7/2013, 9:46 PM
You bring up an interesting point with the removable drives.

Could be something was recently used on an external and it keeps looking, but it's not in the project so it eventually moves on?

It always seemed to me that when I'd use MS Office with an external drive, no matter what, until I reboot, Windows always seemed to want to access that external. Wasn't recently though could of been an old bug that was patched.
PeterDuke wrote on 2/7/2013, 11:30 PM
I sometimes get long delays if the last file transfer was from another computer on the home network and the other computer is not currently switched on. If Vegas were looking for a series of off-line files it could take a long time indeed.
musicvid10 wrote on 2/8/2013, 12:13 AM
Take a look at your system monitor while the Vegas project is loading.
Any chance it has run out of RAM with the project 45% loaded ?
larry-peter wrote on 2/8/2013, 8:39 AM
The reason I suggested renaming the folder and attempting to relink, which I believe is what DaveT2 suggested also - perhaps communicating it better than I did - is that I had the same looong load process on a project several times when opening it, and when it suddenly began opening normally again, the media replacement bug had struck.

I was wondering if perhaps Vegas' database is having some sort of issue with the folder name. When you changed the folder name and skipped the contained files, it loaded quickly, right? And if you have no problem renaming the folder, moving contents, opening in other programs, etc., I wouldn't think the folder itself is corrupted.

Edit: when you get it to load again, run Timeline Tools and see if any media names or paths have been altered, or if anything seems suspicious.
MUTTLEY wrote on 2/8/2013, 12:09 PM

During the troubleshooting day, and in general practice, I'm pretty good about clearing unused media. Regarding renaming folders I have done that however, having done the "Save As" and including all media onto an external to try it on my laptop Vegas throws everything into one folder and doesn't re-create file paths and that version did the same thing on the laptop so would think that would rule that out.

Don't have a card reader attached however I usually have two 2 Terabyte drives that are USB 3 connected, one I store projects ready to archive and the other I backup my 2 Terabyte internal. Right now have them uplugged though. First unplugged them when Windows was having a problem booting and then left them as I hadn't realized how much having them connected full time can drag on the computer at times. For instance they power down and if you open My Computer it will stall till those two fire up. That said all the files are on the internal and haven't added anything from either to the project. This started happening though before I started unplugging them unless I need them.

Not maxing out the ram or CPU, it's stuck right now at the notorious 45%, the one I tried to open yesterday was still unopened today so trying again, though a little nervous at this point. Firefox is actually eating more memory than Vegas.

I should mention that once I open Vegas and attempt to open that project, you can see all the media on the timeline, or at least the top 14 tracks which are all audio and the media all say "Building Peaks." This is where it chokes. I had gone through and deleted the sfk's at one point and re-opening but that didn't do it.

- Ray
Underground Planet

Former user wrote on 2/8/2013, 12:11 PM
Where is your temp folder for building peaks?

Dave T2
MUTTLEY wrote on 2/8/2013, 12:27 PM

Hm, doesn't it use the location of the media is in? If it goes into the folder you assign for temp files that's set to D:\Vegas Temp
When I did the purge though I searched the drive for *.sfk and deleted all of them.

- Ray
Underground Planet
larry-peter wrote on 2/8/2013, 2:04 PM
So it's actually hanging in the building peaks stage? Can you cancel the peak building process and work normally? Or does the program stall completely?
MUTTLEY wrote on 2/8/2013, 2:20 PM

Nope, stalls completely, up top left it says "Not Responding" and then out of nowhere it'll just go through ... or at least it was before, not having as much success with it today. The first time I realized it would open eventually was after a good 10 hours of trying to get it to work I assumed that when it got to the "Not Responding" that it was completely dead and would try the next attempt to fix. The last time it hit that was a good 4 in the morning and out of frustration when it got to "Not Responding" I walked away in frustration and called it a night but didn't bother to close it. Next morning I woke up and it was loaded.

- Ray
Underground Planet
ForumAdmin wrote on 2/8/2013, 2:33 PM
Ray, what is the View mode in Project Media? Is it Thumbnails? If so, please change the View mode to List or Details, then try again. Let me know if there's any change.

larry-peter wrote on 2/8/2013, 2:37 PM
Are all the files in the suspicious folder wav or aif? No format that Vegas tries to create audio proxies for? Any new versions of audio plugins installed that are used on those files? Years back I installed a updated version of Waves plugins and even though the plugins were named the same, it took Vegas a long time to load projects for the first time that had been created with the older versions. (Not hours, though. Extra 2-3 minutes on a typical :60 radio spot perhaps.)
MUTTLEY wrote on 2/8/2013, 4:42 PM
Paddy, view in Project Media is set to details.

atom, I can't say 100% since I can't open it to check but I'm pretty confidant that during my previous trouble shooting efforts that I had converted anything that wasn't a wav to a wav. As far as audio plug-ins haven't upgraded any in a good long awhile, all I have installed is iZotope Ozone 3 and RX. I don't recall doing anything on any of the sound effects or music but likely used Ozone to sweeten the audio of the talent which was recorded straight to the camera with my F3.

Don't think I mentioned yet but might note that during my long long day of trying to get this to open I did try resetting everything in Vegas as well as uninstalled and reinstalled it and other plug-ins.

I just noticed trying to open it again that as Vegas is opening there's the usual pause before the project "pops" open and the moment it says 45% and freezes is the same moment that "pop" takes place, as in the media shows up on the timeline and in the project media window though as I said previously, all the wavs on the timeline say "Building Peeks"

- Ray
Underground Planet
rmack350 wrote on 2/8/2013, 4:59 PM
"it says 45% and freezes"

This is sounding very very familiar but I can't put my finger on it.

How about this. There was a conversation a while back about each version of Vegas having its own temp folder. You might look for that thread, make sure this version of Vegas has it's own folder, and empty it before trying to restart the project.

Tom Pauncz wrote on 2/8/2013, 5:23 PM
Sounds familiar - around Vegas 9 maybe. Wasn't the problem opening certain types of video files and a backlevel .DLL fixed it?

What type are the video files in the project?

Geoff_Wood wrote on 2/8/2013, 5:58 PM
As side issue - I've had not necessarily VEGs, but things in general (install apps specifically) taking FOREVER to open on a USB memory stick. Way beyond transfer rate issues.

Geoff_Wood wrote on 2/8/2013, 6:01 PM
Um, we have looked at the possibility of a plugin problem - no, or have I missed it ?

Anything unusual in this project that you don't commonly use on others ?

TheHappyFriar wrote on 2/8/2013, 9:05 PM
I opened a semi-large project I'm working on just now and it says "building peaks" for a split second. I don't believe it's actually building the peaks, it's looking and seeing if they exist, are the up to date, and uses those if it doesn't need to do anything.