Optimization tips/tricks for editing 4k on Movie Studio 16 Platinum ?

GoodEnough wrote on 10/14/2020, 8:45 PM

Editing a 45 min file from a GoPro. 4k at 30fps.

The build proxy took a lot longer than 1080p. Normal? Like 20 mins for only 45 mins of footage.
Next time, I will delete the LRV files before adding the files to the project.

To save disk space, I lower the bitrate down to 10,000,000

While editing, I have the preview on "Full", which I like.
Is there an optimal setting?

Should/can I turn off the preview while rendering for speeding up?

I also enabled my GPU by selecting Options->Preferences-> Video tab -> GPU Acceleration of video processing

Are there any tricks to making things faster?

 

 

Comments

FayFen wrote on 10/15/2020, 5:39 AM

"The build proxy took a lot longer than 1080p. Normal?"

Maybe because 4k is 4times larger than 1080???

If you need proxy for your 1080, than maybe your system isn't enough to begin with?

GoodEnough wrote on 10/15/2020, 3:51 PM

I have a fast 6-core CPU, decent GPU, and 32GB RAM

Vegas just builds the peaks automatically, when I add the video to the project.

For 1080, it just takes a few seconds.

Should I turn that off? How?

 

 

j-v wrote on 10/15/2020, 5:14 PM

Editing a 45 min file from a GoPro. 4k at 30fps.

The build proxy took a lot longer than 1080p. Normal?

It should not be needed for hardware that meets the specs for the program to use proxies for FHD, maybe a little for UHD or 4K.
When using proxies anyhow the Help files say also that this is only possible when using one of the Preview options

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.38 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

EricLNZ wrote on 10/15/2020, 6:16 PM

Vegas just builds the peaks automatically, when I add the video to the project.

I wonder if you are actually building proxy files? Are you sure it's not the audio waveform files you are referring to. They are almost instantaneous.

GoodEnough wrote on 10/15/2020, 8:12 PM

You're right ! I just added a 2.7k video file and it was "building peaks" for audio.

11 min file took like 30 seconds.

So, it seems it only builds proxy files for 4k ?

j-v wrote on 10/16/2020, 4:24 AM

So, it seems it only builds proxy files for 4k ?

Yess, but only if you select this option yourself:

 

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.38 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

GoodEnough wrote on 10/16/2020, 11:28 PM

Yes, I have that selected. So, it only makes proxies for 4k.

Who/when/why do you actually need proxies for 4k?

GoodEnough wrote on 10/16/2020, 11:29 PM

If you have preview lag, then you need proxy?

If your hardware is strong, and preview is fine, then you don't need Proxy?

GoodEnough wrote on 10/17/2020, 9:16 AM

I turned off "automatically create Proxy for HD media"

I created a new project, added the 4k video, and tried to edit it.

No issues with lagging and the edit process is fine.

So, it looks like my CPU does not even need proxy files to edit 4k smoothly.

Will keep the setting off.

j-v wrote on 10/17/2020, 9:25 AM

I turned off "automatically create Proxy for HD media"

@GoodEnough
Where did you find that option?

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.38 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

GoodEnough wrote on 10/17/2020, 11:18 AM

I turned off "automatically create Proxy for HD media"

@GoodEnough
Where did you find that option?

Options

Preference

Video

 

j-v wrote on 10/17/2020, 12:27 PM

Than you see more than I do, I only see it for Ultra HD

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.38 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!