OT: Discovered why I lose the AC3 file icon

FTech wrote on 5/2/2007, 10:27 AM
Hello,

For those who have been using Vegas, Acid, Sound Forge, etc may have noticed that you lose that icon graphic associated with AC3 files.

I used Ashampoo Uninstaller, an installation checker, that shows any changes to your system drive, registry, etc. To my amazement, I updated to Vegas 7.0e and it deleted this key:

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ac3]
@="AC3"
"Content Type"="audio/ac3"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ac3\AC3]

Now whenever I check my AC3 files, it shows a DEFAULT windows icon beside it. What did I do to remedy this? I restored this key back into my registry. Voila, I got my AC3 icon back. I noticed this phenomenon happening EVERY TIME whenever I update my Sony software programs. I'm not sure if anyone has been experiencing this but it's quite annoying.

Hopefully the software engineers can rectify this bug in forthcoming releases or software updates.

Thanks


CPU: AMD Ryzen 9 3900x 12 Core @ 3.8Ghz (non-overclocked, PBO enabled) OS: Windows 10 Pro 64-bit (version 20H2) RAM: G.Skill TridentZ Neo 32GB DDR4 @ 3600Mhz (16-16-16-32) @ 1.35v (Tightened timings via DRAM Calculator) Graphics Card: Zotac GeForce GTX 1660 6GB GDDR5 (studio driver v456.71) Sound Card: Sound Blaster Z (driver v6.0.102.74 dated Nov 6, 2020) Storage: Samsung 970 EVO Plus M.2 1TB; Seagate Baracuda 6TB (System Managed Swap File) Mobo: ASUS ROG STRIX X570-F GAMING (bios 2608) PSU: Corsair RM850x Blu-Ray Burner: Asus BW-16D1HT 16x (firmware 3.10) Case: Fractal Design Define R6 w/USB-C

Windows configured to use the AMD Ryzen Balanced Power Plan