OT: Loss of firewire

bjtap wrote on 11/19/2004, 8:55 PM
I had my computer in for some minor work at Data Doctors and when I got back discovered my firewire devices are not working (recoginized)
1) Two different devices on two different firewire inputs stopped working. One on my sound card, the other on the mobo.
2) The external DVD burner does work when switched to USB.
3) My digital camcorder does not work (recoginized) at all.
4) Hardware devices sees both firewire ports.
5) Windows XP Pro SP 1 (NOT 2)
6) Both devices worked fine before.
Previously this problem occured when XP Pro disc would not install avicap32.dll. I reinstalled this anyway.
Any ideas on what to check? BIOS settings? Other Files? Thanks in advance.


johnmeyer wrote on 11/20/2004, 9:40 AM
Look in the control panel, the system applet and look for the device list in the hardware section. There should be no yellow or red icons next to any devices.
bjtap wrote on 11/20/2004, 12:09 PM
Thanks for the reply. There are absolutely no yellow or red icons to any devices showing in the Device Manager. Both my 1394 IEEE devices show just fine. (OHCI and VIA OHCI).
I also checked the BIOS and the device is enabled on the MOBO... just as one would expect if the Device Manager sees it. I have also tried reinstalling the 'drivers' for both these devices.
nickle wrote on 11/20/2004, 6:02 PM
What kind of minor work was it in for?
Did they get inside the case?
bjtap wrote on 11/20/2004, 6:16 PM
Thanks for the reply. They were moving around and connecting hard drives and dvd players. Problem is, I have no way to prove that Data Doctors did it. My BIOS shows the IEEE enabled, the Device Manager shows no problem with either IEEE device and uninstalling and reinstalling the drivers makes no difference. The avicap.dll(s) are still okay.
If you have any ideas please throw them out at me. Sites to look at, people who might have a clue. I have been searching Microsoft's site but could not find specific enough info.... but then again their 'knowledge base' is so huge who knows if I searched the exact right words.
nickle wrote on 11/20/2004, 6:37 PM
It sounds like a mess. Obviously they changed something somewhere.

Try clicking start/run/type msinfo32 and click OK and when the System information box comes up click on hardware resources "+" to open it and click the various headings.
Under DMA make sure all items have OK in the last column.
Same for I/O IRQs and memory.

Look at forced hardware.

bjtap wrote on 11/20/2004, 7:30 PM
Again I thank you for being there. I followed your instructions and saw nothing but "ok" after each listing in all columns. There is no forced hardware.
If nothing else you certainly taught me a great new command.
If you have anymore ideas please share.
Sites to visit? People to contact? (I spent 2 hours checking Microsoft's site but to no avail.)
nickle wrote on 11/20/2004, 7:43 PM
I don't know of anyone to contact because the problem is too evasive.

Something changed when you took the PC in for repairs, anything from them changing jumpers to stepping on the motherboard, or who knows what.

The problem is to figure out what has changed.

If your firewire is recognized by windows, it is a good thing.

What happens when you try to capture? Does Vegas say there is no device? In the capture window, under "video" does it list "Microsoft DV camera and vcr" when your camera is plugged in and set to vcr

Could the cable be broken now or the camera plugin?

You have a couple of options though.

Turn off the computer and remove all the cables except keyboard, monitor, mouse and firewire.

Then fire it up and try a capture. Make sure your camera is set properly.
bjtap wrote on 11/21/2004, 6:30 AM
Thanks again. With Vegas the message is "Please Connect A Device" and under video is 'No capture device'.
I use Scenalyzer Live for capture and it says"Connect your Camera/VCR and select a capture device to be used". Above that the message "not available:Microsoft DV Camera and VCR"
I get similar messages with Premiere 6.5, Pinnacles LE and with Windows Movie Maker the program just froze and futher attempts to open the program leads to immediate shut down of the program.
Your comment about make sure your camera is set properly is well taken because a couple of times I set it to Camera and not VCR... this is not the case this time.
I am considering removing the sound card where one of the firewire inputs is located but that does not seem likely since both firewires died simultaneously. I doubt it is the cable because that would mean two different cables went bad at the same time... very unlikely. I also did switch cables around.
Let it be said I appreciate your time and effort here!
nickle wrote on 11/21/2004, 9:55 AM
By all means remove the sound card. I think johnmeyer solved a similar problem by disabling his ATI firewire card.

It is far easier to start at the beginning by a fresh install of windows and letting it install all the devices than to work backwards and try to locate what went wrong.

But after removing the sound card and trying again, the only thing else is to remove the firewire card and reboot so windows knows it is gone and then replace it (in a different slot) and let windows detect it again.
nickle wrote on 11/21/2004, 12:32 PM
Another thought

Have your Windows install cd in the drive

click "start/run type scf /scannow click OK" Windows will scan for missing or corrupted system files and replace them with new ones from the cd.
Spot|DSE wrote on 11/21/2004, 12:38 PM
I've not read the entire thread. Have you tried removing the card in the Control Panel and then letting windows seek it out?
Sure you've got a good cable? Sure they didn't kill your Firewire card? Sure the slot is good?
Card isn't disabled in Control Panel? You've got 1394 Network shut down in your Networking properties?
bjtap wrote on 11/21/2004, 4:04 PM
I already ran the scannow. Thanks

I've not read the entire thread. Have you tried removing the card in the Control Panel and then letting windows seek it out?
Yes, I have. The fact stands two separate firewires 'died' simultanously, one on sound card and other on mobo. (Yes, the latter is enabled in BIOS).

Sure you've got a good cable?
Sure they didn't kill your Firewire card? Same as before, 2 different firewires at the same time. The soundcard still works... at least I get sound from it. Two different cables going at the same time?

Sure the slot is good?
Same slot as been in for a year, plus again... 2 at the same time?

Card isn't disabled in Control Panel?
Do you mean Hardware Devices? Both firewires show there and I have uninstalled and reinstalled the drivers. No yellow or red icons have appeared in any of my hardware devices. (I even tried update drivers but it uses those found in XP Pro.)

You've got 1394 Network shut down in your Networking properties?
Spot: This one I may need further explanation. How do I check and change these 'networking' properties? Are you refering to Control Panel -> Networking Connections? When I check the status of my two 1394 connections icons they both show "connected." They both say device working properly.

The last time I had this was because Windows did not install the avicap32.dll but it is there now.

To all those trying to help, again I thank you all and look forward to more ideas.
nickle wrote on 11/21/2004, 4:16 PM
Maybe we need more information about what the Data Doctors did other than move things around.

What exactly did they do?
bjtap wrote on 11/21/2004, 6:24 PM
I have an email into Data Doctors and am hoping for a reply. This is what I saw and know they did.
1) Took hard drive that was internal and put into external case.
2) Hooked up a 2nd internal DVD machine... a player to go with burner.
3) In an attempt to get more memory they removed my video card, not the audio card where the firewire is.
Beyond that I am not sure. They may have installed drivers for the external hard drive. I have since removed that hard drive from it's external case and reinstalled it internally. In order to do this I 'pulled' the plug on the DVD player. I did see them in the BIOS once and have asked in my email what they did there. I have checked and seen that the mobo firewire is enabled. I made a change AFTER the firewires stopped functioning... I disabled the auto virus protection within the BIOS.
Again I thank you nickle!
nickle wrote on 11/21/2004, 6:48 PM
OK Barry

Was the hard drive firewire or usb when they made it external? If it was firewire and working that would be important.

When you say they removed the video card, was that just removing it to access the memory slots or did they replace it with one with more memory in it?

Disabling bios antivirus is OK.

All you need is a ribbon cable with 2 plugins and make your dvd burner a master and dvd player a slave to run them both off of the secondary ide.

I don't know why they would be in the bios at this point.

There is a setting in the cmos to change it to failsafe which will change everything to it's default settings regardless of who changed what.

bjtap wrote on 11/22/2004, 6:26 AM
You have been great and thank you.

The hard drive was an internal ata. They switched it to a usb external case. I switched it back.

The video card was removed to access the memory slot.

I had Data Doctors handle it because the original builder tied and fastened the wires extremely tightly to the case. I did not want to risk cutting or ruining the wires. I was not concerned about how, it was the risk I would take.

I am not sure why they were in the bios either, unless when they hooked up the external hard drive the bios automatically came up.
If you can give me more info on where to find that cmos setting to change to failsafe I would appreciate it. Sounds like it is worth a try.

nickle wrote on 11/22/2004, 9:19 AM

They probably went into the bios to check if the hard drive was detected properly.

Depending on the bios manufacturer the failsafe may be different, on mine it is the f5 key, but usually when you first enter the bios settings there will be a listing of what keys do what.
ie f1 for help f5 for defaults etc.
Ususally the defaults or OK but sometimes it isn't optimal and the builder may have had a reason to set it a certain way.

One thing is that most default to "no" for plug and play operating system which you should try setting to "yes" to allow windows to control your devices.

Spot's reference to turning off the networking - just right click "My network places" and where you see your 1394 connection, right click and disable it.

Mine is still enabled and work fine but it may make a difference.

Have you been reading the other post regarding "firewire problems"

If not check out the thread "Vegas 4 Video capture problems" by roncc, there is lots of good advice in there from craftech and SonyTSW that may apply.

It seems like your firewire is working but not the camera and I can't see anything that Data Doctors did that would cause it.

You did follow my suggestion of unplugging everthing other than keyboard, monitor, mouse and firewire didn't you?

I have seen a case where a cat bit through a usb printer cable which caused windows to hang and not find a ps/2 keyboard and another where dead batteries in a connected usb camera caused a PC not to boot.
Sometimes these things defy logic.
bjtap wrote on 11/23/2004, 6:51 AM
Last night I moved the sound card (with the firewire port) to another slot. On reboot the computer 'found' all the audio drivers and firewire drivers including the one on the mobo. Problem NOT solved. Windows continues to see them but none of my 4-5 programs do.
Since I really can't believe that in a coincidence two different devices went bad at the same time (one of which still works on USB) and since I find it hard to accept that two different cables went bad with them, and since moving the sound card actually also found the mobo firewire, I have decided to just plain remove the sound card from the system and see if the mobo firewire works. If that does not work I will put the sound card back in and disconnect the firewire cables from the mobo to see if that does it.
Data Doctors only went into the BIOS to make sure the external hard drive was being seen by the system.
I am also looking into new mobos since I already know the mobo I have has memory slot problems.
If you or others have other ideas I will be very appreciative, as I have been.
nickle wrote on 11/23/2004, 10:50 AM

The problem is likely some simple thing that is being overlooked.

I have never met a PC that I couldn't fix one way or another if I have it in my possession. (no don't ship it to me)

Sometimes it is just seeing what is happening that leads to a solution.

Your firewire cards are being recognized.

Your programs won't see anything until you turn your camera on and the programs get a signal from the camera, through the firewire card and cable and then through the pci bus and cpu and ram etc. and a series of drivers and instructions for the software to function.

Somewhere in all that lies the problem.

As has been suggested, open device manager, watch the imaging devices and turn on your camera on and see if it appears. If it doesn't you are still at square 1.

After trying all the various suggestions and not getting it to work then eliminating as much crap as possible is the most straightforward solution.

Such as a fresh install of Windows with only 1 firewire port, then Vegas, then try a capture.

That is the easiest because if it doesn't work, there is less troubleshooting involved

But it is the last thing most people want to do because of loss of data, and email and settings and finding all the driver disks and properly setting everything up.

Sometimes it is the quickest and most successful way.

Then you add your other devices and software and make sure everything keeps working.