Jay Gladwell wrote on 3/5/2008, 5:42 AM

Since the Search function still isn't working...

A few years have passed since I originally set up my Vegas 5.1 system with
the M-Audio Delta 410 card (proper driver is installed) along with the M-Audio Studiophile LX4 5.1.

Now, after my upgrade, I can't seem to get it right. The channels aren't working correctly. Front R & L are fine. The LFE channel is fine. The SL channel comes out of the center speaker and vice versa (yes, I checked the connections, even though they weren't fiddled with during the upgrade), and the SR is totally silent.

I'm sure I don't have the control panel set up correctly. If anyone has this system, and would be willing to lend me hand, I certainly would appreciate it.



JohnnyRoy wrote on 3/5/2008, 8:25 AM
I don't have the Delta 410, I have the Firewire 410 but the outputs are assigned in the Vegas preferences. Under Options | Preferences | Audio Device I have the Default stereo and front playback device: set to output channels 1 & 2, the Default rear playback device: set to 3 & 4 and the Default center and LFE playback device: set to 5 & 6. Then I just physically plugged the respective speakers into those outputs on the FW-40. Something similar should work for you.

Jay Gladwell wrote on 3/5/2008, 2:18 PM

Yeah, you'd think that would be the case, but it isn't working that easily.


In Vegas audio device type, just switched from M-Audio Delta ASIO to Direct Sound Surround mapper. That did it!


Jay Gladwell wrote on 3/5/2008, 2:29 PM

Oops... now the stereo doesn't work! All I get is the left channel.

JohnnyRoy wrote on 3/5/2008, 2:32 PM
You should be using the M-Audio Delta ASIO driver. If you have all of the outputs mapped correctly then maybe it's the mixer application that comes with the Delta 410. Check that and make sure you didn't reroute or mute any outputs.

Jay Gladwell wrote on 3/5/2008, 2:39 PM

When I use the ASIO driver, that's when things get messed up. There does not appear to be anything rerouted or muted in the control panel.

Jay Gladwell wrote on 3/5/2008, 2:45 PM

Going back to the Direct Sound Surround everything seems to work now, even the stereo.

Wonder why the ASIO isn't working? I'm sure that's what I used previously.

Jay Gladwell wrote on 3/5/2008, 4:15 PM

Did a test with pink noise in each channel--left, right, center, s-left, and s-right. Then burned a DVD. It worked until it got to the s-left and s-right speakers. They played together, instead of one at a time.

Any ideas anyone?

fldave wrote on 3/5/2008, 5:08 PM
I don't think you stated exactly what you upgraded? Machine, internal component, operating system, Vegas version?

MyST wrote on 3/5/2008, 5:41 PM
Have you tried re-downloading and installing the latest driver? Maybe it got corrupted during download.
MRe wrote on 3/6/2008, 12:59 AM
May be a long shot but do you have (or have you had) any other ASIO-driver (or ASIO-capable device) in your computer?

I quite recently switched from M-Audio Revolution 5.1 to MOTU and before I was able to use MOTU ASIO, I was required to uninstall M-Audio drivers. The problem was that uninstall still left ASIO-drivers there for some reason (may be because I first removed the card and after that uninstalled the drivers) and I was forced to clean the registry manually.

And also one thing: if you have already an existing 5.1-project the channel assignments do not (always?) follow the preferences. Check the channel assignments from master volume bus also.
Jay Gladwell wrote on 3/6/2008, 4:27 AM

Dave, I upgraded the MB, CPU, video card, and memory. All else is the same as before.

Jay Gladwell wrote on 3/6/2008, 4:28 AM

MyST, yes I downloaded new drivers.

Jay Gladwell wrote on 3/6/2008, 4:31 AM

MRe, no, never had any other ASIO drivers other than M-Audio.

Will check the channel assignments, too.

Jay Gladwell wrote on 3/6/2008, 6:57 AM

All else seems to be fine. Still, there is no sound coming from the S-R speaker, just a low rumble.

Last night I got down on the floor and checked all connections, even tried various combinations. For some reason, the S-R is not working properly.

I'm at a loss. Is it an M-Audio or a Vegas issue?

fldave wrote on 3/6/2008, 7:39 AM
When you said you use Direct Sound, does that channel work? If so, then it is not mechanical, it clearly is a driver issue.

I assume with all of that you also reinstalled the Operating System? I thought with a MB changeout, the OS needed to be reinstalled? Maybe at least repaired?
Jay Gladwell wrote on 3/6/2008, 9:02 AM

Yes, the OS was a fresh reinstall.

Last night when using Direct Sound it worked in Vegas, but the test DVD I burned didn't work on all channels (both surround rear channels).

The VU meters in 5.1 indicate the proper channels.

MRe wrote on 3/6/2008, 10:02 AM
There has been numerous problems with VP8 5.1 support.

To my understanding if you render audio, it does not use/rely on your audio card (as it does not care your display card or display settings while rendering the picture).
Jay Gladwell wrote on 3/6/2008, 10:54 AM

I've got VP8, but not installed. I'm still using version 5.

Looks like I may have to ditch 5.1.

fldave wrote on 3/6/2008, 11:11 AM
Did you install XP or Vista? I kind of doubt that Vegas 5 will work properly on Vista.

I may be wrong.
Jay Gladwell wrote on 3/6/2008, 11:25 AM

XP Pro.

Everything else is working just fine.

psg wrote on 3/10/2008, 2:08 PM

You may have tried this already, but when I installed a new motherboard, it had on-board audio and tried to load the audio drivers, which conflicted with my Maudio Firewire 410. I disabled the onboard audio hardware in the BIOS which was enabled by default.

Jay Gladwell wrote on 3/10/2008, 4:38 PM

Thanks, Peter, I'll take a look at that!

Jay Gladwell wrote on 3/11/2008, 6:46 AM

Peter, I checked it and the onboard audio was disabled.

Cameron at M-Audio, after running some tests (don't ask), determined that I may have shorted something out on the sound card when I installed it. I may have.

After installing the card, I realized I had turned off the computer, but I neglected to disconnect the power (the little green light on the MB was still on), so it apparently had some adverse effect.

Now I'm looking at the Delta 1010LT.