Pitch and stretch glitchy in Vegas9, but not 8.

flyerstl wrote on 1/11/2010, 10:15 AM
Since upgrading from Vegas8 to 9, I've noticed that when doing pitch change to a cue, or time stretching/compressing on a cue, that it's glitchy with just a little change. In version 8, I could pitch -200cents and not hear any glitches. I could time compress 3-5 percent (on voiceover) before hearing any significant glitchiness. But in 9, even 1% time compression, or -50 cents pitch change causes significant audible glitches. I've checked settings, made sure everything (that I found) is the same in 9, as was in 8, and even clicked the box in setups for high quality resampling, but no luck. Any comments on this?

Thx.

jmm in STL

jmm in stl

Windows10 with Vegas 11 Pro (most recent build). Intel Core i7-3770 @ 3.40GHz 3.90 GHz, 32GB ram, separate audio and video disks. Also Vegas 17 Pro on same system. GPU: NVDIA GeForce RTX 2060 SUPER. Dynamic RAM preview=OFF.

Comments

flyerstl wrote on 1/21/2010, 1:53 PM
I'm really stumped here. The sound card settings are the same, everything appears to be the same, but still, it's different. Anybody? Anybody? SonyPCH, can you offer any advice here?

Thanks

jmm in STL

jmm in stl

Windows10 with Vegas 11 Pro (most recent build). Intel Core i7-3770 @ 3.40GHz 3.90 GHz, 32GB ram, separate audio and video disks. Also Vegas 17 Pro on same system. GPU: NVDIA GeForce RTX 2060 SUPER. Dynamic RAM preview=OFF.

Geoff_Wood wrote on 1/24/2010, 1:10 PM
As not happening for me, can't really help. DId you log the fault 'officially' ?

geoff
flyerstl wrote on 1/25/2010, 8:57 AM
I am not sure how to do that, but I will look around and see how to do it. Thx.

jmm in STL

jmm in stl

Windows10 with Vegas 11 Pro (most recent build). Intel Core i7-3770 @ 3.40GHz 3.90 GHz, 32GB ram, separate audio and video disks. Also Vegas 17 Pro on same system. GPU: NVDIA GeForce RTX 2060 SUPER. Dynamic RAM preview=OFF.

flyerstl wrote on 1/25/2010, 1:56 PM
So I have an update:

I found that the pitch change and stretching properties drop down box, located under a CLIP's properties was set to "NONE". In Vegas 8.0, it was normally set to "classic", and this was evidently the normal setting. So in Vegas 9.0, you have to choose "Classic" or "elastique" in the drop down menu. Problem solved. (BTW the elastique is MUCH better than the 'classic'. This is awesome). BUT...the caveat: it appears at first glance that I would need to do this for every single clip. I cannot select all clips, for instance, no a track and changed their method to 'classic' or 'elastique'. There must be a way to make this standard for all clips....hmmmm.....still looking.

jmm in STL

jmm in stl

Windows10 with Vegas 11 Pro (most recent build). Intel Core i7-3770 @ 3.40GHz 3.90 GHz, 32GB ram, separate audio and video disks. Also Vegas 17 Pro on same system. GPU: NVDIA GeForce RTX 2060 SUPER. Dynamic RAM preview=OFF.

pwppch wrote on 1/27/2010, 8:17 AM
When an event's audio clip has None as its stretch property, this means that no stretching/pitching is being applied. Only when you see classic or elastique are you actually telling Vegas to stretch the audio.

So, yes, the default is NONE for media on the time line since by default events are not stretched.

Yes, you will have to do this for each clip since you have to stretch the clip in order for the stretch mode to be applied.. There is no default to select elastique globally. I will makes sure this is considered for a future version/update of Vegas.

Peter
SonyMLogan wrote on 1/27/2010, 3:37 PM
While testing stretch properties I discovered an issue with the Audio Event Properties Dialog:

If you open up the Audio Event Properties Dialog for a un-stretched event and click "OK" it seems to mess up the stretch settings. If you then stretch the event the waveform stretched properly, but what you hear is a looped version of the file at the original tempo. Likewise, if you then go and set the stretch to "NONE" after this point, the audio will now play stretched, but the waveform draws looped.

The only workaround I have identified is to undo the project back to the point before the Event Properties were changed.

I have already added this to our bug database.
JohanAlthoff wrote on 1/28/2010, 7:28 AM
Peter, could you tack on a request to make these properties scriptable as well? I believe we've discussed this earlier, just wanted to toss in a friendly reminder.
SonyMLogan wrote on 1/28/2010, 3:26 PM
Johan,

I have added your request to the list. Thanks for pointing this out!
flyerstl wrote on 1/29/2010, 3:31 PM
Peter:

Thanks for taking a look. My 'workaround' for now is to place a cue/clip in the timeline which is unedited: for instance, I used the stretch and pitch quite often on voiceover for matching takes. Then, I begin my editing, splitting it into many different smaller clips. If I choose "elastique" or "Classic" in the stretch method box BEFORE i being any editing, then all subsequently edited clips will have the same stretch properties. But..any new clips added to the timeline from other files will of course be normalled back to "NONE". In Vegas8 and earlier versions, the stretching properties appeared to be normalled to 'classic" (since elastique didn't exist).

Being able to set a systemwide/project time stretch/pitch shift/Method would be helpful to me. Dunno if it would for others.

Thx.

jmm in STL

jmm in stl

Windows10 with Vegas 11 Pro (most recent build). Intel Core i7-3770 @ 3.40GHz 3.90 GHz, 32GB ram, separate audio and video disks. Also Vegas 17 Pro on same system. GPU: NVDIA GeForce RTX 2060 SUPER. Dynamic RAM preview=OFF.