Possible bug, no Alpha Channel Renders in V11????

i am erikd wrote on 1/11/2012, 9:45 AM
I feel pretty confident I am wrong about this but here is what is happening. I am using V11 to create some text effects using the New Blue Titler. I clearly have 32bit graphics on my Vegas timeline before rendering. (I can see the checkerboard alpha on each event.)

I have tried rendering to both Lagarith and Huffy RGBA and neither will give me an avi that includes the alpha channel. I am stumped as to what is happening and am wondering if anyone can repro this. (I think I will try a Quicktime next)


Edit: I was able to render a Quicktime with alpha channel but there is something really wrong with the aspect settings. I have set everything to match my property settings exactly but the rendered video is squeezed in from the sides regardless. This looks like a bug for sure.


R0cky wrote on 1/11/2012, 11:06 AM
I am getting the same problem in V.10. I know that both used to work and now they don't.

Lagarith and Huffy both.

i am erikd wrote on 1/11/2012, 1:09 PM
Thanks Rocky for confirming on your end. Didn't know that it was an issue in 10 also. Can someone else confirm this please?
malowz wrote on 1/11/2012, 1:35 PM
and if rendering on uncompressed + alpha?
R0cky wrote on 1/11/2012, 1:39 PM
uncompressed works in V.10. The info on this forum is that Avid DNxHD also supports alpha. I've resisted that because anything in a mov container seems to be buggy though others are having good results with the Avid codec.
i am erikd wrote on 1/11/2012, 1:52 PM
The Avid DNxHD codec I also tried to render in V11 and could not get the alpha channel. I did not try any uncompressed options yet in V11. Are you saying that uncompressed will render the alpha channel in V11?

larry-peter wrote on 1/11/2012, 3:02 PM
I did some tests and it's quite angering. DNxHD will no longer render alpha channels in either 10 or 11/511 for me. Even more angering is that I now find that my preferred format for moving alpha containing material - Matrox Mpeg2 i-frame+alpha - will ALSO no longer render in either 10 or 11. Just get an error message.

Rendering alpha with uncompressed AVI still works fine for me in V 10 & 11, as does QT Animation codec at 32bpp.

This is another unexcusable instance of 11 BREAKING my working version 10. Sony MPEG4 won't render in 10 since I installed 11 and now my alpha options are being drastically reduced.

Fix this quickly, please. And the fix should repair our old versions too. Just disgusting.
malowz wrote on 1/11/2012, 3:34 PM
@i am erikd

just try rendering to uncompressed + alpha and see if it works.
dxdy wrote on 1/11/2012, 5:15 PM
The DNxHD alpha channel doesn't work for me in 11/511 either. The only one I could make work from VP11 was QT with PNG.
i am erikd wrote on 1/12/2012, 3:49 AM
Well, it seems it might be official now that V11 can only render alpha channel in uncompressed formats. I finally noticed the little tick box near the bottom of the render dialogue that asks if you want to render alpha channel or not. It states next to the tick box that this is for "uncompressed formats only".

How exciting to have render huge/mega file sizes to get our alpha channel files. Not to mention slower renders. Another step back for V11 in my book.

larry-peter wrote on 1/12/2012, 8:41 AM

At least in my case I was able to get QT/Animation to render alpha properly. Set it to 32 bpp. I didn't try the QT/PNG suggested above because truthfully, I forgot about it. So there may be two compressed alternatives, but not ideal ones. QT/Animation has always produced acceptable quality to me when I've had to use it.

i am erikd wrote on 1/12/2012, 1:30 PM
Thanks Larry. I'll give the QT animation setting a try. I've used this in the past with success also but I don't remember it having significantly smaller file sizes. Still, at least there is one other option at least until the next build of V11 comes out.