Possibly useful observation... Frame boundaries...

cybercom wrote on 5/2/2012, 10:56 PM
I've noticed that the timeline is very fluid and forgiving at the boundaries between two clips. Frames do not necessarily line up with and/or connect to each other exactly at the framelines, e.g., the clip ending at 00:10:13 may actually end 1/2 frame early and the frame starting at 00:10:14 may actually start almost a complete frame late. Vegas just seems to ignore this and shows video continuously. Since we don't usually drill down to that level of detail when editing, these holes would be easily missed.

I wonder if this might be the cause of some of the "Black Frame" issues?

< ")????><<


rmack350 wrote on 5/2/2012, 11:31 PM
This is sounding very familiar but I think the conversation was had 5 or 6 years ago. Maybe I can find it...

Well, I found a similar conversation from 2003. It also mentioned black frames a bit.


cybercom wrote on 5/3/2012, 7:54 AM

Following a link in the thread you indicated shows that this situation was reported 10 years ago in "VV3."

I'm speechless...

< *)###><
TheHappyFriar wrote on 5/3/2012, 1:18 PM
I remember this too. I never noticed blacks between my videos though (if they're butt right up next to eachother) when rendered. I DID notice blacks in preview because 1/2 a field would be missing sometimes.
rmack350 wrote on 5/3/2012, 2:35 PM
I'm speechless...

Set Vegas' compatiblity mode to Windows95 and you'll be okay. ;-)

Seriously, it gets hard to follow these threads that far back, but I think that people were having troubles with black frames and randomly replaced frames way back then. I don't remember entire clips being replaced, though.

And that doesn't make the observation any less important.

Former user wrote on 5/3/2012, 2:45 PM
Do you have Quantize to Frame turned on?

It will show a RED bar if the frame does not line up correctly. You have to enable this under VIEW>Video Event Edge Edit Frames.

Dave T2
riredale wrote on 5/3/2012, 6:03 PM
Wow, a trip in the WayBack Machine to 2003 and Vegas3! Nine years of my life working with this software!

It was fun to see ol' BillyBoy as one of the commenters. I recall he later had a bit of a tangle with others on this forum.
John_Cline wrote on 5/3/2012, 6:15 PM
"Bit of a tangle" is an understatement.

Regarding "Quantize to Frames", I can't think of any reason to ever turn this off. Video must be quantized and Vegas now allows you to slip the audio anywhere you want.
cybercom wrote on 5/3/2012, 7:33 PM
I don't see any red line with quantize on or off.
I'm looking at the connection between two clips that is happening between 00:10:37:29 and 00:10:38:00.

There are 16 divisions (tick marks) between the two frame markers (dotted lines) and the two clips are joined at 00:10:37:29 +9 and 3/4 ticks.

Since I know this cannot be, I'm wondering what the mechanism is in Vegas that thinks this is legal video.

I was once given EDL's from an FCP editor and was having constant crashes after the footage was on the timeline. Discovered that "black" on the FCP timeline was not actually anything so the EDL put nothing on the timeline and that was causing the problem. Once all the fades and dissolves had an actual black video, or tif file to work with, the problem disappeared.

That said, how do I force video events on the timeline in this project to line up exactly to frame boundaries without totally destroying my edit.
And how do I ensure that new projects are forced to comply?

Does "Quantize to Frames" make this happen? I am totally file-based. Nothing is ever captured from tape so I don't know how things could get out of a specific frame length to begin with.

Looks to me like Vegas' audio editing background is showing through the thin veneer of an NLE!

< *)%%%><(

@mack350: "windows95 compatibility mode" ROFLOL!!!
TheHappyFriar wrote on 5/3/2012, 9:07 PM
Vegas doesn't really care if the video's any special way as long as it can read it. It can go down to a sample level so, if Vegas supports 96khz audio on the TL then you can zoom down (I think) to the sample level. That's detailed. What is that, 96,000 tic marks in a second? So a frame could be that small. :)
cybercom wrote on 5/3/2012, 11:40 PM

So what happens when video is being rendered? If I have a cross dissolve between two clips as listed above, you're saying that Vegas can dissolve in the middle of a frame???

When does vertical retrace start?

A frame is a frame is a frame - I think. I mean we spend a lot of money for tri-level sync generators and black burst generators and timed switchers just so there are no "glitches." And then we delay audio so it syncs.

I just checked in Premiere Pro CS5.5, and you cannot place the current time indicator (cursor) anywhere but at a frame boundary. Play, Stop, FF, REW, Scrub, the cursor always stops at a frame boundary.

< *)???><
TheHappyFriar wrote on 5/4/2012, 6:07 AM
If you're using a clip @ 30fps and you have a clip that's 60fps, that's two frames on the second clip for each frame on the first. You could have one frame (on the second clip) that is in the middle of a frame on the first. If you're project is @ 60fps then you would have a dissolve starting at the middle of a frame on the first clip. If your project is @ 30fps then the image at the start of the frame is what's displayed.

I don't know when the vertical retrace starts, I don't know, I just remember seeing the preview being black but it not effecting the output.

A frame is a frame but it's not a time unit. A frame is one image in video, it can be any length. I just did a test with a 29.97 interlaced piece of footage. Setting the TL to double NTSC (59.940) & the TL at 29.97 NTSC, you have two frames of video per every frame on the timeline. A sample is even smaller and audio can be mixed with greater detail (time wise) then video. I'm sure Premiere can do this too if you change the TL scale or check an option (like Vegas has) to ignore frame boundaries.

EDIT: there's a TL option for samples and it's based on the sample rate of the project. The smallest the TL will go is where one arrow key = 1/6th of a 196khz sample.
Former user wrote on 5/4/2012, 7:21 AM

I am not quite sure what you are saying about frames being any length. A frame yes indeed is just a frame, but a frame in interlaced video is made up of two fields. when you change your 29.97 video to a 59.97 rate, you are seeing both fields.

IF a frame is in a 29.97 project, then it lasts 1/30th of a second~ . You can only edit on frame boundaries. When Vegas does show a frame in between boundaries, it will try to make an educated guess on which way to round off. If the space is too big, you might have a black frame. Vegas will always find the frame boundaries when creating a file or laying out to tape. Vegas included the Quantize to boundaries to keep you from editing in between frames. You cannot edit video at a subframe level.

Audio can be edited at the SAMPLE rate so if you are using 48k audio, it will allow you to edit at 48,000 of a second.

Cybercom, did you turn the VIEW on that I mentioned in my post?

Former user wrote on 5/4/2012, 7:41 AM

Did you turn the VIEW option ON that I mentioned?

Dave T2
TheHappyFriar wrote on 5/4/2012, 8:02 AM
There's two framerates Vegas uses: the one in the video & the one for the project (I know we all already know this). If you have the project at a different framerate then the video you will either edit sub or super frame, not on the frame, unless it lines up perfectly. Anything can be edited at any rate you want. You could edit NTSC video at a sample level but it would mess it up. Don't forget just because you CAN do it doesn't mean you SHOULD. ;)

I tried finding a video that didn't have frames line up perfectly. Both my DV & HDV clips lined up perfectly, I used to capture analog (until ~2005-ish I think), those weren't always perfect.

So I did some more tests. I took an HDV clip & 29.970 (30) fps on a 29.970 fps timeline. Worked as expected. I upped the project to 59.940 (60) fps (double NTSC). Auto resampling make it smooth @ the 60fps so I disabled resampling. I cut in the middle of a frame. @ 60fps in preview on Best@Full there was a blank frame there (as expected) because I cut it. I took the TL back down to 30fps. @ Best/Full I get a black frame. At Best/Half I get a frame @ 1/2 resolution.

So, next step: what if I cut at less then 1/2 a frame? I change the FPS to 120, then cut ~2/3rd though the same frame & delete the small segment. I change to 30fps & it displays as I would assume @ 30fps with Best/Full.

So, if you have less then 1/2 a frame it shows black when at a lower resolution. More it shows the frame. If you render (again, tested it), at a lower resolution you have a black frame. At the same resolution it... interesting, you get a funky image & black bar smear.

EDIT: images from my testing: here
Former user wrote on 5/4/2012, 8:15 AM
Sorry, but you are not exactly correct. If your project settings don't match your source video, it does not allow you to edit at subframe. It simply displays the frames at that rate.

If you render a 29.97 video at other than 29.97, it will try to create new frames based on the interpolation set in the project properties. If you render to 23.97, it will discard frames, if you render at 59.97, it will create frames.

If your source material is 24 frames and you render to 29.97, this is when 3:2 pulldown comes into play. Vegas, and other programs, will create frames from the current frames by blending fields.

Even if Vegas is showing you an ability to edit at subframe level, it will not actually do that. When you render and get a black frame, it is because Vegas has rounded off your subframe edit to a full frame.

Dave T2
WillemT wrote on 5/4/2012, 9:03 AM
To show the red event ends when not on frame boundaries, you need to set "Show Unquantized event start/end" to TRUE - they are FALSE by default. (<Shift> + Options->Preferences, then select Internal tab).

rs170a wrote on 5/4/2012, 10:32 AM
Willem, thank you very much. I wondered why the red line wasn't showing up when I first tried this.

altarvic wrote on 5/4/2012, 10:43 AM
Red line indicator is in the Internal settings - "Show unquantized event start/end"
p.s. sorry, didn't noticed Willem's message :)
Former user wrote on 5/4/2012, 11:47 AM

thanks for the correction. It had been a while since I set that.

Dave T2
TheHappyFriar wrote on 5/4/2012, 12:04 PM
Sorry, but you are not exactly correct. If your project settings don't match your source video, it does not allow you to edit at subframe. It simply displays the frames at that rate.

If you want to get THAT picky then you don't edit anything, it's a nondestructive NLE. You don't even edit at the frame level.

You're assuming frames mean something, they don't, they're just a measurement of time. Having the project at 60fps with a 30fps video is the same as rendering the video at 60fps. The program makes up frames and the 30fps video is treated at 60, you edit in smaller increments of 1/30th, so you're editing in smaller then a single frame increments then the 30fps video

Even if Vegas is showing you an ability to edit at subframe level, it will not actually do that. When you render and get a black frame, it is because Vegas has rounded off your subframe edit to a full frame..

It does, (non-destructively). I said you'd get a black frame, I provided evidence of what the results are for different issues with less then a frame of video.

If your source material is 24 frames and you render to 29.97, this is when 3:2 pulldown comes into play. Vegas, and other programs, will create frames from the current frames by blending fields.

Only if you tell it to, I tested that too (didn't mention it though), it works like you think it would with resampling with a 30fps clip on a 60fps timeline.
Former user wrote on 5/4/2012, 12:17 PM
Okay, I am not sure why the angry tone in your response. So I am done here.


Dave T2
cybercom wrote on 5/4/2012, 12:47 PM
@ all:

I have Quantize to frames set and that solves the "in between" frame problem.

I've also set View|Video Event Edge Edit Frames though I'm not too sure what that is doing. Thanks!

I think some of this partial frame stuff started because I used Pluraleyes to sync a 3D camera rig's individual L & R files. I'm sure I didn't have Quantize to frames selected. One would think that would be the default, at least I would! :-)
Not sure if that would have made a difference or not to the Pluraleyes syncing. Perhaps someone who has an upcoming project could test.

Man have I got a lot of red lines...!!! THX!

@ all:
I see a "Do not quantize to frames for audio-only events" checkbox under options\preferences\editing. Should that be checked or unchecked? How will that effect sound/picture sync?

I have a boatload of cleanup to do before everything is snapped to boundaries and quantized however it will make things much easier moving forward.

I only opened this can of worms because so many people were having "black frame" issues and I thought the interframe thing might have something to do with it. Little did I know how much I was going to learn in the process!

Thanks to all for this look "behind the curtain."

< °)%%%><€

cybercom wrote on 5/4/2012, 3:10 PM
Follow up:

At every red line, I shifted the video and audio to the real frameline, e.g., shortened both heads and tails, and then closed the gap. This removed 1minute, 16 seconds of partial frames from 57 minutes of material!

< **)%%%><(

WillemT wrote on 5/4/2012, 3:25 PM

"Do not quantize to frames for audio-only events" will not effect sound/picture sync unless, of course, you move the audio relative to the picture.

With "Do not quantize to frames for audio-only events" checked (the default setting) and "Ignore Event Grouping" disabled (the usual setting) picture and sound will quantise to frame boundaries together. If you enable "Ignore Event Grouping" you can move the start and ends of an audio event freely. With an audio only event it will not quantise to frames regardless of the "Ignore Event Grouping" setting. This allows for fine adjustment of audio event end points.

The only problem is that you will have red lines at the event ends (would be nice if they could be turned off for audio events).

With "Do not quantize to frames for audio-only events" not checked, audio will always quantise to frames (assuming "Quantise to frame" is enabled.

Hope that makes sense.