Praise for version 12

RunnerBrett wrote on 3/22/2013, 6:07 AM
I hesitated to upgrade to Vegas Pro 12 because of how often version 11 would crash. I didn't want to spend the $$'s and then be disappointed.

Version 11 would crash VERY often especially when using New Blue text.

It's been one week and I've been using Version 12 and extensive use of New Blue (Version 2) and not one crash.

Knock on wood, throw salt over my shoulder, say positive words, I hope it stays this way--I'm happy.

Comments

Tom Pauncz wrote on 3/22/2013, 10:01 AM
Please post your system specs in your profile.
Thanks,
Tom
Martin L wrote on 3/22/2013, 10:21 AM
I agree. I hesitated to upgrade, but did it anyway. And I have not been disappointed. It is much more stable than 10 and 11 ever were. NB works most of the time and the updates that have been released since have fixed most remaining issues. I would say Vegas 12 is a top notch professional editing software again.
videoITguy wrote on 3/22/2013, 11:36 AM
Martin L, your generalization is interesting - BUT you can really help everyone else, by doing two things:

1) Post your system specs, which should include the videocard model number, and video card driver version.

AND most importantly:
2)Your typical workflow - including your sources, your intermediate compositing and renders if any, and final output formats...and whether you leave GPU on/off or tweak ram preview...

PLEASE!
drmathprog wrote on 3/22/2013, 12:37 PM
Vegas Pro 12: the Longfellow's little girl of software.

"And when she was good, she was very, very good,
But when she was bad she was horrid."

;-)
Guy S. wrote on 3/22/2013, 4:07 PM
Vegas 12 has been great for me as well!

System specs are posted
GPU acceleration OFF at work, ON at home (simpler timelines, just 2 video tracks)
Dynamic RAM Preview 2048 (set to zero if GPU ON)
Memory Needed By Vegas (Options>[Shift+Click]Preferences>Internal) 2048 (64bit)

Source: AVCHD 1080 60i, 24p, or 720p from Panasonic GH1 and/or GH2), 16MP stills

Plugins: Magic Bullet Looks 2

Typical Timeline Length: 10min or less (work), 3min - 45min (home)

Workflow:
At work I generally break my product videos into smaller logical segments because projects load fast, timelines remain very responsive, and Vegas seldom crashes. I've also found that a complex 12 minute timeline with AVCHD media takes 3 - 4 times longer to render than a simple one-track video timeline with MXF media, which renders faster than realtime.

So... I render the individual projects to MXF files and combine the files on a new timeline. The time savings happens when I need to change a segment: I can render just that segment to an MXF file, re-place it on the timeline with the other MXFs, and re-render the complete timeline in ~realtime.
winrockpost wrote on 3/22/2013, 4:58 PM
Guy,, not to be a negative nellie but sounds more like a compromise than vegas is working great...I love to hear v12 works ! but sounds like workarounds to make it work
VidMus wrote on 3/22/2013, 6:09 PM
Vegas 12 was a bit unstable and shaky at first but that was with my old system that was badly cluttered as well as Vegas 12 starting off a bit on the rough side.

On my new system in which I finally posted the new specs for I have had only a few crashes but that was because my system was already unstable at the time.

For instance I had opened a number of animated gif files with internet explorer which causes it to no longer work. So Vegas was also not able to work correctly. Problem not Vegas 12. A restart and everything is fine again.

Even so, I can edit for hours with Vegas 12 and be 99.9% rock solid! No work-around's of any kind. Thumbnails are head-center-tails. All video is from my Sony cameras. Audio is from my 4 track recording device. I cannot remember what the tech name for it is. The ram in my head is shot! LOL!

With GPU on, renders from HD to standard def is less than half the time of the project.

I typically divide large projects into small ones. It is not good for Vegas or any NLE to gobble the entire meal at once.

Oh yes, I forgot about the power supply. It is a good quality one by Corsair. Watts are important but also the amps. A higher watts power supply may or may not put the amps where you need them the most. On the old system I replaced a 500 watt supply with a 400 watt supply because the 400 watt supply had the amps where I needed it and the 500 watt supply did not. The 400 watt supply was much better quality in the way of regulation and power stability which is important for system stability especially when pushed hard by Vegas.

On the system I had prior to my last system, I cheaped-out on the components. What was the lowest price I can pay to build my system? Well cheap means buy it twice because the results were subpar. I am not implying that others here who have problems with Vegas went the cheap route, I am just saying what I used to do.

One must have a balanced quality system to get the best results!

Danny Fye
www.dannyfye.com/ccm
im.away wrote on 3/23/2013, 1:09 AM
I, too, have used V12 with no real problems except for just one time when a render job produced nothing but black frames. In that instance I must have stuffed something up in the render template because it did not do it again, nor has it ever done it since. My system specs are posted. System 1 is a Toshiba laptop that rarely gets used these days. It was used to do editing while travelling. Now I use system 2 for the same job. It is based around a mini itx motherboard and is portable enough to lug around in our caravan (trailer, for our friends in the US).

My workflow is varied but I have edited projects that are a mix of mxf files from my EX1R, m2t files from my HDR-HC3 cameras, mp4 from my GoPro and mov from my DSLR camera. I output 720p for the Internet in most cases. I don't use intemediatries or proxies when editing, but do use colour correction to match the cameras to each other. I also use stabiliser occasionally and Bluff Titler.

Having an IT background hasn't helped me understand the perplexing issues that others experience with Vegas Pro and I am grateful that, for whatever reason, it just works on my rig.

Cheers
barfnuts9000 wrote on 3/23/2013, 4:09 AM
Being a long time user of VP8, I had used that extensively with little to no issues and was happy. A few years later, a work project required some video presentations, so I checked to see how VP had progressed. I saw that VP11 touted GPU acceleration as well as many new features and faster rendering, so I made the upgrade.

From that point is when the all-too-well-known horrors with the GPU acceleration module started. VP12 was released not too much later and was thankfully able to upgrade at a reduced rate. Like a schmuck I thought the GPU acceleration bug would have been fixed. Unfortunately, like most of you probably experienced, it definitely was not fixed. I even had two complete separate systems at work and home. They both have AMD Radeon HD video cards now, but VP was still crashing constantly when I originally had a newer NVidia video card (which recently died).

Fast forward many, many months of bitterness from not using GPU Acceleration (plus brooding about making a seemingly worthless upgrade purchase), I came across a forum post which stated that the newest version of Catalyst (which I think was 13.1 or something) was yielding good results with GPU Acceleration enabled.

I was extremely skeptical given Sony's track record for almost a year, but I gave it a shot. Since then, I have not had ONE crash with GPU acceleration turned on. Not ONE. I am very impressed. VP12 is now running how it SHOULD have been running from the get go. I was almost ready to write the entire package off and move on to another NLE.

Since VP12 hasn't had an update since January, and the Catalyst update was installed in late February, it's leading me to think it was the video card drivers all along. Had AMD/nVidia not built stable capability in their driver package, or is VP's programming so strict in its hardware specs that it will crash at the drop of a hat when an unexpected video render event arrives?

I don't know which one it is, and I don't care. It's working great.

You have earned +1 Life Sony, please keep it up.
dirtynbl wrote on 3/23/2013, 1:20 PM
GPU acceleration is still in its infancy. ESPECIALLY openGL and openCML. It's nice to see NVIDIA's hold on CUDA cores crashing, but I always kind of figured that this was probably the biggest problem with Vegas 11. I've used since 3 and was really happy with everything until 8. 9 was awful. 10 is where I am now.

Maybe I'll give 12 a try...
Tisso Shark wrote on 3/25/2013, 4:53 AM
Version 9 was not good for me... But when I updated to version 11 all my problem were gone. I'm trying to render a quicktime file and noticed nothing changed for QT options from versions 11 to 12.
set wrote on 3/25/2013, 5:09 AM
For comparison note here:

Vegas 12 #486 is fully stable in my system too, mostly working with AVCHD codec media, and HDV codec.
All FXs are Vegas' internal. problem with 3rd party, e.g. Beautybox. Haven't try other FXs yet.
NewBlue TitlerPro 2 causing a lot of crashes.

Windows 7 update : last update is November, ATI Catalyst version 12.8

Setiawan Kartawidjaja
Bandung, West Java, Indonesia (UTC+7 Time Area)

Personal FB | Personal IG | Personal YT Channel
Chungs Video FB | Chungs Video IG | Chungs Video YT Channel
Personal Portfolios YouTube Playlist
Pond5 page: My Stock Footage of Bandung city

 

System 5-2021:
Processor: Intel(R) Core(TM) i7-10700 CPU @ 2.90GHz   2.90 GHz
Video Card1: Intel UHD Graphics 630 (Driver 30.0.101.1191)
Video Card2: AMD Radeon RX470 4GB VRAM (Driver Version
21.30.23.04 / 21.Q4.Dec3 / 30.0.14011,2006)
RAM: 32.0 GB
OS: Windows 10 Pro Version 21H2 OS Build 19044.1586
Drive OS: SSD 240GB
Drive Working: NVMe 1TB
Drive Storage: 4TB+2TB

 

System 2-2018:
ASUS ROG Strix Hero II GL504GM Gaming Laptop
Processor: Intel(R) Core(TM) i7 8750H CPU @2.20GHz 2.21 GHz
Video Card 1: Intel(R) UHD Graphics 630 (Driver 30.0.101.1191)
Video Card 2: NVIDIA GeForce GTX 1060 6GB GDDR5 VRAM (Driver Version 472.84)
RAM: 16GB
OS: Win10 Home 64-bit Version 20H2 OS Build 19042.1415
Storage: M.2 NVMe PCIe 256GB SSD & 2.5" 5400rpm 1TB SSHD

 

* I don't work for VEGAS Creative Software Team. I'm just Voluntary Moderator in this forum.

Martin L wrote on 3/25/2013, 4:20 PM
VideoTguy, I hope my specs are visible now. Let me post this to see...
Martin L wrote on 3/25/2013, 4:25 PM
Now, if one clicks my forum name, my machine specs will be visible.
Martin L wrote on 3/25/2013, 4:35 PM
Workflow: Import: Capturing HDV through Firewire or other material through USB2 or by the memory card reader.
Editing in Vegas 12, sometimes using NB Titler Pro2 for title graphics. Export: Rendering in Vegas 12, usually these days to h.264 Main Concept AVC mp4, which seems to be the format of choice for many web applications. For television I usually export in Quicktime according to specs given to me.
That's it.
I also have Premiere Pro and After Effects but seldom use them.
All video seen here: http://tidningenmonitor.se/media_till_vara_artiklar.php
are done this way, except some of them were edited by others on other platforms but I put them all together, and reedited in my Vegas 12 and exported from there.
videoITguy wrote on 3/25/2013, 4:43 PM
Thank you , MartinL, most helpful to post your specs and workflow for all of us. Thanks.
chap wrote on 3/28/2013, 12:29 PM
I upgrade every time no matter what, because I want Sony to keep developing the software, and I assume that my purchasing does just that. Vegas 4, 5, and 6 used to be a bit unstable, and by the time they got to 8 it was rock steady. 9 was perfect. It was only when we needed to move to 64 bits that the new problems started (remember the unusable 64 bit version 8, circa 2005?).

As it is it is getting more and more stable.

Keep sending in your crash reports, include the extra info, and make sure to be hitting CTRL S a whole bunch.

Chap
TheRhino wrote on 3/30/2013, 12:12 AM
Disappointed with the GTX 6xx series, I held-off upgrading my 4 year-old GPU until today when I noticed MicroCenter had GTX 570s for $140 AR. Disappointed with V11, I have been using V10e for all paid work. Without a fast GPU, CPU-only renders in V12 were 40% slower than V10e, so I haven't been using V12...

I installed the GTX 570 with the 296.10 driver in my 4ghz 6-core 980X. The 5 minute sample clip was a typical HD project rendered using the MainConcept Blu-ray codec.

V10e - 100% of CPU = 7:52 minutes
V12 = 50%-70% of CPU, GPU ON = 3:55 minutes

My current workflow has me rendering-out a HD Blu-ray mpg2 and SD DVD mpg2 with two VEGs of the same 1.5 hour project running in the background. I setup V12 to do the same thing overnight and the render windows indicate both projects should finish in about 2.5 hours with V12 vs. 4.5 hours with V10e.

Previously I tested-out a GTX 570, V11, and a different driver with poor results. V12 and the 296.10 driver are a definite improvement. I will likely continue to start-out all paid projects in V10e but move them to V12 for at least final rendering. At just $140 I bought another GTX 570 for a second workstation.

Workstation C with $600 USD of upgrades in April, 2021
--$360 11700K @ 5.0ghz
--$200 ASRock W480 Creator (onboard 10G net, TB3, etc.)
Borrowed from my 9900K until prices drop:
--32GB of G.Skill DDR4 3200 ($100 on Black Friday...)
Reused from same Tower Case that housed the Xeon:
--Used VEGA 56 GPU ($200 on eBay before mining craze...)
--Noctua Cooler, 750W PSU, OS SSD, LSI RAID Controller, SATAs, etc.

Performs VERY close to my overclocked 9900K (below), but at stock settings with no tweaking...

Workstation D with $1,350 USD of upgrades in April, 2019
--$500 9900K @ 5.0ghz
--$140 Corsair H150i liquid cooling with 360mm radiator (3 fans)
--$200 open box Asus Z390 WS (PLX chip manages 4/5 PCIe slots)
--$160 32GB of G.Skill DDR4 3000 (added another 32GB later...)
--$350 refurbished, but like-new Radeon Vega 64 LQ (liquid cooled)

Renders Vegas11 "Red Car Test" (AMD VCE) in 13s when clocked at 4.9 ghz
(note: BOTH onboard Intel & Vega64 show utilization during QSV & VCE renders...)

Source Video1 = 4TB RAID0--(2) 2TB M.2 on motherboard in RAID0
Source Video2 = 4TB RAID0--(2) 2TB M.2 (1) via U.2 adapter & (1) on separate PCIe card
Target Video1 = 32TB RAID0--(4) 8TB SATA hot-swap drives on PCIe RAID card with backups elsewhere

10G Network using used $30 Mellanox2 Adapters & Qnap QSW-M408-2C 10G Switch
Copy of Work Files, Source & Output Video, OS Images on QNAP 653b NAS with (6) 14TB WD RED
Blackmagic Decklink PCie card for capturing from tape, etc.
(2) internal BR Burners connected via USB 3.0 to SATA adapters
Old Cooler Master CM Stacker ATX case with (13) 5.25" front drive-bays holds & cools everything.

Workstations A & B are the 2 remaining 6-core 4.0ghz Xeon 5660 or I7 980x on Asus P6T6 motherboards.

$999 Walmart Evoo 17 Laptop with I7-9750H 6-core CPU, RTX 2060, (2) M.2 bays & (1) SSD bay...