Problem with Alpha Channel?

Jim H wrote on 8/14/2009, 3:05 PM
I'm working on my new i7 Win7RC 64-bit system and I've discovered that videos I created with Bluff Titler that were saved with Transparency do not display correctly in vegas 8.0c or any other player (nero7 or WMP). See image below.

This holds true for videos I create now or ones that I created on my old system where they worked fine. The vids look fine while I'm creating them in Bluff and they play fine if I save them without transparency. So my thought is/was that this is a codec problem.

I installed the Shark007 codec pack for WIN7 and the add-on for 64bit OS. This had no effect.

I'm stuck. Any idea what could be causing this problem?
Thank you.


JohnnyRoy wrote on 8/14/2009, 5:06 PM
Two things to check:

(1) In order to retain an alpha channel you need to write the video as 32-bit. Most codecs only support 24-bit. This leads people to render as uncompressed 32-bit but actually the Quicktime Animation codec produces files that are much smaller than uncompressed and can process 32-bit retaining the alpha channel. If you can't create a Quicktime movie from Bluff then you need to use uncompressed AVI.

(2) Vegas doesn't always recognize the alpha channel so sometimes you have to tell it. Just right-click on the event and go into the Properties and on the Media tab you can select the type of Alpha Channel. Straight (unmatted) usually works well unless you rendered the alpha as premultiplied in Bluff.

kkolbo wrote on 8/14/2009, 5:20 PM
It looks very much like Johnny's number 2. Not meant the way that sounds.

ReneH wrote on 8/14/2009, 7:17 PM
Jusat by chance, did you uncheck/check the "FX Bypassed" on the Video Preview window? That could be your problem. Go and click on it and see if it cleared your problem.
Jim H wrote on 8/14/2009, 7:18 PM
I should have specified that I am familiar with how to turn on the alpha channel in vegas. Bluff titler, if you're not familiar with it, has the option to render the video clip using uncompressed with transparency.

After further testing, I'm starting to think it may be just this one Bluff project that's hosed up some how. I've gone back and looked at the older Bluff clips of mine and with alpha turned on in Vegas they do look OK. They have that blocky look in my media players but I guess that's because they can't handle the alpha...though I never noticed that before.... Too many variables. Thanks for the feedback.