problem with debugmode frameserver

nolonemo wrote on 11/8/2008, 9:51 AM
I installed Debugmode Frameserver to try out. I have an NTSC HDV project on the Vegas 8.0b timeline, with about 1 minute selected. I click Render As and choose Debugmode Framserver and click Save. A dialog pops up asking to select the video outfup format. No matter which type I select, when I click Next, I get an error popup that says "Unable to create signpost AVI file. Please close any applications that may be using this file and try again." The target drive for the signpost file has 70GB free space. I am able to save files created in other apps to the target location. OS is XP Pro latest SP.

Can anyone help?


musicvid10 wrote on 11/8/2008, 11:01 AM
Try putting the virtual file right on your desktop. This always worked for me. (Disclaimer: I haven't used the frameserver in a long time).
Cliff Etzel wrote on 11/8/2008, 11:28 AM
I ran into this issue sometime ago and was referred to a forum that discussed the same issue - here's the fix (at least for me it was):

Check your projects audio properties - I believe there are issues with DebugMode Frameserver when the audio properties are set to 48khz - set your projects audio properties to 44khz 16bit and you should be able to work with it.

Cliff Etzel - Solo Video Journalist
bluprojekt | solo video journalism blog
nolonemo wrote on 11/8/2008, 2:08 PM
Thanks Cliff! Worked for me too (my properties had been 48/24).
Now I have to figure out why the BD video stream TMPGEnc is creating is crashing DADA5....
Cliff Etzel wrote on 11/8/2008, 5:37 PM
I frame serve regularly to On2 Flix Pro to create my FLV's - a much better solution IMO compared to built in encoders like Adobe's Media Encoder.

Quicktime Pro doesn't like the frame served files FWIW - it throws an error about 8% into the encode to h.264 MP4.

Cliff Etzel - Solo Video Journalist
bluprojekt | solo video journalism blog
musicvid10 wrote on 2/7/2009, 8:57 AM
I was reinvestigating the frameserver after some discussion in another thread, and it seems it only outputs square pixels.

That makes it pretty limited for most current formats, right? Is there a way to get widescreen out? I found I can frameserve to Super but it is squished 4:3.

Does this mean that the workflow I've been using, h.264->Super->FLV is still the best for 16:9, or is there some some setting / trick I'm missing?
musicvid10 wrote on 2/7/2009, 9:28 AM
Answered my own question --

If I set the Super output to 432x240 (or 864x480) and stretch the output, I get a usable widescreen FLV from the Satish Frameserver.

I check the Direct Code Decode switch in Super to get it to work.

I will do some more comparisons, but this seems like a slick solution to the Vegas-to-FLV question. Going to try that other converter mentioned too.
rmack350 wrote on 2/7/2009, 10:57 AM
The Frameserver should be outputting exactly what you give it without making any sort of pixel conversion. That's the whole point of the frameserver.

There are other problems with it that basically boil down to it being a free tool that is good enough but not polished. For instance, I think on occasion the settings you see may not really reflect the settings it's using, especially after a crash or failure. You may need to manually find and delete a signpost file, change and rechange's not perfect but it does a very specific and unique thing.

Never had a problem with 48k audio but I don't use it nearly as much as cliff does.

Rob Mack
TGS wrote on 2/7/2009, 12:00 PM
It's not 48K audio it has a problem with, it's 24 bit. instead of 16 bit.
musicvid10 wrote on 2/7/2009, 2:52 PM
**The Frameserver should be outputting exactly what you give it without making any sort of pixel conversion.**

My captured footage and project properties are 16:9 Widescreen NTSC DV, 1.21 PAR.
The frameserver sends out 720x480 1.0 PAR (square pixels) VFW. The distortion is obvious.
I have previously rendered this project to DVD Widescreen and MPEG-4 Widescreen.
I haven't found any setting for aspect in the frameserver.
It looks like it hasn't been updated to do this.

If there is an easy workaround that you know of in Vegas without stretching to fill a custom project frame size I would like to know about it.From an

rmack350 wrote on 2/7/2009, 6:02 PM
Hmmm. Okay, you want it to apply a PAR. I think my point stands. You're using a 720x480 project and that's what it's outputting. Seems pretty straightforward. There is no PAR, just pixels.

It's up to your receiving program to apply an interpretation to that frame. If you're going Vegas to Vegas then you'd adjust the media's properties in the project media window

musicvid10 wrote on 2/7/2009, 6:20 PM
Actually, I agree more with your original statement .

I just don't think it's there yet. I don't know if there is any plan to continue development either.
I don't want to "apply" a PAR, but like you I was hoping it would preserve the PAR.

"It's up to your receiving program to apply an interpretation to that frame."
Ideally the frameserver, like other renderers, would pass the source PAR to the output.
Without that information, one would need to manually adjust the source dimensions or the destination
Former user wrote on 2/7/2009, 6:36 PM
PAR is strictly a display flag. It does not affect the resolution or cause any change of quality. A DV video is 720 x 480 pixels, NTSC. A flag for 16 x 9 is inserted by programs in order for the video to be displayed as widescreen. When the flag is applied does not affect the quality or cause any "pixel conversion" of the video file.

Widescreen itself does affect the display quality. Although we are used to seeing it since that is the way that SD Widescreen DVDs have always been created. It is taking 720 pixels and stretching them to 873 or so pixel widths.

Dave T2
ScorpioProd wrote on 2/8/2009, 11:22 PM
I use the Frameserver to TMPGEnc on every project. I just tell TMPGEnc that my source is 16:9 and my output is 16:9, and that's that. TMPGEnc takes care of the PAR.

A number of file formats don't include a PAR flag anyway, it's not an unusual situation.