Production Assistant in Vegas :(

LarsHD wrote on 6/2/2010, 2:36 AM
When starting Production Assistant from within Vegas:

"Your License has expired" and offers me the option to click "OK"
"Cannot find any installed BackPacks"
Etc etc etc.

I purchased this PA from Sony Creative Software hoping it would at least launch reliably.

QUESTION: Is this a known bug? Is there an easy fix / workaround? If not, I'll spend a couple of hours moving this old little vegas-project over to the new editing instead.

I'm really so tired of Vegas and this patchwork feeling I get when opening it up.

I haven't started any new projects in Vegas for a long time now. But now and then I have to use Vegas to take care of older productions for clients, updating and changing stuff etc.

Every time now I feel like I'm opening up Vegas is like going back in time and perfomance.

What I said about Vegas earlier: the fast and easy to use interface etc. I really have to take that back now after having done several productions in other NLE's. Vegas is slower, unpredictable, messy and old. I can't see any good reasons at all to start new editing sessions in the app. Sorry.

And it's not just a question about performance. It's about the whole concept of how you edit etc.

If anyone has a solution to that Production Assistant bug I'd be greateful to know. Otherwise I'll just spend the time it takes to free this project too from Vegas.



John_Cline wrote on 6/2/2010, 3:00 AM
I swear that you have the absolute worst luck with Vegas. I have asked this many times but have never gotten an answer from you: Is all of this stuff you've been complaining about for months taking place on one machine?
alltheseworlds wrote on 6/2/2010, 3:22 AM
And maybe I missed it in some other post, but what's the other NLE that's made you so happy ? I don't want to start a debate, just interested...
Grazie wrote on 6/2/2010, 3:45 AM
Lars, old bean, please fill out your system specs? Yes? - If you want solutions you'll need to meet people half way, at the very least.


Rob Franks wrote on 6/2/2010, 4:02 AM
"I swear that you have the absolute worst luck with Vegas."

I have learned that there are a select few (and always the same few) on this board who have nothing but issues. Not to say that those issues aren't real, but one has to ask what the heck they are doing (or not doing) to PROVOKE the problems they are having!?! I just don't understand how Vegas can be such a disaster for the same few people ALL the time.
Paul Fierlinger wrote on 6/2/2010, 4:18 AM
MSK wrote on 6/2/2010, 6:32 AM
This may be a result of installing PA on a user account that is not the account you are attempting to access it on. PA installs a folder and settings here:

C:\Users\<USERNAME>\AppData\Roaming\Sony\Production Assistant\1.0

If it tries to open and does not see this folder or the appropriate contents within this folder, then you might see that error message.

If you have more than one user account, try browsing to this folder in the user account you installed PA on and copy/paste it to the same level in your current user account. If you are browsing to this folder, you will need to "Show hidden files" in Windows.

Also, make sure the Production Assistant .dll file lives in this folder:
C:\Users\<USERNAME>\AppData\Roaming\Sony\Vegas Pro\Application Extensions
ushere wrote on 6/2/2010, 6:39 AM
wow lars, you really do seem to have bought a lemon.

now, having said that, my version of vegas has been trouble free, other than a couple of know bugs that were cleared up in 9e. and this seems to be the general consensus.

on the other hand, you don't give any system specs (as has been asked numerous times before), so we can't even begin to help you out, and as you've found an alternative nle that makes vegas old fashioned, i'd love to know which, and on what you're running it....

that said, your posting here seems rather pointless......

CClub wrote on 6/2/2010, 7:43 AM
ALLL of Lars postings on this forum seem rather pointless. Several months ago, Lars was allegedly so upset with Vegas that he deleted his account (do a search under username "LarsHD," and you'll see everything 3-17-10 and after deleted). Every week or two, he comes back on and states how bad Vegas is and how great all of his other NLE's are. A few people always buy into his circlejerk and he skips away with glee. Someone on this forum previously stated that he is [allegedly] some producer known somewhere, but I can't imagine that is true given how much he wastes his time on this forum for a product he hates.
JohnnyRoy wrote on 6/2/2010, 12:06 PM
Hi Lars,

From that error message it seems that Production Assistant can't find your license key. Does it give you an opportunity to input the key? (it should). If not, launch PA from the desktop and see if that is licensed (check the AboutBox by clicking on the VASST logo in the lower left) and if not, will that allow you to enter your license key?

If you installed it under one user account and are trying to use it under another account you will also see this error because it is licensed to the account that installed it. Feel free to contact Sony Support about this and if they can't figure it out they will escalate to VASST support. I can also help you over on the Production Assistant forum.

LarsHD wrote on 6/2/2010, 12:57 PM
Thanks for all the kind advice. Experimented a bit and found out the following:

If I start Production Assistant as standalone it starts OK.

When I start Production Assistant from within Vegas the following happens:

Launching extensions "Production Assistant 1.0".

Getting "BackPak-1 Your License has expired"

Now clicking the X in the upper right:
Now I get "Enter BackPak-1 License Key"

Now I try clicking X in the upper right again... And I get:
"BackPak1 Load: Exception has been thrown by the target of an invocation for C:]Program Files (x86\VASST\Common\BackPaks\BP-1\BackPal1.dll You must enter a valid licence key. The program cannot continue"

Again I click on the X in the upper right corner... Now I get:
"Cannot find any installed BackPaks"

Again I click on X in the upper right corner:

AND... Production Assistant now launches OK and runs OK!

Fantastic! Everything's working as it should! Just forgot I should have clicked X a couple of times on these error messages in order to launch Production Assistant.

Best & thanks

PS. If I try to enter the license again - which I did when installing it, it says "License Install Error - An error occured while installing the license. Ensure you have sufficicent privliges to install the license" Well, well.... X-clicking seems easier.
John_Cline wrote on 6/2/2010, 1:00 PM
I guess I'm never going to get the answer to my question.
LarsHD wrote on 6/2/2010, 1:24 PM
Hi Johnny (jr)

"Does it give you an opportunity to input the key?"

Yes, but it doesn't work... I enter the licensce key (see above what response I get then).

Thanks for your kind and constructive question and help.
LarsHD wrote on 6/2/2010, 1:30 PM
To John Cline

Sorry John, I forgot to check the box for "show system information" in my user settings. I had listed my setup but failed to check the box for actually letting others view it...

FrigidNDEditing wrote on 6/2/2010, 1:45 PM
Hey Lars, sorry for the hijack, but wanted to make sure you saw that DVFilm EPIC will be 64 bit soon (if not already).

John_Cline wrote on 6/2/2010, 2:05 PM
Lars, the question I have been asking for months is whether all the problems you have been having with Vegas have been on that one machine? In other words, have you tried Vegas on another machine to confirm that your troubles are actually with Vegas and not some conflict between Vegas and that one particular machine.
JJKizak wrote on 6/2/2010, 2:53 PM
If LARS is hitting the "X's" to get things to work his machine is definitely malfunctining.
farss wrote on 6/2/2010, 4:23 PM
"Lars, the question I have been asking for months is whether all the problems you have been having with Vegas have been on that one machine? In other words, have you tried Vegas on another machine to confirm that your troubles are actually with Vegas and not some conflict between Vegas and that one particular machine. "

I have replied to the exact same question asked by you before. In case you missed it I'll give you much the same answer again.

I have copied at least one of Lars's test cases. They repo on my machines.
Since my last post on this issue I have found the exact same problem in footage from at least one other user who has posted here. This user was using V8, I tried V9 and got the same result. Under certain circumstances Vegas may duplicate frames leading to the appearance of juddery motion in the rendered output. This problem seems most pronounced with 29.970p footage.
Lars's analysis that Vegas is "unpredictable" is correct and the most damning indictment of the product. What Vegas produces as rendered output is a bit of a lucky dip. Many users might not notice the problem or may take the advice regularly given here that the problem is the player or a natural consequence of shooting low frame rate progressive material. As it turns out all this may be just a smoke screen.
I've also had instances of Vegas's timecode FX producing significant jumps in the burnt in timecode. I cannot determine though if the error is just in the timecode FX or how Vegas calculates the current frame. Based on the other issues I'd strongly suspect the latter.

John_Cline wrote on 6/2/2010, 4:46 PM
Almost exactly seven years ago back in 2003, I reported that Vegas was duplicating frames on 29.97 fps material. Once the reason was determined, I have succesfully worked around the issue ever since. Here is the original thread (complete with some BillyBoy nonsense.)
JohnnyRoy wrote on 6/2/2010, 6:38 PM
Hi Lars,

> Yes, but it doesn't work... I enter the license key (see above what response I get then).

There are three things that might cause this:

(1) If you download the trial of Ultimate S Pro (which shares BackPak-1) it is possible that it's the trial BackPak-1 that has expired and you would need an Ultimate S Pro key to unlock it (the install should not be overlaying a licensed version with the trial but I have seen it happen).

(2) Your key might have spaces in it. Some times the key gets transmitted in an email as "1234 - 5678" instead of "1234-5678" Make sure there are no spaces in the key (the dashes are needed)

(3) You are using an userid that doesn't have administrative privileges to store the key. (not very likely if the rest of Production Assistant is licensed)

What I would suggest that you do is uninstall the version of Production Assistant that you have an install the latest 1.0.16 version that was just released. You can download it from the Sony site.

Make sure that Vegas is not running in memory when you uninstall and re-install or else it will cause problems. Installing the latest version should clear up the BackPak-1 license problem because it should re-establish the correct files.

Let me know how you make out. You can contact me via the ultimatesupport email account at if you want me to check your license key or send screen shots or anything.

farss wrote on 6/2/2010, 6:44 PM
that thread bought back some memories I could have done without reviving!

So, you say you've been working around this problem for ages. To save anyone else having to endure reading through that thread in a nutshell can you please explain how you've been working around it.


I fear I've run into a similar problem to do with audio from a composer using Logic. Why oh why in the world he's running a "NTSC" timeline when the movie was shot at 25fps escapes me. The error I'm getting in each of his reels comes out very, very close to the errors you'd found. For example a reel of 00:19:09;18 overruns vision for that reel by 00:00:1;10 at 25fps. I've perhaps foolishly ignored this problem until now. Now its biting me in the butt when elements in his score have to line up frame accurate with the vision. My other big concern now is all this has to go into an online.

As for the problem in Vegas and duplicated frames. The test cases I've been using use gen media from Vegas itself, possibly Vegas cannot read its own frame rate correctly. More confusingly the outcome seemed to depend on which codec I rendered to. Uncompressed AVI was fine, MXF was not. That could be a clue that one of those codecs is rounding the frame rate.

John_Cline wrote on 6/2/2010, 8:35 PM
Basically, it all boiled down to the fact that Vegas correctly operates at a framerate of exactly 30000/1001 which is 29.97002997 fps. Most other apps incorrectly use 2997/100 which is 29.97 fps even. This causes a speed mismatch in Vegas that uses the more precise framerate calculation and can cause frames to drop or repeat. For example, Adobe's After Effects writes it's movies as 2997/100, whereas Vegas captures and operates at 30000/1001. This particular oddity manifests itself with the 29.97 footage repeating a frame at 2 seconds 28 frames from the beginning of the file in Vegas. I've been getting around it in AVI files by using a little command line utility that changes the header of non-precise AVI files from 2997/100 to 30000/1001. It's available here:

You say that you've seen duplicated frames using media generated from within Vegas itself and uncompressed AVI was fine but MXF was not. This is very odd, I've never seen this happen except in the scenario I described above. I'd think I would have noticed it if it was happening but maybe not.

You audio problem in Vegas using an NTSC audio timeline sounds like a drop frame vs non-drop frame issue.

(Wow, I really don't miss BillyBoy at all, but it seems that one user after another shows up here pretty regularly to take his place. Fortunately, they never last long.)
farss wrote on 6/2/2010, 9:14 PM
Thanks John.
I downloaded Speedmangler and will give it a whirl when I have some free time. I'm upto my armpits in aligators at the moment with my other business that pays real money so I don't have a whole lot of free time to do more investigative work for a while.

Re ND / NDF:

One thing I noticed a few weeks ago on a Vegas 9.0e T/L setup as DF was the timecode go from xx:xx:xx;27 to the next frame at xx:xx:xx;03. Changing to NDF and sanity prevailed.
Needless to say I don't have to deal with NTSC / Region60 footage very often so I just moved on.

farss wrote on 6/3/2010, 4:04 AM
Found a minute to delve into this a little.
Analysis of MXF rendered out of Vegas shows the following

3128 | 0xc38
Timeline Track
|-- SimpleElement ........<Instance UID> UUID 2a.0a.02.3c.8a.b0.4c.db.85.1f.fa.40.b2.36.43.bc
|-- SimpleElement ........<Track ID> UInt32 1
|-- SimpleElement ........<Track Number> UInt32 0
|-- ReferenceElement .....<Sequence> UUID 24.c3.2c.14.dc.
|-- SimpleElement ........<Edit Rate> Rational 30000/1001
|-- SimpleElement ........<Origin> Position 0

So Vegas is correctly flagging 29.970 as 30000/1001

farss wrote on 6/3/2010, 5:54 AM
I just rebuilt Lars test case, reinserted fresh TC so I wasn't being led up the garden path. This is from Vegas 9.0e. Source is a 35Mbps VBR Sony MXF, rendered to the same. Examination of the rendered file using Vegas 9.0e shows the following:

Frame number Timecode
00 00
01 01
02 02
03 02
04 04
05 05
06 06
07 07
08 08
09 09
10 09
11 11
12 12
13 12
14 14
15 15
16 16
17 17
18 18
19 18
20 20
21 21
22 22
23 23
24 24
25 25
26 26
27 28
28 29
29 29

Given the repitition rate of the duplicated frames I'm inclined to doubt this is due to a small frame rate inconsistency. I ran another test replacing the 100% random noise pattern with solid black and rendered that out. Viewing the results again in Vegas 9.0e the result is perfect.
My logical conclusion is the flaw is in the encoder or the encoder interface. The average user is very unlikely to see this problem or if they did it'd be 1 in 1,000s of frames, it would appear dependant on content. This also explains why rendering to uncompressed HD the problem went away.
The remarkable thing is the noise test pattern survives pretty well considering this is an extreme stress test. If the encoder was simply running out of bandwidth I'd expect to see macroblocking or some other artifact.