Render Problem

Yep wrote on 12/31/2014, 9:28 AM
I've been using Vegas Pro 13 now for about 7 months with remarkably few problems.

However over the last week I've had significant problems getting one project to render. The original media is 1920x1080 10mbps. The project length is 65mins 30secs length. I've been trying to render to 1920x1080 60i 10Mbps. Numerous attempts ended in render failure at around the 43% mark.

I had about 550 Gig free space on my hard drive and though I didn't think it would help I freed up another 275 Gig just to see what would happen.

The next attempt saw the render fail at a tantalising 94%. Now I'm wondering if the additional free space on my hard drive had anything to do with it - or was that just a matter of chance? I'm not very techy, but it would appear to me that 825 or even 550 Gigs of free space should be more than enough for a render of that type. I'd be very interested in hearing opinions.

My basic PC specs are

Win 7 Pro 64bit
8 Gigs Ram
Intel Core i7 CPU @ 3.50 GHz

I'm also wondering if upgrading to 16 Gigs Ram might be helpful. I have noticed that I can't run two instances of Vegas Pro at the same time without things going a bit wonky.



Chienworks wrote on 12/31/2014, 10:16 AM
Rendered output file size is determined by the length and the bitrate used; no other factors matter. You don't specify what bitrate you're using, however, 550GB would hold a 65 minute file at 1155Mbps, which is an insanely high value. At a more reasonable 16Mbps 550GB would hold about 4,693 minutes. It would seem that hard drive space is not an issue.

Perhaps you could tell us the output format, file type, codec, and any other options you're using.
Yep wrote on 12/31/2014, 12:41 PM
Thanks for the reply Chienworks. Sorry - should have included a bit more information.

Render details are AVC - that is Sony AVC/MVC 1920x1080-60i at a bitrate of 10Mbps. I have quite a few effects applied across the timeline but I've rendered much more complicated projects in the past with no problems.

Yes - I think I am really grasping at straws on hard drive space. It just seemed odd that the render suddenly made it to 94% as soon as I made some more space available. I understand the basic principles of lengt+bitrate to filesize - but thought perhaps Vegas was using the hard drive in some way during the render process that required more space. Sorry - I am not very techy at all.

It has also just occured to me that this might be a GPU acceleration issue. I had it turned on during the render process and that has caused me problems in the past where .jpg images were included in the timeline. I have no .jpg files in the current project - but GPU acceleration does seem to be a problem in Vegas 13. I'll try and render with it switched off tonight when I go to bed.

Any and all comments welcomed.

Thanks again
PeterDuke wrote on 1/1/2015, 12:27 AM
Did you get a message when Vegas failed? if so what did it say?

Do you just have a single disk with no partitions? If not, then make sure that you have adequate space for the temporary work files, wherever they are located, as well as your final render.

Most definitely turn off GPU while you are sorting out other problems.
NCARalph wrote on 1/1/2015, 3:16 PM
What kind of video card do you have?

Vegas 13 definitely has problems rendering with at least some NVidia cards. You might try rendering using the GPU with the Dynamic RAM Preview Max memory setting at 0. That fixed my problems with a GTX 570.
Yep wrote on 1/1/2015, 3:26 PM
In answer to PeterDuke - thanks again for your reply.

No message as such - just one of those crash notices asking if I want to send crash details to Sony.

I have an SSD for my operating system. Normal hard drive for storage and render operations currently with about 550 gigs free space.

In reply to NCARalph - I have NVIDIA GeForce GTX 560i. Thanks for the suggestion. I will definetely give that a try and report back - but it will be a few days before I get around to it.

Well it seems that in this particular instance it was GPU rendering that caused the problem. I swithced it off and ran the render again overnight. The render completed without any problems though it took about 4 hours.

It's funny how this GPU problem seems to affect only certain media. As I said previously I had a similar problem several months ago where a project with .jpg images wouldnt render. In that case as soon as I turned off GPU it rendered without a problem. I've made literally hundreds of renders since then with GPU switched on without any problems at all - until I tried to render the media in my current project. It sees to me the GPU problem relates to certain media only - maybe it doesn't like the way the media was originally encoded.

I'd be interested in hearing comments and opinions on the GPU rendering issue.

Thanks all for your input.
NCARalph wrote on 1/1/2015, 5:13 PM
There's been a lot of talk about GPU issues, do a search for NVidia going back a year if you are interested.

I had much the same behavior, some files rendered without problems, others crashed, and not always at the same place. I suspect it's just software bugs, and in a massively parallel situation like rendering, tracking them down is very difficult.

Do try the rendering memory setting at 0. It completely fixed my problems.
Yep wrote on 1/2/2015, 6:56 PM
Well this if very interesting. I tried rendering the project with GPU enabled and Dynamic RAM Preview Max memory set at 0 as suggested by NCARalph. The project rendered without any problems. Wondering if I had just got lucky with that attempt I also went back to another project that simply wouldn't render with GPU enabled. Lo and behold that rendered without any problems with GPU enabled as well.

While not an absolutely conclusive test - NCARalph's suggestion seems to be a valid fix for the problem.

Now I'm curious - can anyone tell me what happens when you set the Dynamic Ram Preview Max memory to 0 - from a technical point of view that is.

Big thanks Ralph ;)
Kitt wrote on 1/20/2015, 6:56 PM
Thank you NCARalph for your suggestion of rendering using the GPU with the Dynamic RAM Preview Max memory setting at 0. It fixed my problem in Vegas Pro 13 well and I am using the GTX 770. The same setting also fixed the exact same issue I had using Movie Studio 13 Platinum.

Additionally, I tried to increase the default Dynamic Ram Preview Memory from 200 to 1,024 and got a 3% improvement in speed, but still had the same non-clean render issues of jerky, dithering video. With the setting = 0, I am rendering 33% faster than what my my i7 core processors could do alone with the GPU turned off.

I do not feel like I wasted the money on the NVIDIA card anymore, but am surprised this has not been fixed inside the application over the years it's been known about. This tip is greatly appreciated. I would never have thought to turn the setting to zero and improve performance.