Rendering problems

MarkMac wrote on 3/28/2003, 1:44 PM

I recently purchased Vegas Video 4.0, and I have just created my first 10 minute long project. Origionally, I attempted to render the project to an Mpeg1 file, and I got an error saying "An error occurred while creating the media file. The reason for the error could not be determined".. I played the file that it created, and went to the end of the file. I went to the same point in my project, and tried rendering just that region, and it errored out as well. I can play the whole project in preview mode, and it plays fine.. I replaced the video file that was at the point where it errored out, and it continued to render with no problems. NEXT.. I was told to add some jpegs into the video, so I loaded the project up, and added the photos. I tried to render again, and again, it errored out during the render (it actually errored out while rendering a portion that only had a video clip, and a background music track).. I moved the video in that portion to another place on the project, as well as replacing the mp3 track in that location, and it STILL errors out in the exact same spot.. I tried rendering the project to avi format, and it renders with no problems at all.. Does anyone have any ideas? Rendering to avi is ok, but at 2.3GB for 10 min presentation is going to get costly afterwhile. Tech support suspects a corrupt media file of some sort, but seeing as I replaced both the video and audio in that point, I find that hard to believe, as well as the fact that it renders ok in avi format..


emailrobert wrote on 3/29/2003, 5:28 PM
I am havin the exact same problem. I am rendering a 12 minute video to MPEG1 and it craps out at the same spot every time
AmishBoy wrote on 3/29/2003, 7:32 PM
DITTO! Same problem here. Different projects, different media/clips, same message:

"An error occured while creating the media file *****.mpg. The reason for the error could not be determined."

I hope Tech Support can "determine" the reason!
simojo wrote on 3/31/2003, 10:33 AM
Same problem here, with both mpeg1 and mpeg2, for an 18 minute video. AVI render works without a hitch. Will check out the possibility of corrupt media.
Dell 4500 P4, 512 RAM, 40 & 80 HDD, Matrox G550, WinXP Home
BillyBoy wrote on 3/31/2003, 10:54 AM
For what its worth...

I've seen this error or others like it a few times. What has always worked for me is the following, assuming of course the source file isn't corrupt. It may not show as corrupt when rendering to AVI, but may cause problems when rendering to MPEG.

1. Insert a break (split) a second or so BEFORE you get the error message.
2. Insert a NEW track(s) if you have both video and audio.
3. Cut the event right of the split your made in #1 and move to the new track(s).

My experience is it will now render correctly. I refer to this as a 'corrupted' track. That's my spin on it, for lack of a better description, sometimes happens to an event or part of an event so my moving it to a new track it cures it. Why? I have no idea. Worth a try anyway.
defucius wrote on 3/31/2003, 2:10 PM
I had the exact same problem trying to render to Mpg1 this past weekend. It was a time urgent project of simply converting from VHS to VCD. After several failed tries, I moved the file to another computer, and it got the same error.

Then I rendered to AVI without any problem. And I tried to render that new AVI file, it failed at the same point!

Finally, I went back Vegas 3.0, loaded the original file. And Vegas 3.0 renders just fine.
simojo wrote on 4/1/2003, 10:47 AM
Just found this:
which includes this reply from SonicEPM at SoFo:
"We have found a potential MPEG1 render problem and will address it in the next Vegas update."
Looking forward to it.
AmishBoy wrote on 4/2/2003, 4:51 AM
Any idea when the update might become available?
pconti wrote on 4/2/2003, 4:55 AM
SOFO says later this week.
dara wrote on 4/5/2003, 9:30 AM
just wanted to add to the number of people having render error messages for mpeg render!! very frustrating. love some of vv4 new features, but they're pretty worthless if I can't render the darn thing.hurry the heck up w/ that update sofo!!!
MarkMac wrote on 4/7/2003, 1:42 PM
Yep, mine was a deadline urgent project, and after spending about 4 hours trying to get the bloody thing to render, I just printed it to tape, and it worked fine.. AFTER the project was presented, just for kicks, I tried rendering it again, and it worked fine ????? I think the problem was the fact that I needed it done in a hurry. So to solve the problem, never use this software if you need something done by a certain time, only if you have nothing better to do :) LOL

I just downloaded 4.0b and now I have to wait until I get another project to do before I can test this one out (which could be along time). Can someone else let me know if this solves the problem??
simojo wrote on 4/8/2003, 6:33 AM
After updating, I was able to render the MPEG1 file that caused problems before. I'm now getting some slight jitter in high-motion areas that I did not see before, but other than that it looks like my specific problem was solved.
LOWtense wrote on 4/8/2003, 5:52 PM
Well, i don't know what i'm doing wrong here but i'm trying to render my project to MPEG 2 for SVCD and Vegas stills gives "An error accured....."
But the errordetail displays:" AllocateMixBuffer(Microsoft-geluidstoewijzing) : m_wfxPrepared.nSamplesPerSec is 44100! (m_ccPreroll 237545398427446856 nBuffers 55309168)" I used the last update 4b but this aint funny anymore!
Does somebody have a REAL solution? Now i have to render it to AVI and then convert it using TEMPGenc or Canopus Procoder (=Double the time and effort!)
MarkMac wrote on 4/9/2003, 12:36 PM
Well, at least they give you an error message. Nothing is worse than calling tech support and when they ask you the error you are getting, you tell them "I don't know"..

Hopefully I will have a project to do soon, so I can see how this works now.
NeilPorter wrote on 4/14/2003, 10:45 AM
I have found that MPEG-1 renders are quite jerky. I have played them on a VCD on my lounge-room DVD player. It is particularly noticeable when a person is moving quickly or when the camera is panning horizontally, even slowly. I consider this to be a critical problem as it effectively tells me that I cannot ever have a VCD of my movies. It appears that the problem is in the rendering of the MPEG-1. i.e. not in the original source, the captured .avi, or an .avi printed back to camera tape.

Are we stuck with this or is there a way out?

By the way, I am using Pal systems.
reamenterprises wrote on 4/15/2003, 7:39 PM
VV Users,

I am glad to see some others having a rendering challenge with *mpeg files. I have had the problems since VV3 and with VV4. I have gone to the point of literally rebuilding two computer systems, because I am told of a device driver error.

This has been very frustrating, sometimes it does it... sometimes not.

I hope all future version and upgrades resolves these issues.

SonyEPM wrote on 4/16/2003, 9:39 AM
If you have 4.0b, you should be able to render long MPEG files (-1 or -2) with no failures. We tested this extensively prior to release.

If you still encounter render hangs with 4.0b, please let us know- we want this resolved as much as you do.
wri7913 wrote on 5/2/2003, 7:03 PM
I too have been having this problem "" AllocateMixBuffer(Microsoft-geluidstoewijzing) : m_wfxPrepared.nSamplesPerSec is 44100! (m_ccPreroll 237545398427446856 nBuffers 55309168)"

I installed the 4b update and its still doing it. I haven't had any probs recently and it just started doing it.
BillyBoy wrote on 5/2/2003, 7:31 PM
I'm running version 4b build 174 and so far I've rendered several larger projects with it without a single burp. The last "big" project was a single file running just over 76 minues as a avi using the default NTSC DV template. A little over a 12GB file was the result. I turned around took that file and used it as source and made a MPEG-2 with no problem, about 2.5 GB.
wri7913 wrote on 5/3/2003, 4:31 PM
I too am using 4b build 174. Everything was working fine till two days ago. I haven't made any changes except to make a custom render that reduce the bitrate of the SVCD (so it will fit on CD-ROM).

I just rebooted, reinstalled the software and got these two different error messages about 3/4's of the way through the render

AllocateMixBuffer(Left/Right Front) : m_wfxPrepared.nSamplesPerSec is 44100! (m_ccPreroll 304045167360880504 nBuffers 70792352)

AllocateMixBuffer(VIA Audio (WAVE)) : m_wfxPrepared.nSamplesPerSec is 44100! (m_ccPreroll 263958244713153696 nBuffers 61458888)

I figure the problem is related to my sound drivers or something in Windows Media. I'll try downgrading Windows Media to 7.1 then 8.0 and see if this fixes the problem.
pwppch wrote on 5/3/2003, 8:49 PM
Can you tell me exactly what you did. The more step by step details on what you did will help me to track this down. The simplest case will also be a major help.

Please email me direct at if you would prefer.

wri7913 wrote on 5/3/2003, 11:52 PM
I think I started getting the errors after trying to run an older version of Vegas 3.0 and newer version of Vegas 4.0 at the same time. I tried to render two items simultaneously since Vegas doesn't have any kind of batch processing yet. Ever since, I keep getting errors that halt the render midway. I've tried to render to AVI and that worked fine. I then tried to create an mpeg with tmpgenc but I got static in the mpg file and it appeared to be blank. When I render in Vegas Video I was using a template that I created myself. The custom template is for SVCD and I reduced the bitrate so it would fit on a CDROM. All the errors seems to point to a problem with sound either in directx, windows media or possibly a corrupted sound driver.

Downgraded to 7.1 media player and that didn't work.

Reinstalled software and that also didn't work

wri7913 wrote on 5/4/2003, 1:40 PM
I think I figured out part of the problems I was experiencing. The problems started after I created a custom template for SVCD. I went back to using a normal Vegas template and it worked. I went back and created a new SVCD template to my specs and it also worked. I must have changed a setting in the audio tab portion of the custom template that screwed up the rendering. I'll try a few more and see if this was the source of the problems.