Scaling Still Images

ADI2000 wrote on 1/19/2005, 10:32 PM

I need to have an image of the following dimensions appear at actual size in the video frame: 1131x777 pixels. I’ve created a geographical map which has a transparency (file type .tga / alpha: straight unmated). What I need to do is have the image appear at the full (oversized 1131x777), showing only part of the image at 100% of its native resolution (centered 654x480). I wish to scale the image to fit the frame using scaling within track motion. VV5 is rescaling the image automatically for me.
The reason for this is that part of the map contains text and arrows indicating locations, I scaled the original map image in Photoshop so that the text areas will appear full screen at 100% resolution. These text areas represent about a third of the entire image and I want them to appear at full resolution so that there will be no distortion and the text can be read easily. In essence, I want to impart a zoom effect to the text areas of the map by restoring the frame using track motion – having the zoomed area appear at 100% of native resolution. I have already disabled the “stretch to fill” feature in pan and crop for the still. The image is still scaled down by VV5 automatically. Can someone please tell me how to permit the still to spring up to its full resolution?



ADI2000 wrote on 1/19/2005, 10:58 PM
I'm not overly articulate tonight - here's an image of what I mean. Again, any help is greatly appreciated!
Liam_Vegas wrote on 1/19/2005, 11:20 PM
And... what exactly is wrong with simply zooming in using the Pan/Crop tool? Is it that you have a problem letting Vegas do the scaling? If so... then why don't you crop the image in photoshop so that you have the precise area (655x480) so that Vegas does not end up scaling at all.
ADI2000 wrote on 1/19/2005, 11:26 PM
Again, I need the image to appear at 100% resolution for the text to be clean. When I rescale in Vegas, the text gets blurry. Can I do what I need or not?

Liam_Vegas wrote on 1/20/2005, 12:24 AM
I guess I'm not getting it then.

On the page you setup you have a version of the Image that you say is how you want Vegas to display the map... to that exact scale. I say again... why don't you load THAT image into Vegas? It is already scaled to 654x480 right?

I just loaded that jpeg into a project and it appears to display just fine... no blurred text (although the tiny size of the text is inappropriate IMO for legible reading on a TV anyway).

You have set your preview to be Best/Full right?
ADI2000 wrote on 1/20/2005, 12:39 AM
Those are not Vegas screen shots. It is very important for the text to be legible. The problem here is the map is almost twice as tall as it is wide. I need to fit the entire map into the frame, and then zoom to the text portion. I scaled the original bitmap image to the 1131x777 as it works out perfectly in frame to the section I want zoomed. The text appears quite clean this way. There has to be a simple way for Vegas to allow me to let out the image to its native 1131x777. This way I can scroll up and down the image at close-up, then pull out to the full map using the scaling in Vegas.
Again the image I have now is at 1131x777 pixels. I want to have it let out to full res. I will next rescale it using track motion to the full size map. I will next use keyframing to restore to 100% (which will be unscaled by Vegas) so that the text will be viewable at the full native resolution. The way it is now;Vegas takes the 1131x777 image and shrinks it to fit the frame. When I zoom to make the text appear large enough to view, it now has to interpolate the pre-scaled image to the new zoom view. If I can get full resolution from the start; I will be able to zoom to the text area without the interpolating of the image. I’m having a real tough time explaining this, but I simply need the capability to have the 1131x777 image let out to full resolution. This has to be an option within the program…no?
jaegersing wrote on 1/20/2005, 1:22 AM
Have you tried simply keying in the size you want in the track motion window? This seems to work OK in Vegas 4, but on this machine I have no quick way to tell if the image is being rescaled to project size and then blown up again.

Richard Hunter
ADI2000 wrote on 1/20/2005, 2:54 AM

Tried that - no good. I had to select "no" for both “stretch to fill frame” and “maintain aspect ratio” within pan/crop in order to allow the image to "fill out." I next keyed in the values in track motion, and I thought I had it. Unfortunately, the image was truncated, and suffered significantly as if Vegas had blown the image up artificially instead of simply allowing the image to spread out to its native resolution. It's hard to believe that this program doesn't allow such a simple task to be completed. I've seen the effect I'm trying to complete all the time on programs, whereby a map is shown full frame, and a detailed segment is cropped and zoomed including text and fine detail. I sure hope there is a way to do this in VV5. Any assistance is appreciated!

ADI2000 wrote on 1/20/2005, 2:59 AM
Just an updated link to the page with the images:
farss wrote on 1/20/2005, 3:55 AM
if you use track motion then you have a problem. No matter what size the original image was this is what happens.
1) It's scaled to project res, for PAL that's 787x576.
2) That res image is then scaled by track pan/crop.
That's why you're seeing the res drop.

So what you need to use is EVENT pan/crop, that works from the original media res to scale it to fit the project frame.

Of course you still face the various limitations of the video system, you need to watch colors and there adjoining levels etc. Also when rescaling in Vegas set render to Best. If there's only a small section with rescaling taking place it maybe quicker to render that out and patch it back in, that way you can render the rest of your project at Good to save some render time. However if your target is DVD then encode straight from the T/L in this instance for a small boost in quality.

Barry_Green wrote on 1/20/2005, 1:55 PM
You should be able to do this without even using track motion. Just put the big map at full size on the timeline, then right-click and choose Video Event Pan/Crop.

In the Width part, type in 720. In the Height part, type in 480 (or 576 if in PAL). That will give you a full-screen, full-resolution extraction. You can then change the X Center or Y Center parameters (or both) to scroll around the image. You can use keyframes to create smooth motion of full-screen extractions... I think that's exactly what you're trying to do, right?
Liam_Vegas wrote on 1/21/2005, 2:22 AM
I load high-res slides into Vegas all the time. I then do detailed pan/zooms.. and I get perfect results every time. That's why I tried to tell you to use Pan/Crop before... although I notice now from your reply you still talk about using track motion anyway.

I think that Barry has it right. You have been trying to do this zoom using track-motion. You need to use the Pan/Crop tool to do the zoom... not track motion.
rmack350 wrote on 1/21/2005, 10:02 AM
Definitely render at BEST because you want to take advantage of bicubic interpolation. This is what BEST is all about.

Since it's a map with text and other fine, sharp detail, just render that little segment out as uncompressed. That way you lose nothing and can later render for DVD or for DV25 or whatever.

You could just leave it as-is without rendering it at all, of course. This would be best if you plan to actually change the project template or if you're editing for PAL but also want to do an NTSC render. This would be better because vegas would be resampling your original stills at render time instead of the uncompressed PAL render of it. (I doubt that I'm getting the idea across...)

Rob Mack
ADI2000 wrote on 1/22/2005, 8:21 PM
Just want to thank you all for the advice. The pan and crop utility was indeed the way to go in this situation – though some tweaking was necessary. I’ll tell you, it’s amazing how something can be right under your nose, and you don’t see it. I was confused with how VV5 scales an entire image to the video frame, not realizing that the full resolution of the image was there all along – just in an inverse perspective. If anyone is interested in how the final segment for this project appears, you can see it at: I learned a few things while tackling this issue with respect to optimizing a still for video where fine detail is critical. I will relay some of this information below for anyone interested.

When fine detail is necessary; “vector” images are preferred as originals. Rescale your image in a vector imaging program such as Adobe Illustrator, then drop it into a bitmap editing program such as Adobe Photoshop to render the final image. Vector images do not degrade when rescaled. This is especially important if fine details are required, i.e. map and text. Scale the image so that the area(s) to be zoomed appear crisp and clear at 100% zoom in a 655x480 (72 dpi) frame. Now scale the remainder of the document to accommodate the rest of the image. For my map segment; I had an image size of 4444 pixels high. This way, when I zoomed into the text and detail areas; the legibility was maintained. Test your image – you may need to add some document buffer laterally, to accommodate the frame scale upon zooming in pan/crop. In my case, I needed almost as much width for my document as height – so as not to crop out part of the image at full zoom.