Serious questions for 9.0 users

ReneH wrote on 8/10/2009, 10:03 AM
I installed both 9.0 and 9.0a Vegas Pro versions on another computer in hopes of NOT recreating the dreaded "FileSurrogate" or the "ErrorReportingLauncher" error. Unfortunately, both errors presented themselves on the new install.

1. My question, is this a common problem with most installs of the new version?

2. How did you correct this to remedy the problem?

3. Did the changes you made resolve these errors?

As it stands right now, I have a veg file that I want to continue editing but I am locked out from using it since Vegas won't open it, thereby crashing.


Guy Bruner wrote on 8/10/2009, 10:19 AM
I did not experience those errors on my original 9.0 install or after updating to 9a. I am running 32 bit Win XP Pro SP3 (current with patches) on a Q6600 with 2GB RAM
JohnnyRoy wrote on 8/10/2009, 10:33 AM
I have not had those kinds of problems with 9.0 or 9.0a but you now have another data point by installing on a second machine. What is it that your two computers share in common? Do they have the same internet / anvivirus / suite of software? It sounds like something that you have on both machines is causing this. You just need to figure out what.

ReneH wrote on 8/10/2009, 10:35 AM
I have Viper anti virus on on it, which I stopped before I installed. I'm thinking that there is some driver, dll, or program that is screwing with the Vegas install. I'll keep chipping away at this I suppose...
Guy Bruner wrote on 8/10/2009, 11:57 AM
Are you running XP or Vista? Is it up to date with all SPs/patches? You might consider downloading and running the free CCLeaner to get all the junk out of your registry.
ReneH wrote on 8/10/2009, 9:29 PM

I appreciate the help, and in fact I did run XPRegistry Repair Pro and went to Windows updates and did all that as well. Maybe I'll try CCleaner and see if that program finds anything the other missed. Thanks for the help.
ReneH wrote on 8/11/2009, 8:56 AM
CCleaner didn't help at all. I am uptodate on all the WinXP fixes. I'm pulling hairs right now...running out of ideas.

I even tried stoping processes one ata time to see if any of them might be the culprite but no dice.

I'm wondering whether an nvdia driver update I did might be causing the problem?
ReneH wrote on 8/11/2009, 9:04 AM
I am getting this error when I try to open a veg file:

0fe8789d-0c47-442a-afb0-0daf97669317 - Media Generator
0fe8789d-0c47-442a-afb0-0daf97669317 - Media Generator

I suppose this is the problem causing all my woes? Anybody wanna take a stab at this?
xberk wrote on 8/11/2009, 1:55 PM
Are you getting this error with ANY veg file ?
Can you open Vegas and create a new veg?

Paul B .. PCI Express Video Card: EVGA VCX 10G-P5-3885-KL GeForce RTX 3080 XC3 ULTRA ,,  Intel Core i9-11900K Desktop Processor ,,  MSI Z590-A PRO Desktop Motherboard LGA-1200 ,, 64GB (2X32GB) XPG GAMMIX D45 DDR4 3200MHz 288-Pin SDRAM PC4-25600 Memory .. Seasonic Power Supply SSR-1000FX Focus Plus 1000W ,, Arctic Liquid Freezer II – 360MM .. Fractal Design case ,, Samsung Solid State Drive MZ-V8P1T0B/AM 980 PRO 1TB PCI Express 4 NVMe M.2 ,, Wundiws 10 .. Vegas Pro 19 Edit

kairosmatt wrote on 8/11/2009, 2:22 PM
I got a very similar error when I opened a project from one computer on a second computer-the original had BorisFX/Grafiti installed and the second one did not. I had opened BorisFX at some point in the project before moving it, and that prevented me from opening the .veg on a computer without BorisFX installed.

This was with 8.0

So that could be a plugin problem, however I don't know if that would cause the filesurrogate and errorreporterlaunching problems in 9.0

farss wrote on 8/11/2009, 2:47 PM
I've had a very similar problem years ago. None of my archived project could be opened by any version of Vegas hat I had installed. Support couldn't open them either. The symptom was the media generator dll crashing Vegas.

It does seem to me that there are minor changes to the structure of the project files between point releases and forward compatibility is only checked between the last point release of one version and the next version. What I mean here is for example V6.0b can open V6.0a projects and V7.0 can open V6.0b projects however it may not be able to correctly open V6.0a projects.

ReneH wrote on 8/11/2009, 7:10 PM

I am getting the error after I work on a veg file and after I open it a couple times later, the error happens.

Yeah, I can create veggies but after several instances of opening and saving them, the veg file becomes corrput.
ReneH wrote on 8/11/2009, 7:15 PM
The veg file was created on this one sytem with the problem and worked on exclusively on this very same system. I have not imported or exported to any other system. What I did do was open and worked with jpeg's and png's with paint shop pro while I had Vegas opened. That was never a problem with any earlier versions of vegas.
ReneH wrote on 8/11/2009, 7:21 PM
Thanks for your reply.

The veg files I created were on 9.0a version, and not from an earlier version and opened on 9.0a. So it isn't due to backwards incompatibility I am afraid.

So far, I have scoured the registry and deleted all references to Vegas, Newblue plugins, after I deleted them. To make sure I would have a clean reinstall of vegas. That didn't work either, the Error Launcher poped up again.

Ran two registry cleaners, uploaded all Microsoft fixes, including NetFramework 3.5. I ave not done any bios changes for a long while, so I do not think that is the issue. I'm really stumped!
ReneH wrote on 8/11/2009, 8:17 PM
Ok another update in my ongoing saga.

I was abl to reinstall Vegas 9.0a all over again after yet another registry cleansing. I was able to opne the veg file in question, and promptly made a back up by changing under another name should things go awry.

But, no matter what I do, the "Error Reporting Launcher" and "File Surrogate" error are showing up in the process under task manager.

I can't seem to shake them off! LOL!

Any more suggestions?

P.S. No longer getting the Media error as reported in my first post.