Grazie wrote on 5/7/2014, 12:44 AM
Your assumption is correct. CSP2 working well here.


Grazie wrote on 5/7/2014, 1:04 AM
This what I needed to do:

1/- While in CSP SELECT VP12 from the drop down menu AWAY from the GLOBAL option

2/- Copy this selection

3/- THEN navigate to VP13.exe file



What you'll notice is that I did NOT apply any CSP Presets from within a VP13 Folder.

imaginACTION_films wrote on 5/8/2014, 8:29 PM
Thanks, Grazie, I got similar advice from Contour-design and it now works well. It seems Sony used the VP12 .pref files instead of the VP13 one.
Grazie wrote on 5/9/2014, 1:54 AM
Yeah . . . Over the years I've come to realise that maybe CSP and SCS do not share and compare install-activation-pathway-convergency. It would be good if the SCS QA team actually spent time to, and borrowing a phrase from Jean Luc Picard's famous, "Make it so.". - happen!

Come to think of it, just glimpse down at your CSP? Look reminiscent of a "particular" Spaceship? - Coincidence? Yeah well, I think not!


SonyDKF (SCS Dev) wrote on 5/9/2014, 8:45 AM
Thanks for the info, the guys from Contour Design also notified us of this issue and we'll address it for the next VP13 update.

VMP wrote on 5/9/2014, 9:16 AM

Grazie wrote on 5/9/2014, 10:38 AM
Dee, thank you.

Serena Steuart wrote on 5/13/2014, 2:56 AM
Would you mind going through that again? APPLY where? Do you mean paste? My interpretation of your instructions doesn't work.

Grazie wrote on 5/13/2014, 3:04 AM
Do you have an APPLY button?


Serena Steuart wrote on 5/13/2014, 7:09 AM
On the shuttle menu? Yes.

I go wrong at step 3. When I navigate to Vegas 13 there are already pref files for Vegas12, but clearly I don't understand. I've followed John's setup instructions, but I cannot get Vegas 13 to show in the application setting.
dlion wrote on 5/13/2014, 7:23 AM
i can't get it to work reliably. shuttle works, some of the buttons, but not play/pause or play/stop.
Grazie wrote on 5/15/2014, 1:43 AM
OK.... I've been asked for "help" on this, off-forum, so I'll respond here just in case others are needing a further blow-by-blow account of what I do. This is for those that have CSP working in VP12.

NB: All of the following is done within the CSP Device Configuration Menu.

1/- Open "Contour Shuttle Device Configuration".

2/- Click OPEN the "Application Setting" drop down menu.

3/- Locate and select ANY reference to Vegas 13 or VEGAS 130.exe .

4/- Click OPTIONS and "Remove Settings" - This will ensure that any previous reference to VP13 is deleted/removed.

5/- Click APPLY - VERY important!

6/- Click the drop down arrow in "Application Setting" drop down menu.

7/- Locate and select the SONY VEGAS 12 Setting

8/- THEN click "Options" >> "Create New Settings" >> "Copy Contents from Current Settings" and navigate to the VEGAS13.exe file - SELECT it and the VEGAS 13 EXE will appear in the "Application setting" window.

9/- Click APPLY. VERY important!


NB: I've repeated these same 9 steps 4 times, deleting the CSP VP13 references in the CSP Menu, just to make sure, and I have CSP functioning in VP13.

Serena Steuart wrote on 5/15/2014, 2:09 AM
Thanks Graham, that works. Of course I didn't have Vegas 13 listed in the applications which turned out to be a desirable thing. Once I did, your detailed instructions did the trick,
djircik wrote on 6/14/2014, 11:28 PM
Thank you that worked for me here.
Martin L wrote on 4/8/2015, 8:36 AM
Thanks Grazie! (remember me from BVE 2013?)
I got it to work with my new CSPv2 as well.
But considering Wolfgang W's link (,
I haven't tried that yet, but is there any difference between Grazies method and that?

Anyone has some good tips on what functions to use on the buttons, or if the preconfigured setting are good?

Martin L, Sweden
videoITguy wrote on 4/8/2015, 8:51 AM
This should have been fixed in build 373 and beyond with VegasPro13
Former user wrote on 4/8/2015, 9:04 AM

these are mine that I find quite useful.