Since Update, Rendering Jams at random percentage

Paul-McIntyre wrote on 6/30/2022, 8:08 AM

I updated Vegas Pro 19 on Monday and began a video edit. I completed the edit which is around 11 minutes long. Since being a 365 member I have had very little issue but since this update my render just cuts out half way through. It says it is still rendering but it makes no further progress. During the beginning of the rendering process, it doesn't appear to be using a lot of my system's resources. Around 48% CPU, 2gb of memory out of my 16gb and less than 1% of disk usage.

When it gets around the 40-70% completion stage however, the values drop significantly and it only uses about 8% CPU. This is when it jams and stops working.

To resolve the issue I have updated my driver's, checked for system updates, restarted multiple times, cleared the cache in the system, tried new render settings, condensed my timelines on the edit to try and reduce additional pressure and still no resolve.

I'm now going to deactivate GPU processing and dump it on the CPU for encoding and hope that helps (as seen in FAQ).

Is this an issue with the update and is anyone else experiencing this?

I have a pretty solid PC I'm operating and again it's not under much strain here so I can only think that it is a software issue. My video is now a day late and needed to be done yesterday so it is becoming frustrating and I have another edit to have done by Wednesday.

Comments

j-v wrote on 6/30/2022, 8:50 AM

 

Is this an issue with the update and is anyone else experiencing this?

I do not see such things, also not with a test of 2 hours project with 4K AVC and HEVC sources

I have a pretty solid PC I'm operating

Tell us the hardware:

- Processor
- GPU (s??)
- Driverversions(exact numbers)
- Windows version
 

 

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W11 home version 22H2, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti with driver 528.24 Studiodriver and Intel HD graphics 630 with driver
gfx_win_101.2115
Laptop  :Asus ROG Str G712L, W11 home version 22H2, CPU i7-10875H, 16 GB RAM, NVIDIA GeForce RTX 2070 with Studiodriver 522.30 and Intel UHD Graphics 630 with driver gfx_win_101.2115 
Vegas software: VP 10 to 20 and VMS(pl) 10,12 to 17 are installed, all latest builds
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEM CELL DONOR !!!
 

Paul-McIntyre wrote on 6/30/2022, 9:05 AM

 

Is this an issue with the update and is anyone else experiencing this?

I do not see such things, also not with a test of 2 hours project with 4K AVC and HEVC sources

I have a pretty solid PC I'm operating

Tell us the hardware:

- Processor
- GPU (s??)
- Driverversions(exact numbers)
- Windows version
 

 

Thanks for responding.

I'm running the following;

Processor - AMD Ryzen 5 3600 6 Core 3.6GHz

GPU - NVIDIA GeForce GTX 1070

Driver versions (not sure about this one. I use Driver Easy to keep everything up to date and all are up to date.)

Windows 10 - Version 21H2

Just to add, I tried disabling GPU on Vegas Pro and the render jammed on 30% again.

My current plan is to uninstall the software and reinstall an earlier build to try resolve the issue. Any other ideas would be greatly appreciated though.

 

 

j-v wrote on 6/30/2022, 9:37 AM

Driver versions (not sure about this one. I use Driver Easy to keep everything up to date and all are up to date.)

Show here a screenshot of the result after clicking Help/Check for Driver Updates

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W11 home version 22H2, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti with driver 528.24 Studiodriver and Intel HD graphics 630 with driver
gfx_win_101.2115
Laptop  :Asus ROG Str G712L, W11 home version 22H2, CPU i7-10875H, 16 GB RAM, NVIDIA GeForce RTX 2070 with Studiodriver 522.30 and Intel UHD Graphics 630 with driver gfx_win_101.2115 
Vegas software: VP 10 to 20 and VMS(pl) 10,12 to 17 are installed, all latest builds
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEM CELL DONOR !!!
 

Paul-McIntyre wrote on 6/30/2022, 10:05 AM

Hello,

I appear to have fixed the issue by uninstalling Vegas 19 and reinstalling an earlier build. It now renders with no issue. It is clearly a problem since the last update.

Gid wrote on 6/30/2022, 10:12 AM

@Paul-McIntyre Hi, as j-v says Help will show the drivers but Nvidia Geforce Experience is what i use to keep GPU drivers up to date, Studio driver is the one you want https://www.nvidia.com/en-gb/geforce/geforce-experience/

Vegas Pro 20
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Magix Movie Studio Platinum 2023 - from 2004-ish - Latest version,
Magix VPX14
Adobe After Effects
Boris Continuum & Sapphire, 
Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, 
Boris Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 54, I've been a UK joiner for 38yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G
 

Paul-McIntyre wrote on 6/30/2022, 10:16 AM

@Paul-McIntyre Hi, as j-v says Help will show the drivers but Nvidia Geforce Experience is what i use to keep GPU drivers up to date, Studio driver is the one you want https://www.nvidia.com/en-gb/geforce/geforce-experience/

Thank you.

I installed that driver yesterday in the hopes to solve this issue and also have Geforce Experience installed for that reason. It is very odd because the new update wont let me render and my Vegas was crashing a lot during the editing process. I am just thankful that I had an old installation file for Vegas 19 that I was able to install instead, because now it appears to be working fine, which says to me it's not an issue on my end alone.

Gid wrote on 6/30/2022, 10:28 AM

@Paul-McIntyre hmm curious 🤷‍♂️

If you're using one particular type of file there's a tool called MediaInfo, download it, it's free https://mediaarea.net/en/MediaInfo
After downloading, right click on the media in your Windows folder, open MediaInfo, choose Text from the View option, select all, copy & paste in a comment here,

Don't know if this will help in the slightest, but to clear out crap if i think there's a bug in my system, i goto C:\Users\your name\AppData\Local\VEGAS Pro\19.0 & delete everything, Vegas will be slow to open next time but will rebuild all those files & maybe that'll repair a 'link',

also to clear crap from my pc - System - Storage - Temp files,, I tick all boxes n delete,

Can you go to your icon at the top, click it - My Profile, & fill in your Signature with your Vegas version, Windows version & system specs, full name of CPU, GPU, & amount of RAM etc. this will then show at the bottom of the comments 

Vegas Pro 20
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Magix Movie Studio Platinum 2023 - from 2004-ish - Latest version,
Magix VPX14
Adobe After Effects
Boris Continuum & Sapphire, 
Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, 
Boris Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 54, I've been a UK joiner for 38yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G
 

Paul-McIntyre wrote on 6/30/2022, 10:45 AM

@Paul-McIntyre hmm curious 🤷‍♂️

If you're using one particular type of file there's a tool called MediaInfo, download it, it's free https://mediaarea.net/en/MediaInfo
After downloading, right click on the media in your Windows folder, open MediaInfo, choose Text from the View option, select all, copy & paste in a comment here,

Don't know if this will help in the slightest, but to clear out crap if i think there's a bug in my system, i goto C:\Users\your name\AppData\Local\VEGAS Pro\19.0 & delete everything, Vegas will be slow to open next time but will rebuild all those files & maybe that'll repair a 'link',

also to clear crap from my pc - System - Storage - Temp files,, I tick all boxes n delete,

Can you go to your icon at the top, click it - My Profile, & fill in your Signature with your Vegas version, Windows version & system specs, full name of CPU, GPU, & amount of RAM etc. this will then show at the bottom of the comments 

When you say delete everything, is this including files and folders?

Also I am unsure what the purpose of MediaInfo is?

Sorry, I am very much self-taught at this stuff so I am not very clued up on the troubleshooting side of things.

Paul-McIntyre wrote on 6/30/2022, 10:46 AM

@Paul-McIntyre Hi, as j-v says Help will show the drivers but Nvidia Geforce Experience is what i use to keep GPU drivers up to date, Studio driver is the one you want https://www.nvidia.com/en-gb/geforce/geforce-experience/

Thank you.

I installed that driver yesterday in the hopes to solve this issue and also have Geforce Experience installed for that reason. It is very odd because the new update wont let me render and my Vegas was crashing a lot during the editing process. I am just thankful that I had an old installation file for Vegas 19 that I was able to install instead, because now it appears to be working fine, which says to me it's not an issue on my end alone.

Okay so it rendered the first draft, I made some adjustments and now we are back to square one with it jamming during rendering at 68%. This is so frustrating.

Paul-McIntyre wrote on 6/30/2022, 11:01 AM

Driver versions (not sure about this one. I use Driver Easy to keep everything up to date and all are up to date.)

Show here a screenshot of the result after clicking Help/Check for Driver Updates

 

Here you go :)

Gid wrote on 6/30/2022, 11:19 AM

@Paul-McIntyre Different media can have different effects on Vegas, some it likes some it doesn't, MediaInfo shows the details of that media,

delete everything, is this including files and folders? which one are you talking about, the file for Vegas AppData is just 'temp build' files, yes select all n delete, Vegas will recreate all those,

In System - Storage - Temp files there is no 'files n folders' , you can decide which to delete but i just tick all,

If your render is failing at a similar point each time, have a look on the timeline & see if there's an event/media that's different or has an fx on it, sometimes just a simple rotation of the image or a change in media from landscape 16:9 to portrait 9:16, or an fx that is hard to deal with, any can mess with Vegas's head. There was someone last yr, his project would render slow but ok, no fx's but when it got to a bit of media that was portrait not landscape it would crash, this was all because of the type of media + the change in aspect ratio 🤷‍♂️

' I made some adjustments' ? was this to the media or to Vegas? my Vegas is pretty much at the default settings,

Last changed by Gid on 6/30/2022, 11:25 AM, changed a total of 1 times.

Vegas Pro 20
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Magix Movie Studio Platinum 2023 - from 2004-ish - Latest version,
Magix VPX14
Adobe After Effects
Boris Continuum & Sapphire, 
Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, 
Boris Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 54, I've been a UK joiner for 38yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G
 

Gid wrote on 6/30/2022, 11:21 AM

@Paul-McIntyre yep same as me

Vegas Pro 20
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Magix Movie Studio Platinum 2023 - from 2004-ish - Latest version,
Magix VPX14
Adobe After Effects
Boris Continuum & Sapphire, 
Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, 
Boris Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 54, I've been a UK joiner for 38yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G
 

Paul-McIntyre wrote on 6/30/2022, 11:31 AM

@Paul-McIntyre Different media can have different effects on Vegas, some it likes some it doesn't, MediaInfo shows the details of that media,

delete everything, is this including files and folders? which one are you talking about, the file for Vegas AppData is just 'temp build' files, yes select all n delete, Vegas will recreate all those,

In System - Storage - Temp files there is no 'files n folders' , you can decide which to delete but i just tick all,

If your render is failing at a similar point each time, have a look on the timeline & see if there's an event/media that's different or has an fx on it, sometimes just a simple rotation of the image or a change in media from landscape 16:9 to portrait 9:16, or an fx that is hard to deal with, any can mess with Vegas's head.

' I made some adjustments' ? was this to the media or to Vegas? my Vegas is pretty much at the default settings,

Thanks again,

I haven't used any different media compared to what I usually use. All it is, is MP4 files, MP3 and PNGs. So I can't comprehend how it would be a file type issue.

I have now cleared out all the temp files and ran the render again but still without luck.

I have had a look at the part where it continues to jam and I cannot figure out what it could be. If it were near the end of the video, I would understand as I have a few effects on but in this particular area it is no different that the rest.

The adjustments I had to make was some cropping on some clips. I have used event pan/crop to resize some clips. I have multiple streams of video running simultaneously in the video in which 4 perspectives can be seen at once. Before I adjusted them, it had reset to 1 clip on screen which may explain why it worked okay.

I have just updated (again) to the current Vegas 19 update as the issue appears to be somewhere else.

The render I have just done has failed again however, in the exact spot so I am going to try investigate it further.

Really appreciating the assistance.

Gid wrote on 6/30/2022, 11:48 AM

@Paul-McIntyre MP4 is just a container, within that container can be different info/formats/codecs, that's where MediaInfo comes in, 😉👍

Last changed by Gid on 6/30/2022, 11:50 AM, changed a total of 1 times.

Vegas Pro 20
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Magix Movie Studio Platinum 2023 - from 2004-ish - Latest version,
Magix VPX14
Adobe After Effects
Boris Continuum & Sapphire, 
Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, 
Boris Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 54, I've been a UK joiner for 38yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G
 

Gid wrote on 6/30/2022, 11:55 AM

@Paul-McIntyre 

Can you go to your icon at the top, click it - My Profile, & fill in your Signature with your Vegas version, Windows version & system specs, full name of CPU, GPU, & amount of RAM etc. this will then show at the bottom of the comments 

👍😉

Vegas Pro 20
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Magix Movie Studio Platinum 2023 - from 2004-ish - Latest version,
Magix VPX14
Adobe After Effects
Boris Continuum & Sapphire, 
Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, 
Boris Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 54, I've been a UK joiner for 38yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G
 

Paul-McIntyre wrote on 6/30/2022, 12:00 PM

@Paul-McIntyre 

Can you go to your icon at the top, click it - My Profile, & fill in your Signature with your Vegas version, Windows version & system specs, full name of CPU, GPU, & amount of RAM etc. this will then show at the bottom of the comments 

👍😉

Sorry, I will definitely update that in a moment. I do however think you have figured out the solution. I just deleted that clip at the 68% mark and it appears to be working. A bit bizarre given that it is just a split section of the clip before it, but for whatever reason it looks like it was corrupting the file.

I will update all that info in my signature once the render is done, or crashes.

Gid wrote on 6/30/2022, 12:19 PM

 

@Paul-McIntyre for some reason i can't upload videos on here so this is on YT,

MediaInfo, https://mediaarea.net/en/MediaInfo you'll be able to analyse that dodgy clip you removed, the more you use this tool the easier it is to understand at least the basics,

Last changed by Gid on 6/30/2022, 12:21 PM, changed a total of 1 times.

Vegas Pro 20
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Magix Movie Studio Platinum 2023 - from 2004-ish - Latest version,
Magix VPX14
Adobe After Effects
Boris Continuum & Sapphire, 
Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, 
Boris Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 54, I've been a UK joiner for 38yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G
 

Paul-McIntyre wrote on 6/30/2022, 1:09 PM

My issue was around one specific clip on my timeline. I had 4 videos of 4 people all running simultaneously almost like a Teams/Zoom meeting. These 4 clips were then broken into parts for a "best bits" style video. Due to this the 4 clips were chopped up, alongside their audio, to fit a smaller video. For whatever reason one person's footage had an issue in the clip, lets call them person 3. I had split up person 3's clips and all were fine and would render until it reached one split clip. I question if this clip may have been corrupted during a software crash when editing yesterday, because as soon as I deleted that section it worked perfectly fine.

Overall, very confusing but thank you to Gid for suggesting I isolate where the issue was.

Hopefully I wont run into any issue during the next edit.

Gid wrote on 6/30/2022, 3:43 PM

@Paul-McIntyre Good, glad you found the issue, it's all learning from crashes & i hope all does go well but i'm sure with Vegas there will be more 'learning' in the future 🙊😂👍

Vegas Pro 20
Vegas Pro/Post 19 (Latest build), HitFilm Pro,  
Magix Movie Studio Platinum 2023 - from 2004-ish - Latest version,
Magix VPX14
Adobe After Effects
Boris Continuum & Sapphire, 
Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, 
Boris Optics,
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(programs on one, project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 Fans

I'm 54, I've been a UK joiner for 38yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G