so how is it working w/UAD now?

wazer wrote on 1/29/2006, 7:15 PM
please let me know how is Vegas working with the UAD card these days?

I'm planning to buy one, but i just saw at the UA forums the newest software upgrade no longer supports DX. As i know the only way to working with UAD/Vegas is using DX-type UAD plugins to avoid that plugin-dealy-thing.

Or is it working properly at all?




PipelineAudio wrote on 1/29/2006, 9:20 PM
Not here...Im sure its working perfect for everyone else though
H2000 wrote on 1/29/2006, 10:04 PM
I am using UAD-1 version 3.9 and Vegas 5. It's working O.K. for me. Vegas6 adds VST capability, but there is a problem in that UAD-1 plugins no longer render with it.

So, my answer would be if you need to render any of the plugins, then no it does not work. And if you are buying a new UAD-1, you will probably have the latest software which no longer supports DX. That means you will have to use Vegas6 with the VST versions and will not be able to render.
drbam wrote on 1/30/2006, 6:40 AM
So it looks like if you want to use the current UAD-1 plugs with Vegas, then you will need to mix through a console because the efx won't render?? Incredible!!

Ben  wrote on 1/30/2006, 7:22 AM
Hmmm, I don't find this to be the case with 6c. The UAD DX plugs render fine, as do the VST ones. The key is not to mix and match the VST with the DX ones, though using the UAD VSTs with other brand DX plugs seems fine. Make sense?
H2000 wrote on 1/30/2006, 12:10 PM
Ben, are you saying that version "c" fixed this problem? Because I know version "b" had the problem, and I see nothing in the "c" release notes to indicate it was fixed. Also, I asked customer support and posted here asking if it was fixed and nobody could tell me.

I went to demo the "c" version, but my 30day trial of the "b" version had expired.
PipelineAudio wrote on 1/30/2006, 1:36 PM
6 c here and I cant render, it gives the "buffer size mismatch" if I try to render

Mute/unmute and solo/unsolo are less likely to crah the program now, Id say 75% of the time will crash rather than 99%
mangooo wrote on 1/30/2006, 1:43 PM
6 c here and it works great with the vst versions of the pluggz. No probs for me anymore.
Ben  wrote on 1/30/2006, 2:34 PM
Yup - as long as you don't mix and match the UAD DX & VST plugs in the same session, seems fine. Don't know when it starting working again; maybe on version b.

I'm still damn annoyed UA have dumped DX support though - backwards compatiblity goes out the window. Grrr. Until they release some plugs I actually want to buy, I'm sticking with 3.9 here.

Ben  wrote on 1/30/2006, 2:36 PM
And btw, for those of view who don't know about this, do check out REAPER -

Many of us Vegas Audio guys have been busy on the forum there... this is quite an app in the making, and it's happening damn quickly! :)

Request your favourite Vegas feature before it's too late...

Ben  wrote on 1/30/2006, 2:41 PM
" see nothing in the "c" release notes to indicate it was fixed."

Yep, hmmm - plenty of times they've fixed bugs I've reported and not mentioned it in the release notes. I guess they're embarrassed of the bugs! Crazy.

PipelineAudio wrote on 1/30/2006, 3:00 PM
I am only using the VST versions here and cant render

What is your sound card/buffer setup ad your uad buffer setup?
Ben  wrote on 1/30/2006, 3:10 PM
That's mad. Echo Mia Midi here, running ASIO at 512 samples at the moment... though any of the buffer sizes seem to work fine. The UAD itself is just on the default settings.

Still get the old munching problem though :-|
H2000 wrote on 1/30/2006, 6:17 PM
I know it wasn't working for me in version "b" (using VST only). Like I said, I can't test "c". I tried to get a confirmation from Sony that it may be fixed so I could consider buying it (I actually did buy "b" and Sony let me return it for refund when I found out it didn't render (they didn't argue)). But, they were not able to give me any response. Of course now I will just wait for Acid Pro 6, but...

I assume since Pipeline's is not working that there still are problems (was your DX versions in V5 rendering, Pipe?).

And, I agree about the backward compatibility thing from UA - it's lame not to be able to go back to old projects.
PipelineAudio wrote on 1/30/2006, 6:24 PM
UAD-1 DX renders many times worked in V5, many times didnt

Certain combos of routing order could cause it not to, as well as any look ahead type plugins
klangtone wrote on 4/11/2006, 10:48 PM
btw. I just got Vegas6.0d and it does not render with my UAD plug-ins! So the problems continue.

Sony, please help us.