Sony Vegas Color Correcting Problem - PLEASE HELP!

MadMaverick wrote on 1/1/2014, 2:36 AM
I've been having a problem with white balancing my footage using my color corrector. I figured it'd be easier to explain my problem visually, so I shot this quick little video describing my problem. I apologize for the poor quality.

Here's the link:

Any help or info would be greatly appreciated.

Thanks, and Happy New Years!



Grazie wrote on 1/1/2014, 2:46 AM
I don't see your problem!? I have a perfectly BLANK white screen. I think your YT link needs a bit more assistance. I'm viewing on my iPhone which gives great YT downloads so it can't be my end.

In any event, I'm sure we'll get a cure for yah!

WillemT wrote on 1/1/2014, 3:18 AM
From your video it appears you have the "Split screen" button depressed. Is "FX Bypassed" perhaps selected?

Grazie wrote on 1/1/2014, 3:22 AM
Still can't see it.....?


WillemT wrote on 1/1/2014, 5:07 AM

Clicking the link does not work. If I paste into Firefox the link updates and it plays.

wwjd wrote on 1/1/2014, 10:28 AM
I would ignore the "Windows glitch" at the bottom and focus on the coloring problem. Windows hiccups over the weirdest things and it should not affect Vegas coloring.

Having used the BLACK and WHITE SELECT TRICK a while, I understand what you are doing and it generally works okay. From what I see on your YOUTBE, it LOOKS like the black AND the whites are decent black and white, so that part worked, BUT you still have that yellow cast, I assume you wish to remove?

- what happens when you just drag the color wheel dot around drastically? all the way to the outer edge or BLUE or something? You can always double click to re-center it and try again.

- Which Vegas version are you using? No WHITE BALANCE plugin in it?

Maybe time to mess with COLOR CURVE and RGB PARADE scope. I learned after watching a 45 minute video of a pro doing stuff, you can line up the Red, Green, Blue in the RGB PARADE and that usually balances everything. --There are ALWAYS exceptions, of course.

Open the COLOR CURVE, select BLUE, double click the slant line right in the middle and pull it toward the upper left and watch the RGB PARADE raise the blue area. Try to match the Blue and Green to the higher RED. Might help.

But it sounds like your real problem is why is the color corrector not doing anything? Not sure, other than grab the center button and push it around manually to SEE if it is doing anything or not.

Can you post that footage up somewhere for us to download and mess with? I downloaded your youtube, but that was not too effective. :)

musicvid10 wrote on 1/1/2014, 12:56 PM
Plain as day. Deselect the split screen button at the top of your preview.
Grazie wrote on 1/1/2014, 2:37 PM
I see it now. When you Click to Select an area of colour, the FX BYPASS Icon gets depressed! Now THAT I haven't seen before. Never ever.

Seriously? It would appear that your install of Vegas would appear to be hosed and needs to be reset to Factory Reset.

Not seen this before....


wwjd wrote on 1/1/2014, 2:38 PM
Grazie wrote on 1/1/2014, 2:44 PM
Yeah . . Reboot.


mdindestin wrote on 1/1/2014, 5:50 PM
Wow, you chose a shot of a guy sitting on a toilet to share with us?

You'll have to excuse me, I'm from an earlier generation.
MadMaverick wrote on 1/2/2014, 1:44 AM
I've tried using the color corrector eye dropper with the split screen view button selected and un-selected, and it doesn't work either way.

My typical method of color correcting is to select the Studio RGB to Computer RGB Pre-Set. That generally gives it an all around good look. Then I do my Black and White selection trick to balance out the colors. I do this even if I white balanced my camera with the shot, because it still makes a difference. Then I'll adjust it as needed.

Color correcting can be a frustrating process for me. When I watch my final clip, I'll think to myself, "That shot is too saturated," or "this shot needs darkened" It can become a seemingly endless process... but I'm a bit OCD, so this is probably just a personal problem lol.

I'm not sure what you mean by my install is "hosed"? By "reboot" do you mean that I should un-install my Sony Vegas 10 program and then re-install it? Will that solve the problem? I'm a little scared of going through the trouble of doing this and having the problem persist.

One thing I forgot to say in the video was, at the top of the window for Sony Vegas, where it says, "File, Edit, View, Insert, Tools etc..." I've had the words look like they were too big for the window, and not even show completely. It seemed like something at the bottom didn't look like it fit as well. I don't even know how this would happened, but when it'd look like this, the color correcting eye dropper would work just fine.

Between this and the program window flickering, I was led to believe that maybe there was something wrong with my computers display settings.

Anyway, thanks everybody for your help. I'm glad I found these message boards.
willqen wrote on 1/2/2014, 3:48 AM
Vegas is corrupted.

Maybe its only temporary and all you need to do is shut down Vegas and restart Windows.

Try again.

But, if like you say, your menu items ie., "file"' "edit" "view" etc., persist at being to large to fit or, otherwise not the right size or in the right place this is telling you that something is definitely wrong with Vegas.

If it persists even after you restart Windows, then you will have to re-install Vegas as it is certainly corrupt.

Good Luck,

Grazie wrote on 1/2/2014, 3:49 AM
Yeah, all of what you're saying is pointing towards a Graphics issue rather than a straight Vegas issue.

Good luck,


MadMaverick wrote on 1/2/2014, 10:25 PM
Well, I un-installed Vegas Pro 10, then re-installed it... and just as I feared... it's STILL not working. I even tried re-starting my computer.

I also tried using the color correction eye dropper on my old Sony Vegas Pro 9 program, and I have the SAME problem on there.

I'm thinking that there's something up with Windows 7... or perhaps with my computer all together. I haven't been using this computer very long, and I don't believe the black/white eye dropper selection trick has ever worked on here.

I don't have a Windows 7 re-installation disc, but I do have a Windows Vista one that went to my old computer (which I'd successfully use the eye dropper on). I was thinking of resorting to extreme measures, by re-booting this computer using my Vista re-installation disc. I've heard alot of bad things about Vista, but I've never had any problems with it.

Any more tips or info would be greatly appreciated.
wwjd wrote on 1/2/2014, 10:44 PM
pull up a couple standard colors like purple (for black) and yellow (for white) in your time line, then try the dropper trick on those..... does anything change?

what happens when you move the controls manually in the color wheels, anything?

maybe try a completely different clip also.... that one did very little when I tried it in Vegas 12 (I downloaded your Youtube to play with)
MadMaverick wrote on 1/5/2014, 5:17 PM
I FINALLY found out why the eye dropper wasn’t working on the Sony Vegas color corrector.

I logged onto the Guest User and tried out Vegas on there. The eye dropper worked perfectly. This initially led me to believe that there was something wrong with my user account… but I noticed that the display on the Guest User was set to “Smaller” which is the default. I then tried the eye dropper out on the “Medium” display, and it also worked, but the “Larger” display didn’t work, which is what my user account is set on.

So I guess I’ll start using the medium display. I think I’ll get use to it. It seems to make the picture look sharper. What is the recommended size display for monitors? I didn't think that it really made any difference. I guess Vegas just can't handle the large display. I guess I was right about my impression that the window and text didn't seem to somehow fit the screen.
wwjd wrote on 1/5/2014, 5:23 PM
where are you seeing smaller, medium displays? something in vegas, or windows or what? I don't understand?
Dan Sherman wrote on 1/5/2014, 8:45 PM
The guy in the video is sitting on a toilet, right!
Maybe this is a joke?
MadMaverick wrote on 1/7/2014, 6:03 PM
wwjd, it's in Windows.

On you computer, go to Control Panel > Appearance and Personalization > then under Display click on Make text or other items larger or smaller. There are 3 settings:

Smaller - 100% (default)

Medium - 125%

Larger - 150%

Mine was set on Larger, which is what caused my problem. On Smaller and Medium though it works. I changed over to Medium.

Oh, and for anyone who's curious. This shot of me on the toilet is from an old Indiana Jones 4 movie review that I shot with my brother. I thought it'd be funny to get up in the middle of the review and take a dump... and I continue the review on the toilet lol. I was just going back and polishing this video up a bit.