Sony Video Capture fails on startup

earthrisers wrote on 8/23/2015, 4:51 PM
Vegas 13 on Windows 8.1...
I have a camcorder connected to the computer via firewire.
I choose File/Capture Video
...and I get a popup box saying:
Sony Video Capture
An error occurred starting Video Capture.
Error 0x800703ed (message missing)
Pretty useless.
It's not a problem with Firewire connection - Windows recognizes the device. But Video Capture fails to come up at all.
I will obviously try reinstalling Vegas, but I'm antsy about whether it's going to work. Has anyone else experienced this??


earthrisers wrote on 8/23/2015, 5:15 PM
Follow-up: I find that vidcap doesn't exist on my system.
When I installed Vegas13, I'm sure I specified to do the default install, rather than custom. But there's no Vidcap program on my system.
Is it possible to get that program separately somewhere to download and install?
...or is there a different video-capture program that will work in Windows8.1 over firewire?
Former user wrote on 8/23/2015, 5:30 PM
Vidcap is installed with Vegas, so I am surprised it does not show up. Unless you have deleted or disabled it, it should be there. It should be vidcap60.exe (not just vidcap.exe)
earthrisers wrote on 8/23/2015, 5:42 PM
More... I'm trying to capture 720x480 SD footage from the camera. I discovered that in Preferences, selecting the Sony Vidcap software doesn't work. I Deselected the preference, and now Vegas' built-in Capture utility launches properly.
But it doesn't recognize my video camera (a Sony FX1000). "Device Not Available", regardless of which Device Type I choose.

Fortunately, I still have an old Win7 32bit machine with Vegas10 on it. On that machine, video capture in Vegas10 works properly. Looks like my only recourse is to do the capture on the old machine to an external disk, then move that disk to the new Win8.1 machine to bring the file into Vegas13.
Awfully inconvenient workaround, especially since I was planning on "fully retiring" the Win7 system!
earthrisers wrote on 8/23/2015, 6:07 PM
Yet more... while a tape capture is running on my Win7/Vegas10 system, I searched for vidcap60.exe on my Win8/Vegas13 system. I did find it, just not where Vegas thought it would be.
When I run it, I get the error I originally reported... "missing error message" and the program fails to run.
musicvid10 wrote on 8/23/2015, 6:12 PM
Search Device Mangler for Legacy 1394 drivers.
ushere wrote on 8/23/2015, 6:41 PM
+1 musicvid10

Jillian wrote on 8/23/2015, 7:51 PM
+ 2 musicvid10

Forget capturing with Vegas.

Install the free utility WinDV which works much better and is far easier to use. I'm sure there are still other free DV capture utilities around, but WinDV is the best I've used.
OldSmoke wrote on 8/23/2015, 8:28 PM
Actually HDVSplit is what must people use/used because the HDV scene defection is broken in Vegas ever since it was introduced.

Edit: SD capturing with Sony's VidCap software does work very well and as many have pointed out may require to change over to legacy 1394 drivers.

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)

Grazie wrote on 8/23/2015, 9:53 PM
Capture via FireWire in Vegas works fine. You need, as others say, to select the Legacy Driver for the FireWire port chipset. It's a two minute process. Then capture via FireWire works fine. I had to do it when I got my new Win7 machine.


farss wrote on 8/24/2015, 1:59 AM
No problem for me needing legacy drivers or anything else with WIn7.

Reading the OP's posts though he seems to have confused Vegas's VidCap60.exe which is what he needs to be using to capture DV with Vegas's internal capture which is only for HDV.

There's a further source of confusion, how the camera / VCR configures its firewire port. The FX1000 is a HDV camera and by default it'll configure its firewire port to talk the HDV protocol. When / if the DV tape starts to play the camera recognizes that it's a DV tape and changes how the firewire port is configured.

Best to go into the cameras menu and change the firewire setting from Auto to DV. Start VidCap and then all should be OK.

Grazie wrote on 8/24/2015, 2:05 AM
@farss: "No problem for me needing legacy drivers or anything else with WIn7."

Sure, but if they are NOT selected the f/w port is blind to Vegas. When I and others had selected it, VidCap.exe, worked. This is all we are saying Bob. Win7 by default did NOT select it for me, I had to do it manually.

Once we can confirm this then that source of potential confusion will be removed from the issues, and move on.

No confusion here.


musicvid10 wrote on 8/24/2015, 8:07 AM
Chances for success are greater if one has a TI chipset in their fireware interface.
Many of the adapters being sold do not.

earthrisers wrote on 8/24/2015, 10:59 AM
Lack - of Progress update...
I uninstalled Vegas on the new system and reinstalled. Then my internet modem failed, so I could not "register" Vegas and so cannot use it. So I won't know whether or not ithe reinstall solved my original problem until late this afternoon, after a Cox Cable technician has got me back on the Net. (I'm writing this on my iPad, connected via Verizon wireless network rather than Cox.)
I'm having one of those weeks when something breaks, and then the thing you need to analyze that problem breaks in turn, and the thing that you need to fix THAT breaks in turn...
My part of the planet is passing through a Technology Failure cloud.
farss wrote on 8/24/2015, 3:21 PM
[I]Sure, but if they are NOT selected the f/w port is blind to Vegas. When I and others had selected it, VidCap.exe, worked. This is all we are saying Bob. Win7 by default did NOT select it for me, I had to do it manually.[/I]

Vegas has nothing to do with it, Vegas does not capture DV, VidCap60.exe does.
If Vegas does identify the device and you're trying to capture DV then you have a problem.
What is selected is determined by the device, not the OS.
Vidcap60.exe is a standalone program, I've simply copied it onto PCs and run it, don't need to install Vegas for it to work.

The issue that I'm describing arises using WinXP, Win7 and OSX.

Yes, fiddling around with all manner of things may eventually fix the problem on both Macs and PCs but that doesn't mean you've identified the actual cause of the issue on either your Mac or PC.

The real problem appears to be how firewire devices identify themselves to the OS. When a HDV device is connected to a computer the OS MAY identify it as that depending on how the device is setup. If it's setup as a HDV device and you're trying to capture DV with Vegas it will fail as soon as the tape with DV recorded on it goes over the heads. If you're trying to use VidCap60.exe that'll fail too.

We've even configured HDV VCRs firewire ports as "DV" for a customer and they've still had issues. Problemo is most of the HDV cameras and VCRs by now have dead "CMOS" batteries, by the time the user went to use the thing it'd lost the setup and reverted to "HDV".

The first thing the OP needs to do is check the setup of his FX1000 before he connects it to the PC.

videoITguy wrote on 8/24/2015, 4:32 PM
Bob, is entirely correct in the thrust of his last post above. The firewire protocol indentifies a sender and the receiver has to be prepared for that handshake.

Virtually all cameras of any quality of the HDV period had menu config to help with this.

It is also something you find in the nature of any cross connection between any firewire hardware - say a camera with firewire connected to a vcr with firewire port has to have the protocol properly setup and connected before they talk.
Grazie wrote on 8/24/2015, 11:07 PM
Most illuminating guys. Thank you.