Speakers play pure static when Vegas is opened

Ian-Harrington wrote on 2/13/2022, 8:15 PM

So I've just downloaded Vegas Pro 19 and am having a very strange issue. When playing sound in other programs, everything is fine. I'm on a brand new Acer Nitro 5 laptop and have had no problems with it thus far. But upon installing Vegas today I started to get pure static from my right speaker. I've checked my drivers are up to date and made sure I'm on the latest version of Windows 10 so I'm sure the problem isn't related to the computer itself but something to do with Vegas. Especially since after I boot vegas up and encounter the issue within the editor it begins to effect any other program that plays audio, including basic system alert sounds and tones.

Interesting side note, if I plug in a pair of headphones Vegas and other programs play sound fine. So whatever has happened must be only effecting the right speaker.

Comments

Dexcon wrote on 2/13/2022, 8:54 PM

In Vegas Pro 19, go to menu item Options / Preferences / Audio Device (tab) and have a look at the options in the Audio Device Type field. Usually, the default audio device is Microsoft Sound Mapper, which is the option I've always used. If it isn't, change it to Microsoft Sound Mapper and see how that works. Also in the Audio Device Type field, try your computer's audio device which usually is also an option - for example, I get the option of Realtek ASIO as that is my computer's inbuilt audio device.

If none of that works, hit the Windows key on your keyboard at the same time as 'R' - the Run window should open. Type in Control Panel and hit OK. Select Hardware and Sound and then under Sound hit Manage Audio Devices. In the Playback tab, your computer's speakers are likely to be set as the default playback device (green spot with a white tick over the speakers icon. Highlight the speakers listing and then hit Properties and go to the Advanced tab. There are 2 items under Exclusive Mode. If they are checked, uncheck them and see if that solves the problem.

That there is no problem with headphones plugged in suggests that the problem more likely lies with the speakers audio settings in the computer. I would think that plugging in the headphones auto changes the playback device from speakers to headphones in the computer's Manage Audio Devices. If the problem was caused solely within Vegas Pro, it would follow that the static would exist with any playback device choice on the computer.

Cameras: Sony FDR-AX100E; GoPro Hero 8 Black

Installed: Vegas Pro 16 Edit, Vegas Pro 17 Edit, Vegas Pro 18, Vegas Pro 19 Edit, Vegas Pro 20 Edit, HitFilm Pro 2021.3, BCC 2022.5.1, Mocha Pro 2022.5.1, Ignite Pro, NBFX TotalFX 7, Sound Forge Pro 16, SpectraLayers Pro 9, iZotope RX9 Advanced

Windows 11

Dell Alienware Aurora 11

10th Gen Intel i9 10900KF - 10 cores (20 threads) - 3.7 to 5.3 GHz

NVIDIA GeForce RTX 2080 SUPER 8GB GDDR6 - liquid cooled

64GB RAM - Dual Channel HyperX FURY DDR4 XMP at 3200MHz

C drive: 1TB M.2 PCIe NVMe SSD

D drive: 6TB WD 7200 rpm Black HDD 3.5"

E & F drives: 2 x 2TB Barracuda HDDs 2.5"

 

Ian-Harrington wrote on 2/13/2022, 10:11 PM

In Vegas Pro 19, go to menu item Options / Preferences / Audio Device (tab) and have a look at the options in the Audio Device Type field. Usually, the default audio device is Microsoft Sound Mapper, which is the option I've always used. If it isn't, change it to Microsoft Sound Mapper and see how that works. Also in the Audio Device Type field, try your computer's audio device which usually is also an option - for example, I get the option of Realtek ASIO as that is my computer's inbuilt audio device.

If none of that works, hit the Windows key on your keyboard at the same time as 'R' - the Run window should open. Type in Control Panel and hit OK. Select Hardware and Sound and then under Sound hit Manage Audio Devices. In the Playback tab, your computer's speakers are likely to be set as the default playback device (green spot with a white tick over the speakers icon. Highlight the speakers listing and then hit Properties and go to the Advanced tab. There are 2 items under Exclusive Mode. If they are checked, uncheck them and see if that solves the problem.

That there is no problem with headphones plugged in suggests that the problem more likely lies with the speakers audio settings in the computer. I would think that plugging in the headphones auto changes the playback device from speakers to headphones in the computer's Manage Audio Devices. If the problem was caused solely within Vegas Pro, it would follow that the static would exist with any playback device choice on the computer.

Thanks for the suggestions but none of that worked. I have to imagine that Vegas is the cause of the problem if not the direct root though because this issue did not exist prior to installation of Vegas and only occurs once Vegas is active. It's especially weird because even switching between applications to go back to vegas causes a short burst of static upon re-entering the program, even though nothing is playing.

 

That all being said I kept kicking around in audio settings and went to "Spatial Sound" and turned the options there to off. Seems to have worked for now, though just changing from one option to another worked temporarily. Only thing I can think of is that Vegas must be crashing up against some kind of setting related to that and just producing static as a result. Will update if the problem crops back up but I saw this same issue get brought up on the forum before without resolution so if anyone else wants to post some suggested fixes I'm sure someone else may find them useful if my problem indeed has been resolved.

Devin-Lewis wrote on 8/29/2022, 8:09 PM

Ian-Harrington did your problem go away? I am having the exact same problem with my recently purchased acer predator helios 300 laptop and with Vegas Pro 20. I've had the laptop for a few months now and installed vegas a few days ago. Every time I open vegas it makes just one speaker get crackly, with all system audio and tones in any program not just sound in vegas. Turning the laptop off and on again makes the problem go away, until I open vegas and the problem immediately starts again. My spatial sound is already off, I've uninstalled and reinstalled the audio drivers, made sure everything is up to date, and I'm at my wit's end. 😞

Ian-Harrington wrote on 8/29/2022, 9:23 PM

Ian-Harrington did your problem go away? I am having the exact same problem with my recently purchased acer predator helios 300 laptop and with Vegas Pro 20. I've had the laptop for a few months now and installed vegas a few days ago. Every time I open vegas it makes just one speaker get crackly, with all system audio and tones in any program not just sound in vegas. Turning the laptop off and on again makes the problem go away, until I open vegas and the problem immediately starts again. My spatial sound is already off, I've uninstalled and reinstalled the audio drivers, made sure everything is up to date, and I'm at my wit's end. 😞

Went away for awhile and then kicked back up when Windows did an update. The "solution" I've found is only a partial one cause I have to keep doing it every time I open Vegas now but it does work.

So open Vegas, issue should start pretty quickly after that. Go to speaker settings, advanced, and uncheck all boxes, particularly anything related to "allow programs to adjust sound settings" or something similar to that. Sorry away from my laptop atm so just going off memory. Once you've unchecked those boxes, hit apply and the issue should stop. If not try rechecking the boxes, applying the change, and then play some audio for a second before unchecking them and applying the change again. Idk why but even if when I open the speaker settings the boxes are unchecked it still does this so sometimes I gotta cycle it once or twice. Hope this helps. I'd forgotten about this post so I'm going to have to try the spatial sound trick again to see if it's more permamemt.