SVMS PE v8.0b: Crash on exit (first ever crash!)

Himanshu wrote on 8/29/2007, 8:41 PM
Just installed SVMS PE v8, and patched it to v8.0b. On the very first attempt to use it, I imported a few HDV clips (.m2t files), set them on the timeline, previewed them, and explored this new version a little bit.

Selected File > Exit and chose not to save the project. My very first crash with SVMS in many years of using SVMS occurred on exit - any ideas why or what to do?

VegasMovieStudioPE80.exe - Application Error
The instruction at "0x031c2fa9" referenced memory at "0x03234f20". The memory could not be "read".

Click on OK to terminate the program


Eugenia wrote on 8/29/2007, 8:46 PM
File a bug report with Sony's online system.
Himanshu wrote on 8/29/2007, 9:03 PM
OK, I looked in the Help menu in the software and I searched around on the web site and the closest thing I could find to filing a bug report was an option to call or email for product support.

Could you point me to where exactly I can file an online bug report?

Himanshu wrote on 8/30/2007, 4:51 PM
Thanks. Opened a support case, 070830-000152.
Himanshu wrote on 9/4/2007, 7:35 PM
Any ideas about response times for support requests? I filed mine on 8/30 and today is 9/4 and no reply...
ADB wrote on 9/5/2007, 3:09 PM
Is the error reproducible with all other apps terminated ?
Himanshu wrote on 9/5/2007, 5:23 PM

Yes, I can reproduce the error even after shutting down almost all processes and certainly all non-essential processes. I used EndItAll2 to kill about 20 processes (something I'm used to because of Pinnacle Studio) and also went through adminstrative tools > services and shut down some more services. Then I started SVMS 8.0b and after it was done loading, immediately clicked on the "X" button on the window frame to exit and the crash occurred as usual.

Does that give you any further clues?
stevefoobar wrote on 9/5/2007, 8:31 PM
This appears to be a bona fide bug because I'm getting a very similar error on closing with only slightly different memory addresses. Very dissapointing. Here is mine:

VegasMovieStudioPE80.exe - Application Error

The instruction at "0x022b2fa9" referenced memory at "0x023222d0". The memory could not be "read". Click on OK to terminate the program

I'm wondering if we have something in common that "most" others don't, but I can't think of anything except that I left my Vegas 6 installation in place with Pixelan that came with it. I'm not willing to uninstall it at this point just to see if I still get this error message.

I guess I'll also file the bug report like you did.
ADB wrote on 9/6/2007, 2:35 PM
Steve, Himan,
Can you please give exact steps to reproduce the error. I can't seem to duplicate it.
Himanshu wrote on 9/6/2007, 8:02 PM
Steve, thanks for the confirmation. If you file a case, please also refer to the case number I posted above...let them know yours is not an isolated case.

The memory address I posted appeared only the very first time I loaded up SVMS 8.0b. After that I've been getting another address very consistently, so it appears that maybe there was a relocation of the DLL that the error occurred in:

VegasMovieStudioPE80.exe - Application Error
The instruction at "0x02de2fa9" referenced memory at "0x02e54f58". The memory could not be "read".
Click on OK to terminate the program


Steps to repro couldn't be simpler: Start SVMS 8.0 by clicking on the icon on the desktop. Get rid of the help/tutorial window by clicking on the "X". Then close SVMS main window by clicking on the "X". Observe crash.

If you like, choose File > Exit. Crash.

Luckily I can work in a session and there are no crashes till exit.

Still no repsonse to the support case I filed.
stevefoobar wrote on 9/6/2007, 10:17 PM
Yes, the same for me. All I have to do is open the software, then immediately close it and I get the exit error every time. Supposedly, Sony tech support should get back to me by tomorrow, but it sounds like you are not having any luck with them so I guess I don't expect to.

I tried calling them but they informed me that there is no phone support whatsover for Vegas without paying for it. That's really too bad.
ADB wrote on 9/6/2007, 10:18 PM
I still can't reproduce it. Looks like a problem with your system. Have you followed all the suggestions in recent threads ... BIOS, drivers, services etc etc ?
Paul Mead wrote on 9/7/2007, 7:28 AM
I have yet to spend much time in VMS 8, but so far I haven't had any crashes.

Your problem could be tough to track down. It could be any one of the bazillions of DLLs that get loaded up in a complex application like VMS. Hopefully, the support people will give you some hints. I don't want to jinx you guys, but I tend to believe that easy questions get answered quickly, and tough ones (like this one) tend to get ignored.
IRH wrote on 9/7/2007, 12:06 PM
Could Steve and the original poster provide a brief run down of their system specs - i.e. OS, GPU, hard drive types, etc.? I'd be interested in knowing whether you each have something in common that others not able to reproduce do not have. (I have not yet updated to 8.0b, so I'm not a suitable test case).

ADB wrote on 9/7/2007, 2:46 PM
This really does sound quite a strange problem. When I was having my crashes, I tried everything imaginable, including going through and changing each of the BIOS settings, eliminating all non essential services etc. A few things seemed to have minor effects such as reducing VMS threads, but the BIOS upgrade was dramatic ... perfect stability now ! There must be something unusual on the problem machines.
Himanshu wrote on 9/7/2007, 3:29 PM

My system: Dell Dimension 4600 P4 2.8GHz (HT-enabled), 1GB RAM, GeForce 4 Ti 4200 (old, I know, but rock solid), 3 x 160GB hard drives (no RAID), Pioneer DVD writer, FireWire card. Windows XP SP2 always up-to-date on service packs.

My machine meets or exceeds the system requirements for SVMS Platinum v8 mentioned here (

Prior to this, I had been running SVMS 6 on this machine for more than 2 years, no crashes.
joecozz wrote on 9/7/2007, 3:41 PM
I have also had this same problem. It also happened when I upgraded to the 8.0b version.

First thing was the crash during closure.

Second, I also had a Audio/Video out of sync issue. Approximately 1 second Out of sync. It was a professional Quicktime file.

When I removed the software and dropped back to the 8.0a, everything was fine.

I still have 7.0b on my machine and that also works fine. It is only this version of the software.

Did you have any similar problems with DVD Arch 4.0?
joecozz wrote on 9/7/2007, 3:46 PM
My system information:
Pentium Dual Core 3.2 GHz Processor
Nividia GeForce 7600GS
Sony DVD Burner
Firewire interface
Windows XP (XP2) Up to date
3 Hard Drives 300GB, 250GB, 250GB

Himanshu wrote on 9/7/2007, 9:17 PM

Thank you *so much* for clueing me in on the 8.0 build 74 v/s build 122 issue. I uninstalled and reinstalled 8.0 at the request of the tech who is handling my case. Based on your post I launched build 74 and exited cleanly without any crashes. Then I patched to 8.0b build 122 and guess what? Crashes returned. So the culprit is 8.0b.

To answer your other question - no, I did not have the same crash-on-exit with DVD Architect 4. However, I have not created any DVDs with that package yet due to issues creating content with SVMS PE v8.

Finally, *yes* I have out-of-sync problems with SVMS PE v8, which I *never* had with SVMS v6, and that is really killing me. I tried a quick render of my 8.0b VF file in 8.0a, and I still saw OOS issues in the render. I'm suspecting the capture which was done in 8.0b is not good. But I'll save this topic for another thread and I'll have to run some more tests.

I hope that tech support can see that this is an issue that several customers are facing and that 8.0 build 74 does not exhibit the same problem. Thanks once again.
joecozz wrote on 9/8/2007, 4:19 AM
I guess there is sense of relief to know we have the same problem but I came from the Pinnacle Studio world where crashes where very common. It is what finally drove me to Vegas.

I don't believe we have some unique hardware configuration that is casusing this problem especially since 7.0 and 8.0a worked fine.

The only other thing I can think of is that I actually have 4GB of RAM in anticipation that I will use it once I upgrade my OS.

At any rate, I will continue to use 8.0a and 7.0 is still there as a back up. I think this is going to require a new update.

Finally, I can grade Sony vs. Pinnacle now. Pinnacle would deny the problem, come out with at least 3 or 4 updates, never admit or fix the problem and eventually charge you for the next version.

dogwalker wrote on 9/10/2007, 8:48 AM
Hey, Joe, I'm glad you pointed out the 8.0 versus "b" patch. My machine is also a dual core, and I get lockups in Vegas. I know there may be codec issues, etc, but I've updated my motherboard and video drivers, and have tried everything I can think of.

Yesterday, I moved my second hard drive to a different IDE channel, to see if that'll help. I was able to edit a lot more, and didn't crash, but time will tell.

If it does crash again, I'll revert back to the 8.0 install.

I wonder if there's an issue with 8.0b and dual core systems?
joecozz wrote on 9/10/2007, 9:06 AM
Do you also have the Audio / Video out of sync issue also?

I have 3 SATA Hard Drives.

It just bugs me that all the privious versions worked fine.

I tried again to reload 8.0b with the exact same result.

I moved back to 8.0a and everything is working ok.

dogwalker wrote on 9/10/2007, 9:19 AM
I haven't experienced any out of sync video/audio yet (but then I haven't done as much work very far into a movie). No, I have only two PATA hard drives.

When I install from the CD, I think it's simply 8.0 (I'll have to check to see if it's 8.0a when I get home).
joecozz wrote on 9/10/2007, 11:06 AM
8.0a is what I got in the upgrade package.

I noticed the Out Of Sync issue when I played back a quicktime music video I downloaded from one of my favorite artists.

The sync was off by exactly 1 second.