Timeline Playback, Loses Synch

MUTTLEY wrote on 10/7/2009, 8:53 PM

I think I've posted about this before but its really driving me crazy. I had hoped this was fixed in the latest release but seems not to be so. When I play back from the time line even with effects off and set to draft auto, the video starts dragging slower than the video. I've tried changing the Dynamic RAM from 0 to back where it is now 1024 with no affect. I've tried changing all the buffering options under Audio Device in preferences as well as Audio device type. I'm on Vista 64 but as others, running 9.0b in 32 because of plugins. Intel Core 2 Extreme CPU X96450 @ 3.00 GHz and 8 gigs of ram.

Anyone else getting this or got any other options that I may try. This has been happening for awhile now and really makes editing painful, let alone trying to show something to a client from the timeline.

- Ray
Underground Planet


tumbleweed7 wrote on 10/8/2009, 7:00 AM

Looking back at your previous posts.... I have no issue with mxf24p footage on my timeline playback... what's diff about your mxf files?

My original stuff is Pana 17mbs AVCHD24p, rendered to mxf24p.... & playback is smooth with no audio lag whatsoever....

HP AMD 64 X2 duo core 5600+ 3Gig ram Nvidia 9400 GT Vista32 VP 9.0b
Jay Gladwell wrote on 10/8/2009, 8:19 AM

I'm not experiencing any of this with my MXF files.

Ray, sorry I can't be of any help. I'm on XP Pro 32.

Maybe submitting a ticket is in order to resolve this issue.

fldave wrote on 10/8/2009, 9:34 AM
Traditionally, the best performance has been with:

source video format = project properties format
source audio format = project properties format

Save downsizing, if any, at render.

The dynamic ram seems to buffer playback even when you don't overtly Render Dynamic Ram Preview, so if you see initially fast playback then slower frame rates, there is some bottleneck still.

Plenty of room on HD drives?
Laurence wrote on 10/8/2009, 10:40 PM
Are you doing 24p or 23.97?
farss wrote on 10/9/2009, 1:11 AM
I've had this happen as well and agree it's most annoying, especially when it happens in front of a client and they notice it. Symptom I had happening was audio slowly drifting behind vision. Stopping playback and restarting it would get it back in sync for a while and then it'd slowly drift out again.

Things to check that might help are audio FXs. Some are CPU intensive and there's nothing that Vegas can do if it runs out of steam to process audio. Dropped frame are bad, dropped samples are a disaster. Also check that you haven't got a disk going bad. I had a number of things go wrong on one project, hard to know for sure exactly which was causing what.


xjerx wrote on 10/9/2009, 5:35 AM
yep...i'm having this problem as well...with any kind of footage from SD DV, HDV 24p, RED....and i'm on Vegas 9b...it is quite frustrating...

mark-woollard wrote on 10/9/2009, 6:16 AM
Same problem here, using Cineform HDV files, SD project settings with Vegas 9b, and Windows XP SP2. I did not have this problem in Vegas 8. Later today, I'll try keeping HDV project settings and see if this helps.
MUTTLEY wrote on 10/9/2009, 9:32 AM
The project properties are taken straight from the clips.

1080-24P (1920x1089m 23.976 fps), Progressive, 8-bit

Playback doesn't start out fast, starts out normal and then video slows down some.

farss, yes, pausing and starting again does seem to work to play in sync, if only for a short while. This happens with effects off, in Draft (Auto) or any other mode, and there are no effects on the audio. Just a wav that was imported from CD in Vegas.

I am using MXF files taken from the camera and converted with Sony Clip Browser. Originally I intended to use the raw MP4 files from the Sony EX1 but converted hoping it may help, obviously that step didnt make a difference.

I should also mention that this happens even if I do "Selective RAM Preview" or "Selectively Prerender Video".

Underground Planet
mark-woollard wrote on 10/9/2009, 12:56 PM
Using HDV project settings did not correct the problem. The video is still lagging behind the audio.
1marcus4 wrote on 11/5/2009, 11:13 AM
Placing the same video on the timeline, ...

On Vegas v9.0c the video severely lags the audio
On Vegas v8.0c the video and audio play flawlessly

I tried this with DV, HDV, MP4, DIVX.
All results the same.

This issue appears version specific 'out of the box'.

Here is what improved the situation for me...

Under Options\Preferences\Video I I changed THUMBNAILS TO SHOW IN VIDEO EVENTS from 'head, center, tail' to 'All" which, btw, happens to be the default value in v8.0. It also helps to play with the expansion/contraction of the timeline to fine tune playback.

Not perfection but it helps.

TimTyler wrote on 12/16/2009, 11:07 AM
I have the same setup at Ray, and experience the same problem. I'm cutting 1080i P2 MXF with Raylight Ultra.

Task Manager tells me that CPU and Memory are no where near maxed during playback either.

I found that if I switched the Deinterlaced Method in Project Properties to "none" that helped a bit, but there's obviously something going on here that was not a problem in v8.
Marc S wrote on 12/16/2009, 1:58 PM
I've had this problem as well.
rmack350 wrote on 12/17/2009, 3:28 PM
I was having this same problem with plain old DV footage in Vegas 7.0. That's the last time I did anything where I'd notice it. It was a bit embarrassing. Never tried to figure it out but the final DVD was in sync.

Rob Mack
hbwerner wrote on 12/17/2009, 4:27 PM
I'm glad to hear others having this problem. I often uncouple video and sound to slide a particular item around, and then recouple and check to make sure something else didn't accidentally get messed up. I've been making corrections elsewhere and then finding when I restart Play that they were OK in the first place. Sure makes it hard on those of us who do this. I hope Sony fixes it soon. This is the first version I've had with this defect.
BrianStanding wrote on 12/19/2009, 8:24 AM
I have always had this problem when using ASIO drivers. Try switching to Classic Wave drivers in Audio Device Preferences instead.
LReavis wrote on 12/19/2009, 9:13 AM
I know that 8c cannot handle as many video codecs as Vegas 9, and by using it I must first render my Sanyo files to Cineform or PicVid in Vegas 9 (9c, for me). Moreover, newer Vegas versions handle large stills with grace, and - again - I must do any panning/cropping of large stills in 9c, then put the rendered .AVIs on the timeline of 8c instead of putting the large stills there.

But for me it's worth the slight additional trouble to edit in 8c. Am I missing something? Is there some other reason why Vegas 9x still is being used for editing, given the problems? As near as I can tell, 8c is rock solid for editing, and 9c-64 imports the 8c .VEGs flawlessly and renders them every time.

In fact, 9c-64 is the first version of Vegas that renders the long, complex .VEGs that in the past kept me up at night - in one fell swoop - no need to cut the project into 2-min. segments, and no need to restart Vegas in order to continue rendering. Seeing the rendering power of 9c gave me immense relief.

Am I missing something? I have done only a handful of modest projects using this two-step 8c-to-9c procedure and maybe there's something wrong with it that I haven't yet noticed . . .