Tirmming causing file corruption

Former user wrote on 11/19/2011, 4:09 PM
Okay, I have had this happen to me now at least 6 times. I am editing a project in Versio 10e and I open one of the video clips in trimmer. For some reason, the computer starts going into overwrite mode and starts writing over the file I am trying to trim. I have to get to task manager as fast as I can and shut down the program. Then when I open the project, parts of the file have been erase/corrupted or whatever. So far I have been able to either recapture the footage from tape, or rebuild if this was a render from another project, but it is getting very annoying.

The odd thing, if the clip is a render from a project (such as prebuilding some effects or sync track after using Plural Eyes) if I open the project where the problem happened, it appears to open the VEG file rather than the clip that was created by the veg file (in all cases, an AVI). I am beginning to think that Vegas is sometimes confusing the VEG and the AVI (which have the same name) and overwriting the file as a VEG file. I can't swear to this, but it is extremely bizarre. Is anyone else having anything close to this issue?

I know I posted it before and one response was a possible drive failure, but this is happening to different drives.

Dave T2


Former user wrote on 11/19/2011, 8:27 PM
I was almost back to a fiinished project and it did it again when I tried to use the trimmer. I have uninstalled 10 andmoving to 11. I know I shouldn't change in the middle of a project, but this is driving me crazy.

Dave T2
Serena wrote on 11/19/2011, 9:45 PM
Presently I'm wary of using the trimmer because I suspect the "going black" issue is associated with that. However I haven't been able to confirm that because:
a) the occurrence is 'random';
b) I'm always trying to 'get on' with the job;
c) it's not always the case that a trimmed clip is involved, but is likely to have been played from MM.

I haven't considered the possibility that any pass through the trimmer (e.g. playing a clip in MM), so that's another variable.

This hardly helps, but whereas formerly I used the trimmer extensively now I avoid it. Rather similar to and as reliable as any other superstition!
John_Cline wrote on 11/19/2011, 9:50 PM
You're right, that's pretty bizarre, there is no reason for Vegas to ever modify a source video file. I've never had that happen to me.
Former user wrote on 11/19/2011, 9:52 PM
Yeah, it seemed to get steadiy worse. At first, it would just do occasionally, but tonight it started doing it each time I loaded the trimmer. It was overwriting that file and was really beating me up. I don't know why it would be going into a write mode.

I have installed 11 now and at first glance it is much more responsive than 10. I was always getting the spinning wheel in 10, but don't seem to in 11.

I have not tried the trimmer yet and will avoid it until I get this project done.

Dave T2
Former user wrote on 11/19/2011, 10:12 PM

The computer would freeze and I could see the harddrive led just flashing away. I would go to task manager, force quit the program, and when I open the project, the file I was trying to trim is showing colored pixels in areas and the audio is either noise or has bleeps in it. It would do it whether I entered the trimmer from the Media Files window or the timeline.

To be safe, I uninstalled 10 before installing 11. Don't know if that made a difference or not since many of my other settings and presets were saved.

Something must have gotten corrupted. I did use the trimmer in 11 a few minutes ago and no problem there. But then I started getting black frames on a pre render. These are just DV SD files so I am not taxing the computer or software any.

I hope 11 does not do it.

Dave T2
i am erikd wrote on 11/20/2011, 12:02 AM
Dave, that is one scary nightmare. That even beats "Vegas Replaced the Video"! I've never heard of anything like that in Vegas or any other NLE. How long have you been using V10 before having this problem? Is it possible you have a virus on your system?

Former user wrote on 11/20/2011, 6:35 AM

I have had 10 installed since it came out and this started happening a few weeks ago. The first time it happened, I thought the drive was just doing some housework. When I finally stopped the program, it had overwritten about 10 video files, all that were in the project, and I had to recapture them.

I don't think it is a virus, but I will scan it thoroughly just in case. It only has happened when I try to use the trimmer. But I am at a loss as to what it might be. It does not delete the files, it just overwrites them and corrupts the video/audio streams.

Dave T2
Chienworks wrote on 11/20/2011, 9:05 AM
Serena, i too occasionally get the 'going black' issue, but it's probably not related to the trimmer. I haven't had the trimmer open on my screen in 12 years, much less used it. Nor have i accessed media manager or project media in a similar period of time.
i am erikd wrote on 11/20/2011, 10:26 AM
"Nor have i accessed media manager or project media in a similar period of time."

I take that to mean you edit by dragging ALL of your content to the timeline from windows explorer and then do all cutting from the timeline?

There is no chance of this method working for me just because of the hundreds of choices to be made in each program. I must use and rely heavily on organization tools such as Media Manager, XDCAM Explorer and Project Media using bin creation. No other way to get my arms around the content.

Chienworks wrote on 11/20/2011, 11:03 AM
Exactly, well, except that i use Vegas' explorer window rather than Windows' explorer. My edits are almost always one or two "tapes" of an event. Editing is trimming out unwanted material and sometimes swapping between the two cameras.

Obviously there are tools available for more complicated projects, but i have no need for them.
Former user wrote on 11/20/2011, 1:01 PM
I am beginning to think the Black video problem is related to having your video sources on multiple drives. Seems like as long as I pull my video from one directory, I am okay, but as soon as I use another drive as a source, I started getting the black video.

Last night after installing V11, I got black video on a pre-render, but I was pre-rendering to a drive different than the source video drive.

Anybody else seeing this?

Dave T2
Chienworks wrote on 11/20/2011, 4:42 PM
Nope. I get it even when working on one single drive.
Former user wrote on 11/20/2011, 5:01 PM

Dave T2
rmack350 wrote on 11/20/2011, 6:08 PM
I think the black file/mixed up file thing is something that is very internal to Vegas. I just don't believe that constantly fiddling with the Rabbit Ears is going to solve the problem. But i'd be happy to be proved wrong.

Files being overwritten when in the trimmer is a serious, serious No-No. I'm trying to think about what happens when you load a file into the trimmer and the first thing that comes to mind is that Vegas creates a peak file named "myfile.xyz.sfk"

Most of the peak file name is identical to the original file name, including the text of the original file's extension. So maybe Vegas (or Windows) is overwriting the original file with the peak file, which says to me that there's some sort of bug causing Vegas (or Windows) to ignore that last .SFK in the filename.

I'm not sure what would cause that. Maybe another application grabbed the .sfk extension?

How about the path/filename length. There's actually a limit to this, although I think it's a big limit like "D:\512Characters\plus_a_few_more_characters.avi.sfk"

How about a FAT32 disk?

Or an unusual character in every filename? (This was once an FCP problem where FCP would reject some characters that the OS would accept, so you could save files from FCP with names that FCP couldn't parse).

Any of that ring a bell?

rmack350 wrote on 11/20/2011, 6:31 PM
For your entertainment, here's Microsoft's info on Path lengths:


Former user wrote on 11/20/2011, 8:28 PM

Your thoughts are similar to mine as far as the file overwriting.

I think my names are consistent with windows standards, here a couple of examples.

E:\Christmas Kids\1st group sync.avi
G:\Vegas Capture\006 - Clip 013.avi

At most I go down 2 folder levels. But these are all only one. And when the file is overwritten, it does not start at the beginning of the file. It is 10 to 20 seconds into the file.

This seems to have gotten progressively worse. The first time it started and overwrote several files with the Vegas capture default names. Then it didn't do it for a while. Last night it started doing it everytime I opened a file in the trimmer. The project veg could be suspect, but I opened that in V11 and it seems to be working fine now. I don't add too many new progams to this computer once I get it set up. The only updates are the Windows security updates, defender updates and the Sony V10 updates. I added the Closed Caption Extension program and the Plural Eyes plugin. And now while I am typing, it seems this might have started happening after I installed the Plural Eyes trial program, because I installed it specifically because I was going to have multiple takes with an external recorder and wanted to sync them quickly.

Plural Eyes could be involved but I have now installed V11 and the trimmer is working correctly on the same veg file updated to V11 and the same drives/ footage and Plural Eyes loaded, but not activated on any of these projects after insalling V11.

All drives are SATA NTFS drives. No raids and each drive was a 1tb size. Musicvid suggested a failing drive, but two drives have been involved and I have had no other issues of read/write failures or unexpected overwrites. Vegas locks during this time and I have to get to task manager and shut it down. The faster I do this, the less the file is damaged.

I don't think there is a virus, because I don't hook to the internet with this computer or download any files directly to it. I don't have an antivirus running on it because I am trying to avoid slowing it down any more than necessary. All downloaded files go throught my other computer which has Avast running on it. And I manually scan all downloads.

But, loading V11 could have fixed any file associations. So I can't test it any further and I can't afford to corrupt any more files. I am going to delete Plural eyes since I can't purchase it right now anyway.

Thanks for your thoughts.

Back to the Black issue, I still think it is related to media being on multiple drives. I know I use a different drive for temp files and pre-renders and V11 showed a black clip last night after a pre-render. I deleted all pre-renders and then rendered again and the black clip was fixed.

I hope this helps with any ideas.

Dave T2