Titles & Text fonts question

YesMaestro wrote on 8/21/2014, 8:56 AM
I just finished a big project with lots of cg created with the Titles & Text (It was quicker for me than using NB Titler Pro). The client now wants to change the font from Arial to Arial Black. The T&T doesn't have Arial Black. Is there a reason why it can't see the font? I can see it in the Legacy text. I hope won't have to redo all of them. I'm using v13 Build 310. Thanks



jetdv wrote on 8/21/2014, 9:53 AM
This is where the new QuickEdit feature in Titler Pro 3 could have saved you a lot of time. With the QuickEdit feature, you would have simply modified the template once and all of the titles using that template would be modified. And, yes, it does see Arial Black too.
DavidMcKnight wrote on 8/21/2014, 10:27 AM
There is a known bug in some of the included titlers where a certain type of font is not recognized. OpenType maybe? Search the forum for details but I don't think it's ever been fixed.
Marco. wrote on 8/21/2014, 10:37 AM
This is a known bug of Titles & Text. There are problems with the main type of a font's super family and Titles & Text don't read OpenType nor Fon fonts.

Oops, David was faster …
NormanPCN wrote on 8/21/2014, 10:38 AM
Titler Pro 3 can do this change easily, if setup to do so.

Vegasaur can modify Titles and Text attributes across multiple text events.

Titles and Text has serious fonts issues, since V12 and probably V11, and it does not look like this problem will ever change. Legacy Text, Protype and NewBlue are all fine.

IMO: Titles and text renders the text glyph outlines to bitmaps itself. It does not use the system for this. T&T does not support all types of glyphs supported by Opentype and even plain truetype fonts. Most unsupported fonts do not show in the font list, but some do and don't work.

At a minimum SCS should fix the problem with some Truetype glyphs. Then they really should support Postscript glyphs.
YesMaestro wrote on 8/21/2014, 11:42 AM
Crud! I guess I'm stuck having to redo all of them. I don't remember reading anything about it. Otherwise I would have gone a different route.

I only have Titler Pro 2. I guess I should upgrade just in case this happens again.

NormanPCN wrote on 8/21/2014, 12:49 PM
If you have TP2, and like it, then the $99 upgrade to TP3 is definitely worth it. The $99 upgrade price is gone at the end of this month.

I just tried creating a "fixed" Arial Black using TransType4 but T&T still did not like the file. All the Arial fonts, including Black, are Opentype with Truetype outlines but something about Black T&T does not like. So if you need Arial Black then using Legacy text, Protype or NewBlue are your only options.
Former user wrote on 8/21/2014, 12:56 PM
Note: I'm using Vegas 12, so not sure if the same behavior is present in Vegas 13...

I just discovered an odd behavior. It appears that the only thing keeping the Titles & Text from using certain fonts on a system, is some sort of issue with the font(s) displaying in the dropdown.

Try the following:

1. Place a copy of the Legacy Text on the timeline (delete the sample text)
2. Click into one of your current Titles & Text event.
3. Select All, copy (ctrl-A) (ctrl-C).
4. Jump back to the empty Legacy Text event.
5. Paste (ctrl-V)
6. Select All (ctrl-A)
7. Choose Arial Black (changes all text to Arial Black)
8. Copy All (ctrl-C)
9. Jump back to your Titles & Text event.
10. Select All, Paste (ctrl-A) (ctrl-V)
11. The text will now be in Arial Bold ;-)

I guess the point is that if you have a legacy text title that uses Arial Black, you can copy it from the Legacy event and then paste it into in the Titles & Text and keep the Arial Black font, even if it doesn't show up in the font dropdown...

You can even edit it, size it, reposition it, etc...


NormanPCN wrote on 8/21/2014, 1:26 PM
Nice catch Jim!

I just tried this with an OpenType CFF font (Postscript glyphs) and this technique works for those fonts as well. Specifically I tried Aachen which I purchased.

The clipboard text is probably coming across as RTF which will have a font name, size, etc embedded as necessary. It's probably how they store things internally since T&T and legacy allow multiple fonts in a text event.

I think this trashes my ideas about why T&T has certain problems. Although, the lack of a fix for T&T for so long is even more pathetic IF it is simply a font enumeration issue and not a functional implementation issue.
YesMaestro wrote on 8/21/2014, 1:53 PM
Great idea Jim! I think I just took it one step further. I took several cg's and pasted them into Word. I then highlighted all of them and changed them to Arial Black and then re-pasted them into their respective events and it looked like it worked. Can you verify for me? Thanks!

Former user wrote on 8/21/2014, 2:01 PM
You might be seeing the RTF effect (via the copy buffer). I don't use MS Word, instead I use OpenOffice Writer and the technique doesn't work using it.

Update: It sort of works. The font in the T&T edit window isn't Arial Black, but the rendered output appears to be. Not sure what the deal is, but doing the same with a temporary Legacy Text event (instead of Word) does work.

One other thing you will find. It appears that T&T and Legacy Text have total different opinions as to what point size is: eg. 28 point in T&T is about twice the size as 28 point in Legacy Text.
NormanPCN wrote on 8/21/2014, 2:14 PM
I just tried LibreOffice Writer 4 and it worked. I don't have MS Office to try.

I tried Windows WordPad (Write) and it works from there. Everybody has this app.
Former user wrote on 8/21/2014, 2:17 PM
Oh yeah. I have LibreOffice Writer 4 as well -- and it does work ;-)
NormanPCN wrote on 8/21/2014, 2:31 PM
OMG! Get this.

I just tried the Titles and Text feature of Vegasaur and it works from there as well.

I created two T&T text events.
Selected them.
Opened the Vegasaur T&T pane.
Choose to modify the font and size. Everything else unchanged.
Selected Arial Black in the Vegasaur font list.
Click apply.
Both events now had the Arial Black font, in the size specified by Vegasaur.


Writing a script could do this as well, but with much less flexibility.
YesMaestro wrote on 8/21/2014, 3:32 PM
That's great Norman! I think I'll go that route and purchase Vegasaur. It will definitely save more time than copying and pasting WordPad. Thanks for checking that out.

NormanPCN wrote on 8/21/2014, 4:27 PM
It (Vegasaur) should be the easiest way for you to get your existing task done. One of many functions these scripting extension tools provide to make things easier.

I did notice that Vegasaur is not listing Opentype CFF (Postscript) fonts. Probably because like me, they noticed T&T did not list virtually all this and the few it did, flat out did not work.

I'll test a little more and if satisfied put in a feature request to Vegasaur to allow Opentype CFF fonts in their list.

Regardless of the T&T user interface problems, under the covers it seems to be fully functional.

The developer in me still wonders what is going on inside T&T with this bizarre behavior. A font enumeration issue is too easy to fix and yet they have not done so for versions. Since T&T accepts clipboard RTF I wonder if fonts specified this way go through the system font engine, and fonts listed in the T&T user interface are supposedly validated to work with its own internal engine.

Of course if that were the case then why not just list everything, and internally handle appropriately when the user makes a selection.
PeterWright wrote on 10/15/2014, 3:38 AM
It's not that uncommon for me to feel stupid, but I've excelled myself!

I need to change fonts and size in many Titles, I have Vegasaur, and I have read how to do it in the Help files.

BUT I cannot find the Text & Titles tool!

I've spent half an hour looking through under the various categories:

1-Click commands
Timeline and

and I cannot see T&T anywhere - there is a Text Generation Wizard under "Timeline", but that's not it.

The Help says it's under Effects, which I found under Editing, but this does not appear to contain this Tool.

One possibility - I used the Legacy Titler rather than Titles and Text for the original titles, but even if I add a Title using Titles and Text the T&T tool still doesn't appear.

Could any user or originator of Vegasaur please help?

I'm using Vegasaur 1.9.1 in Vegas Pro 12

Thanks so much.

edit: The missing word in the first line starts with St and rhymes with Cupid. Censored?!
altarvic wrote on 10/15/2014, 9:57 AM
1) I recommend to update Vegasaur to the latest version (1.9.8) - many bugs were fixed since version 1.9.1
2) Effects tool contains several modules, take a look:
PeterWright wrote on 10/15/2014, 8:19 PM
Thanks altarvic - that helped, and I found the T & T tool.

Unfortunately it doesn't work with the Legacy Titler - I'll make sure I use T & T next time!