Trial version of Pro and Behringer xTouch

Ed-Perkins wrote on 7/28/2019, 5:54 AM

The Quick question is: Is external control restricted in the trial version of Pro 16? Vegas does what I need as far as video editing and creating a soundtrack on the fly...but a recent dual-purpose addition to my studio is a Behringer xTouch. Vegas sees it when I put it in MC mode (and I've tried HUI mode as a cross check)...but it does nothing at all when I use any of the controls on the xTouch. I hit the 'external' switch in Vegas as put in perspective, I tried the same experiment in Cubase AI and it worked right after initial configuration...where I am at right now, either the Behringer goes back, or I find a plan B for software that can edit video and multitrack audio..I've been using Movie Studio 14, but I wanted the mixer control over the audio tracks, instead of dragging volume envelopes..I am primarily a musician, and my goal is to play along with the videos, so workflow is the number one thing on my agenda...TIA!


Ed-Perkins wrote on 7/29/2019, 6:25 AM

followup….I tried the Behringer xTouch with my old MacBook Pro and Logic...immediately upon bootup with Logic, it saw the xTouch as a Mackie Controller and the controller lit up like a Christmas tree...everything worked without me configuring anything...this is 2010 technology. I know Vegas and Logic are, well, apples and oranges..but should I not have something working? Please tell me there is some hidden switch or the whole use is disabled by the crippling in the trial version. thx.

Adi-W wrote on 7/29/2019, 2:08 PM

I use also the xTouch with Logic and with Vegas with which it works well but differently for his setup.

So you say : "it does nothing at all when I use any of the controls on the xTouch".

Do you mean that all the controls like Fader, buttons, rotator and the Playback section does not respond and have no action at all ?

Ed-Perkins wrote on 7/29/2019, 2:30 PM

Yes, for example, I open a project in Logic, all of the faders move, the channel indicators light up, and say the name of the track. The scrub wheel moves the cursor on the timeline, and the transport buttons, start, stop, rewind, etc....on the Vegas Pro installation...nothing at all happens. I was kind of expecting it to perhaps not work perfectly, but I was able (on the same machine) get Cubase to see it and work after a fashion (the transport worked, but not the scrub wheel, the faders would not stay put, etc)...the bad news for me is that I'm working in tandem with an artist that uses Vegas and I just paid almost $500 for the xTouch, which is acting like an very expensive paperweight right now....if I'm really that close, could you show screenshots of your configuration? (I've got an email in to support, which states 48 hours for response)...I'm even trying Reaper to see if I can get some joy...all of this is making Apple computers look awesome right now....

Adi-W wrote on 7/29/2019, 2:35 PM

Did you checked that the "midi X-touch" drivers are selected in the configuration windows of the emulation/Mackie control ?

Ed-Perkins wrote on 7/29/2019, 2:56 PM

other steps I have tried...setting the xTouch to MC mode and HUI mode (saving, exiting Vegas, going back into Vegas, deleting the device from the PC, plugging into a different USB port, reinstalling...I have not rebooted the computer after each step, but I have rebooted multiple times today...not the best science, but my fear is I'm working on something that won't work...the fact that somebody has this working already gives me hope!

Adi-W wrote on 7/29/2019, 3:20 PM

That is what I thought : in the "external control" tab, you have to right click on the "Mackie control" entrie that appear in the Active Control Device window and select "Configuration" or something like that (I am not at my Vegas computer). Then you will have a window where you have to select the appropriate MIDI driver for your Active control device. Usually, you have to do it only once but whenever Vegas crash you may have to go back in that window to re-assignate the x-Touch MIDI driver.

Ed-Perkins wrote on 7/29/2019, 4:50 PM

I forgot to add that image...although I have high hopes that I have missed something or have something not quite the meantime, support has contacted me and suggested that I teach MIDI commands to Vegas one button at a time (tried that for one button and no joy)....not what I had in mind...switching DAW would be preferable...Adi-W, you are my best hope since you have it running..please let me know if you did something to your xTouch pre using it in Vegas..e.g., is it in HUI or MC mode?





Ed-Perkins wrote on 7/29/2019, 5:01 PM

suddenly, it started working...still not sure what or why, had several windows open and when I closed all of them, the xTouch sprang to's not 100% right, but the transport works and the tracks have names on least I know I have to viable gizmos that could work together....thanks for pushing me over the finish line!

Adi-W wrote on 7/30/2019, 12:08 AM

The MC mode is the good one.

Did you checked the "Configuration" window of the Mackie Control or not ?

Ed-Perkins wrote on 7/31/2019, 8:53 AM

Yes, I am in and working now...something that was not obvious before, but I see it now that I own Vegas Pro Edit and the newest version of Music Maker...this is not the best path if softsynths were important...I'm used to a library of very good instruments..even garageband on my iPad has better stuff than what comes with Music Maker...but that's not a show-stopper. Part B of that..things I figured out after I purchased Vegas 16 Pro Edit...softsynths are apparently not a part of Vegas...I don't need that, but it would have been a bummer for a user that just tossed all of their hardware for a midi controller.

Bottom line, I can now use my keyboards to play along with videos and use the xTouch to control the transport and up, figuring out how to assign the busses to the sliders instead of track 1-8...I'm sure that is doable.


Thanks for all of your help!