Trimmer window error and Media Pool bug

Ben  wrote on 10/6/2004, 3:51 PM
After placing markers or regions in a file in the trimmer and either hitting save (to save the markers) or closing the trimmer window, Vegas often throws up this error:

"An error occurred while saving one or more files.

The file could not be opened because some other application already has it open."

I've only even seen this since Vegas 5. The problem is, no other application has the file open. I've also checked that the file's read-only, and it definitely is. I can't work out why it only sometimes gives me this error. Has anyone else seen this?

Another annoyance in Vegas 5, this time regarding the Media Pool. Although the Media Pool arranges file alphabetically, it seems to bizarrely arrange all the files beginning with capital letters first and only once it's done all of them does it arrange the files starting with lowercase. So, the result is that my files aren't at alphabetical! Am I being dumb - is there a way to change this - or is this a bug?



farss wrote on 10/6/2004, 6:23 PM
Dont' know about your second problem but I've had the same thing happen with DVDA2. It simply refused to load markers so I thought I'd try entering markers manually and then saving them. That's when I got the exact same error message.
As luck would have it I'd downloaded the new DVDA2 build so it seemed like an opportune time to install that. Post installation problem went away but unless they've fixed something I'm suspecting it'll be back.

SonyTSW wrote on 10/6/2004, 8:36 PM
> I've also checked that the file's read-only, and it definitely is.

You won't be able to update markers/regions if the file is read-only. Vegas needs to update this information in the media file and it can't if it cannot be written to.

Side note: A bug was fixed starting with Vegas 5.0a so that it now dynamically determines whether the file is writable whenever you click the Save Markers button. This fix also corrected a problem when the same file is open in DVDA2 and in the Vegas trimmer. In some cases quickly changing from DVDA2 to activate Vegas and attempting to save the markers from the trimmer would give an error. If you are not running Vegas 5.0b (the version currently available for download), then you'll need to download and update yours.

In regards to alphabetization ordering in the Media Pool, this is likely happening because capital letters come first when sorting filenames as case-sensitive. I've entered this in our bug database (sorting needs to ignore the case).
Ben  wrote on 10/7/2004, 5:05 AM
Hi SonyTSW

Whoops, that was a major typo on my part! I meant to say:

"I've also checked that the file's read-only, and it definitely isn't"

So the file is not read only and I am using Vegas 5.0b. Is there anything else that could be causing this problem?

Thanks for logging the Media Pool bug in your database... hope it makes it to 5.0c.
SonyTSW wrote on 10/7/2004, 4:04 PM
What file format are you working with that gives this error? That might be a clue.
Ben  wrote on 10/7/2004, 4:44 PM
Thanks for getting back to me. I'm working with 44.1Khz 16 bit wavs.

SonyTSW wrote on 10/9/2004, 10:33 AM
Hmmm, I'm not able to repro this in Vegas 5.0b. I tried this two ways: using WAVs that were already included in my project, as well as those that weren't. I'm still able to save markers I added from the trimmer, no error messages.

Perhaps some more details about your system, exactly what you are doing in Vegas, and more information about your WAV files that makes this problem happen would help. What other applications are running? (including media players -- the QuickTime player is known to keep the files even if it isn't playing, you need to exit the player to release the file).

Right click on one of your WAVs in the Vegas explorer, select Properties. Copy what it says for Stream and Plug-In and paste it in your post, that will give more information about your wav media file.
jeremyk wrote on 11/22/2004, 10:39 AM
I've just encountered the same problem putting markers into a WAV file. Can't save markers because "some other application already has it open".

Vegas 5.0b is the ONLY task running. Oddly, the problem appeared after I had already put about 30 markers in the file, saving them from time to time. It is constant now. Rebooting Windows (W2K) doesn't help.

I've fallen back to Vegas 4 for this task, and it works fine.

Here's the info from the Vegas explorer Properties window:

Audio: 00:58:50.533, 48,000 Hz, 16 Bit, Stereo, Uncompressed

Name: wavplug.dll
Folder: C:\Program Files\Sony\Vegas 5.0\FileIO Plug-Ins\wavplug
Version: Version 1.2 (Build 1914)
Company: Sony Pictures Digital Inc.

jeremyk wrote on 11/24/2004, 11:27 AM
Yo, SonyTSW. Bumping this. It's an actual problem. Interested?