Unable to open V6 Veg... no error... just hangs.

Liam_Vegas wrote on 5/9/2005, 4:21 PM
Just posting this here... I have already posted a support incident with Sony about this. Thought others here may find it useful... or perhaps offer up a possible workaround.

Below is the message I sent to Sony Support.

I am working on a client project and a couple of the more recent project Veg files cannot be opened. No error message is presented from Vegas.. it simply starts to open the file and sits there forever. Task Manager shows a significant processor utilization... but even waiting for 15 minutes nothing happens. Task manager reports Vegas as being unresponsive. I have to kill the Vegas process.

So.... be careful with your projects.

This is making me think very hard about how I can "account" for this type of behaviour.

I regularly make backups of my Vegs, save and work on NEW versions of the Vegs (use Excalibur)... but I think that will not necessarily get around this sort of a problem. For instance... although I saved a new version of the Veg file.... it's not until you try to open it that you will find that Vegas hangs. Sort of a catch 22. It's nice to have all these extra older versions... but what happens if the problem occurred with the first save I made. Unless I shutdown and re-open... it's a difficult problem to workaround.

I guess that IS the (temporary) "workaround"... every time I save a new version... try to open it in another instance.

Very very very odd... and quite disturbing....

Comments

johnmeyer wrote on 5/9/2005, 4:56 PM
That is extremely disturbing. For the sake of all of us, I hope it is something specific to your computer. If something like this is inherent in Vegas 6, and we can't trust it, then ...

I was thinking of switching over on this megaproject I'm doing because nested VEG files would really be great for the final render**.

Have you tried turning the computer off completely, re-booting, and then trying again to load these files?

===============
** Reason nested VEG is important to me: I have twelve short videos to put on one DVD. With nested VEG, I won't have to render each project to small MPEG-2 files. This will let me avoid having and to stitch them together in Womble prior to putting into DVDA (which you must do if you want to create a disk that navigates in the larges number of players). I could put the individual MPEG-2 files into DVDA and then set end actions to connect them, but this creates individual titles, and most DVD players will not fast forward or reverse across these boundaries, nor will most let you use the chapter reverse to go backwards. Only some let you use chapter forward. Playlists don't solve this problem. I can put the multiple MPEG-2 files into a Music Compilation, but then I can't put additional chapter stops and other goodies into the middle of any of the files.

Nested VEG solves all that.
Liam_Vegas wrote on 5/9/2005, 5:30 PM
I agree - this is a big worry. I want to get to the bottom of it.

Tried re-booting.. and accessing the Veg from another PC... still same issue.

I have managed to open the Veg file... sort of... by moving the source DV files somewhere else.... that way I get the prompt to search for them again. If I let Vegas "find" them... it hangs like before... but if I chose the option to "leave all the source files offline". The result... I have my project open.

Now I'll try to re-link to my source files one-by-one (only four of them anyway) to see if it is a problem with one of them (all are standard NTSC DV AVI... and I can play them from the timeline in other Vegs).

Perhaps just re-saving this Veg (with offline media) will magically bring things back.

I'll report back in a moment.

Liam_Vegas wrote on 5/9/2005, 5:53 PM
Still working on it.... the problem is related to the use of a nested Veg within this project.... will post more when I can figure out what is going on.

Certianly this has highlighted to me another issue... one of how adding nested vegs is a great way to make diagnosing things quite a bit more complex.

[EDIT]

Opening the nested veg and forcing it to refind the media - then saving allowed me to get a little further with the original veg.

Now it opens... notices I've moved the media and I let it search a(and find it)... THEN I get to see what it is hanging up on.

Remember I said my CPU is pretty taxed while the Veg was hanging (see first post)? Previously I was unable to see what was going on.

In the present state I can see what is going on. Vegas is stuck in an endeless loop where it is rendering the nested vegs Audio. (intro.veg.sfap0). It never stops. I can hit cancel... but now the audio for that veg is not available. While this process is repeating there is ZERO disk activity... so I have no idea where it thinks this file is being rendered to (a file of that name is in the project directory... but it has not been changed/altered sinf 4/27).

I can work around it (by rendering the nested Veg myself)...



Spot|DSE wrote on 5/9/2005, 6:02 PM
Things to try.
1. Delete the Sfap0 files from that master veg.
2. Turn off Ignore Fact Chunks in Options/Prefs
3. Restart Vegas.
4. ReEnable Ignore Fact Chunks.
5. Restart Vegas
6. Open your veg. Let Vegas rebuild the proxies.
Liam_Vegas wrote on 5/9/2005, 7:18 PM
OK... got a solution....

Problem WAS with the audio file for the nested Veg. It seems it was in a state where it was left open and that was causing Vegas to get caught in an endless loop while opening my main Veg that used it.

Although I "thought" I had re-booted my main machine.. I'm thinking now that maybe I didn't... as I'm pretty sure that a re-boot would have cured this. I'm still pretty certain that I did... but maybe not.

Anyway... at least I now know what to start looking for if this happens again.

The other strange thing is that V6 projects I have not worked on in a few days are now all re-building thair audio waveforms... no idea why... but this strikes me as being a related issue to what caused this nested vegs audio file to get "locked" up.

I'll update my issue report to Sony... if nothing else they should more gracefully deal with an issue where a nested vegs audio file cannot be updated.

Spot... thanks for the suggestions... I didn't need to reset the "Fat Chunks" thing (what on earth is that?)....

Sounds like you may have experienced something similar - maybe during the Beta?
Spot|DSE wrote on 5/9/2005, 7:29 PM
Not "Fat Chunks", that's my ex-wife we'd be speaking of... :-)
FACT Chunks.
It's information about the audio samples in a wave file. Since you're building compressed proxies, you *can* get errors. You want to ignore the errors when dealing with proxies, but this can also create some trouble.
No, I've not experienced this, except when I've forced a problem deliberately to see what it would do.
This is likely part of what you were seeing if it was the audio segment of your proxies.
Liam_Vegas wrote on 5/10/2005, 12:54 AM
"FACT Chunks".... hah... I think I need glasses!
GmElliott wrote on 5/10/2005, 5:56 AM
Spot wrote: Not "Fat Chunks", that's my ex-wife we'd be speaking of... :-)

Ohhh, that's just wrongggg! ;)
Spot|DSE wrote on 5/10/2005, 7:28 AM
You've never seen my ex. A former beauty contestant who discovered chocolate and twinkies late in life, she went from being in front of the camera to being the weightbag for the tripod. She requires first class everywhere she flies (wider seats) and with the new weight restrictions, she'll soon be having to either charter her own jet or check each of her cheeks as excess baggage.
But she still has a sweet smile.
johnmeyer wrote on 5/10/2005, 8:50 AM
... she was so fat, each cheek had its own zip code ...

rimshot