Unable to render MPEG

Pryach wrote on 4/13/2005, 3:21 AM
For some reason, Vegas doesn't have an option to render videos into MPEG format. It's not an option in the dropdown list. I have all the normal stuff, wmv, mov, avi, wav, ogg, etc.

I recently had to format my hard drive and reinstall all my programs. I used to have the ability to render into MPEG, but it's gone now. Is there a plugin or a codec I need to get somewhere?


jetdv wrote on 4/13/2005, 7:07 AM
I would try reinstalling Vegas and/or DVDA. If that still doesn't work, I would uninstall ALL Sony programs, delete the Sony folder, (and maybe even delete the Sony registry entries but only if you KNOW what you are doing), and then reinstall the Sony programs.
[r]Evolution wrote on 4/13/2005, 8:41 AM
If you check out the forums and do a few searches.... I think for MPEG... or something like that, you'll see that there was a problem with the registry at one point and time. I had the same issue and so did a few others. There IS something that you need to delete in your registry. One of the values duplicates or something. Once you delete one of the values... you'll see your option for MPEG appear.

You're on the right track. You'll probably just have to poke around the forums a little and you'll find it. You don't need to uninstall/reinstall. You just need to find the correct value and delete it. You can look in your registry under I believe Main Concept and I bet you'll see duplicat entries. -- but right off hand I don't know which to delete... so don't go deleting till you know the correct one.

Do a little forum 'searching' and you'll see what I'm talking about. I remember seeing this problem mentioned a few times.
jetdv wrote on 4/13/2005, 9:37 AM
What you are referring to fixes a problem where the "Custom" button does not work - however the MPEG options appear in that case.
SonyTSW wrote on 4/13/2005, 10:18 PM
The symptom you describe sounds like you may have forced the Sonic Foundry plug-ins to be installed over the top of the Sony plug-ins (or vice-versa) when you installed after reformatting your hard drive.

This Knowledge Base article should help you straighten things out:
Expired MP3, MPEG and AC3 errors, or demo beeps from your audio plug-ins.

If that doesn't work or you need some additional assistance, you'll need to contact Customer Support.
Pryach wrote on 4/13/2005, 10:56 PM
I looked in the registry in the place that page specified,

HKEY_LOCAL_MACHINE\Software\Sony Media Software\Shared Information

And the only thing in there is HelpFolder and SharedComponentsFolde. There's no specific mention of an individual audio or video codecs.

Also, that page seems to suggest that MPEG should be in my dropdown list, and it's not. It's not that I can't click "custom" or I get an expired error, it's that it isn't there completely.

I have no yet tried a full uninstall and reinstall.