Using external audio editor on m2t audio

RoyBU wrote on 6/1/2009, 6:57 AM
I recently rebuilt my video editing computer starting with a fresh install of Windows XP Home. I then installed Vegas Pro 8c, After Effects CS3, and Adobe Audition 3. On beginning an HDV project (29 fps, 60i) I discovered that attempting to send a copy of the audio from Vegas to Audition to edit would either result in the error message "An error occurred during the current operation. A necessary function has not been implemented." Alternatively, if I tried to send the audio itself (not a copy) to Audition, then Vegas would seem to do so but nothing would appear in Audition. However, if I rendered the audio to a new track, thus creating a separate wave file, then I could send that audio - original or copy - to Audition without any problem.

I tried reverting to Vegas version 8a, and then could send a copy of the m2t audio to Audition just fine, but trying to send the original still resulted in nothing. When I then updated by installing 8c over 8a, the problem of not being able to send even a copy of the m2t audio reappeared.

Has anyone else experienced this problem, or has anyone else successfully sent a copy of m2t audio to Audition or another audio editor? The workaround of rendering to a new track is not a big deal, but is an extra step. Should I report this as a bug? Seems hard to believe it is something with my system since it is a very clean install that has been used for nothing other than what I've described, plus some browsing (like I'm doing right now).


blink3times wrote on 6/1/2009, 8:20 AM
" has anyone else successfully sent a copy of m2t audio to Audition or another audio editor?"

I have aa3 as well and the answer is no. Even with aa2 I was never really able to get it all working correctly.

I just simply render out the track then import as a separate file.. and do the same in return.
rs170a wrote on 6/1/2009, 4:16 PM
I just tried it with some HDV files I have and they opened up in Sound Forge when I asked it to do so.
BTW, it also worked with m2t and m2ts files.
All files were stereo, not 5.1 if that makes any difference.

RoyBU wrote on 6/7/2009, 4:44 PM
Thanks for the replies. I do have Sound Forge but haven't worked with it enough to get used to it. I'll install it and try that route.
RoyBU wrote on 6/12/2009, 6:56 AM
I installed Sound Forge and unfortunately got the same error message when trying to send the audio from an m2t clip. Guess I'll just have to render to a new track and go from there.
wwaag wrote on 6/12/2009, 12:31 PM
This is definitely a bug in 8.0c. Using an m2t file, I have successfully opened an external editor (Sound Forge and others) in versions 7.0e, , 8.0a, 8.1 (64bit), 9.0 (32bit) and 9.0 (64bit). In 8.0c, it creates a "...take.wav" file, although there is nothing in it and you can't open it. If you replace the audio stream with a rendered wav file, it works OK. This should definitely be reported as a bug to Sony.


AKA the HappyOtter at System 1: Intel i7-8700k with HD 630 graphics plus an Nvidia RTX4070 graphics card. System 2: Intel i7-3770k with HD 4000 graphics plus an AMD RX550 graphics card. System 3: Laptop. Dell Inspiron Plus 16. Intel i7-11800H, Intel Graphics. Current cameras include Panasonic FZ2500, GoPro Hero11 and Hero8 Black plus a myriad of smartPhone, pocket cameras, video cameras and film cameras going back to the original Nikon S.

blink3times wrote on 6/13/2009, 7:04 AM
Interesting.... In V9 after some screwing around (not sure what I did), I can now use the "Open Copy In Audio Editor" button (with adobe audition 3), but I still can't get "open n Audio Editor" to work. Audition opens but there is nothing there on the time line