vectorskink wrote on 9/26/2008, 3:17 AM
BTW, Vegas 8.0c is working fine with the m2t's...
Xander wrote on 9/26/2008, 3:24 AM
Open up Vegas 8c and when it asks to keep the file associations, say yes. Then open Vegas 8.1, If it asks to keep the file associations, say no. The above worked for me. Had the same issue with Quicktime files as well.
Jeff B wrote on 9/26/2008, 3:29 AM
The raw files from my Sony HDR-CX7 memory cards (*.MTS) produce that problem. If I use the handycam utility to transfer the files from the camcorder to the computer via the docking station USB, however, that software utility re-packages the files (*.m2ts)... those work fine in Vegas 8.1

It doesn't appear to be the video/audio format, itself, that Vegas has problems with, it's the file container, apparently.... maybe just some bit of info in the file header... who knows? The same files that won't work in Vegas, however, work fine in Nero and Corel VideoStudio.

On version 8.0b, only the first 2gig file from a memory card holding a single >2gig continuous shot would be unreadable. Everything else on memory cards has been usable and readable. Luckily, this is still the case with version 8.0c but, on 8.1, none of the raw memory card files are usable anymore, regardless of size.

What's really annoying is that the HDR-CX7 handicam utility software is impossible to run on Vista 64... I have to reboot over to XP32 to run it and extract all my clips, now, if I want to use them in the 8.1 version of Vegas.
vectorskink wrote on 9/26/2008, 3:30 AM
Xander you're a CHAMPION! It worked!
Thanks mate.
ndar wrote on 9/27/2008, 11:35 PM
any suggestions on what one would do if 8.1 is the only version on box and having same problems? thx
vectorskink wrote on 9/28/2008, 11:48 PM

In 8.1, goto preferences and turn off the "check for associations" option.

ndar wrote on 9/29/2008, 9:47 AM
I'm not at my machine but will check it out tonight. thank you.