V9 very horrible Neo Hdv performance

dreamlx wrote on 5/11/2009, 12:35 PM

I just installed Vegas 9. In Vegas 8, I had about 25 fps when previewing 1080-50i cineform files. In Vegas 9, in trimmer they are still fine, but on timeline, the maximum preview rate I can obtain is 1.2 fps. M2T files preview at the full 25 fps on timeline. I don't know if it is a Neo Hdv problem or a Vegas 9 problem, but as long as this problem is not resolved, I will continue to use Vegas 8, as cutting at 1.2 fps isn't really the best experience.

Can anyone confirm this problem ?

In hope that a solution to this will be found,
David Arendt


fordie wrote on 5/11/2009, 12:38 PM
I found playback was fine with cineform hdv files getting a solid 25fps with 50i footage...however if i add a simple title to the track above playback drops to 6fps during title and then remains at 6fps until i stop playback and restart preview changes from best full to preview half but fps is still 6!
fordie wrote on 5/11/2009, 12:51 PM
ok got answer elsewhere had to disable auto adjust preview..not a very smart auto adjust !
dreamlx wrote on 5/11/2009, 12:52 PM
What version of the Cineform HD Codec are you using ? Here it is showing v4.3.4 as version. I am currenlty running Vegas on a single core 3ghz cpu (this is the same machine on which it runs flawlessly in V8). I checked my properties again, but I can't seem to find anything that makes Cineform performance better.
dreamlx wrote on 5/11/2009, 12:55 PM
How exactly did you disable auto adjust preview ? Right click on preview and uncheck Adjust Size and Quality fir Optimal Playback or did you do something else ? As this doesn't seem to make a difference for me.
CClub wrote on 5/11/2009, 1:21 PM
I'm running into the same problem. Same veg with Vegas 8 ran fine with Preview/Half setting; now in V9, fps around 2-5. Not sure if Cineform issue or Vegas.
jabloomf1230 wrote on 5/11/2009, 3:55 PM
Look here:


Cineform is stating that "Vegas broke compatibility with our 32-bit modes", which probably accounts for the poor preview frame rates in 32 bit Vegas Pro 9.
CClub wrote on 5/11/2009, 4:24 PM
I saw (& posted in) that link also. I'm trying to find out the answer calmly, as someone posted a bit angrily in that forum and got kicked out, but it's driving me CRAZY, because it appears that those of us who purchased Cineform Neo HDV just to utilize their intermediates within Vegas may be out of luck using V9. Makes no sense.
David Newman wrote on 5/11/2009, 8:08 PM
Do you have the same poor performance with the newer CineForm Tools? We have made no changes that should impact performance. We are still using the VFW interface, we only provide 32-bit components -- not the quote from the other link was but 64-bit version running 32-bit components and doesn't apply here. It does seem that Vegas use for VfW has slowed with each new release. We have provided Sony will the CineForm SDKs to see if there can be convinced to provide native CineForm support rather than going the long way around with VfW, as we just don't have the bandwidth to do that integration ourselves (it would take us a solid month of engineering and Sony a week for the same work.)

David Newman
CTO, CineForm
CClub wrote on 5/11/2009, 8:21 PM
Thanks for chiming in here. If I understand what you're saying, I chose Cineform, Tools, Desktop Playback - Fast.

I have both versions of Vegas opened: Vegas 8 plays the veg (1440 x 1080 HDV Cineform files) at Preview, Half at full 23.976 fps. Vegas 9 plays the same veg at Preview, Half but only averages 2-5 fps.

I had used Neo HDV to capture the footage, but that shouldn't make a difference during playback, I'm guessing. I haven't upgraded to Neo HD yet; I'm not sure if that would make a difference here.
rich__r wrote on 5/11/2009, 8:49 PM
Yup. Unfortunately I see the same problems. I used Neo Scene to convert from AVCHD and from Sanyo mp4 to Cinform AVI's. In 8.0c I see 1920 x 1080 play at about 30 fps (the actual framerate from the mp4 is 60fps) sometimes a bit higher. Vegas 8.0c would not play the 1920 x 1080 60fps mp4's at all (it crashed). Now at least 9.0 will play the files without crashing, but pretty much all of my performance gains with from Cineform Neo Scene are gone: native mp4 play at about 6 fps and the Cineform avi plays at about 8 fps. Big Bummer...

Serena wrote on 5/11/2009, 9:12 PM
Put a ticket into Sony. Ability to use Cineform is essential. Guess I won't bother installing V9.
David Newman wrote on 5/11/2009, 10:36 PM
That is very odd, and you sure Vegas isn't defaulting to 32-bit processing when 8.0c defaulted to 8-bit. There is no reason we would be faster or slower, we are decoding at the same rate as before, but something additional is clearly happening downstream of our decode.

David Newman
CTO, CineForm
Aje wrote on 5/11/2009, 11:02 PM
My Neo Scene avi files (made from MTS ) that V8,0c handled so well
don´t even show up when loaded into V9/64 just the audiopart shows on timeline. Video is blank and off line.
Do I have to reinstall Neo Scene after upgrading to V9/64?
fordie wrote on 5/11/2009, 11:14 PM
cineform isnt compatible with 64 bit versions of vegas
dreamlx wrote on 5/11/2009, 11:43 PM
What really disappoints us is that each new version of Vegas introduces new (sometimes major) problems. Unfortunately, we can't tell our customers that delivery now takes longer because of software problems. Furtunately old Vegas versions don't have to be uninstalled before installing new ones, so we can still use the old one. But will this problem ever get fixed ? Nobody knows...
jabloomf1230 wrote on 5/12/2009, 5:34 AM

I haven't installed Vegas 9, just because I was concerned about these issues, but there are a number of posts that claim that the "Adjust Size and Quality for Optimal Playback" setting (found as a check box by right-clicking the Preview Window) kills preview frame rates with Cineform. The best approach is to turn this option off and use "Good,Full", rather than "Preview,Auto", like in Vegas 8. Most people find that they still won't get RT preview frame rates, but the preview is at least usable, until a solution is found.

CClub wrote on 5/12/2009, 5:44 AM
Re Jabloom's comments: even when I switch off the new V9 auto-preview feature, I'm still getting horrid playback rates, even at Preview, 1/2 or 1/4.
jwcarney wrote on 5/12/2009, 6:42 AM
This is rather disappointing. I was planning on upgrading to 9 and purchasing Neo 4K for capture and edit. Not sure what to do now.