Vegas 11 + Nvidia 3D vision

benredstar wrote on 3/14/2012, 10:25 AM
I am trying to put together the spec for a 3D editing system, built around Vegas 11, cineform 3D and Nvidia 3D vision. The problem I am facing is the bug introduced between Vegas 10 and 11 that prevents 3D output to a secondary display (in our case a projector). Vegas 10 works, 11 doesn't. Unfortunately without the GPU acceleration of 11 version 10 is fundamentally unusable.

So my question is:
Does anybody use Vegas 11 and Nvidia 3D vision to edit stereoscopic movies? And are you able to playback through the secondary output in 3D?

If so how have you made it work? I am running a Quadro 4000 card and have tried various driver releases and that doesn't seem to solve the problem. I have heard that people have made this work using a Geforce card and legacy drivers but I can't find any real specs.

Comments

Wolfgang S. wrote on 3/14/2012, 2:13 PM
I am running 3D with nvidia 3D vision since Vegas 10 and now also with Vegas 11. Using a Quadro 2000D I have 3D preview on a 120 Hz monitor using the secondary display. Works fine here.

What you have to do is to adjust the nviida driver that Vegas is recognized as 3D application. If you need further help here, please let me know.

Desktop: PC AMD 3960X, 24x3,8 Mhz * GTX 3080 Ti * Blackmagic Extreme 4K 12G * QNAP Max8 10 Gb Lan * Blackmagic Pocket 6K/6K Pro, EVA1, FS7

Laptop: ProArt Studiobook 16 OLED (ProArt Studiobook 16 OLED (i9 12900H with i-GPU Iris XE, 32 GB Ram. Geforce RTX 3070 TI 8GB) with internal HDR preview on the laptop monitor. Blackmagic Ultrastudio 4K mini

HDR monitor: ProArt Monitor PA32 UCG, Atomos Sumo

benredstar wrote on 3/15/2012, 6:04 AM
Thanks for the reply. I'm still having trouble I'm afraid. Here's a screen grab of the settings we've got in the Nvidia driver:
http://www.redstar3d.com/temp/settings.jpg

It appears from Vegas 10 to 11 the implementation of stereoscopic output changed. Whereas in 10 you would specify a 'Stereoscopic Graphics Card' on the preview device tab of the preferences menu, in 11 there is no such option and you have to select 'Windows Graphics Card' and set the stereoscopic options to 'left and right'. All this seems to give us is a black output. It will output other steeo modes eg anaglyph perfectly but not 3D Vision.

What version of the quadro drivers are you running?
Wolfgang S. wrote on 3/15/2012, 1:46 PM
It is correct that you have to slect "left and right" and "windows graphics card" - but that is fine and works here with my Quadro 2000D.

What I miss in your picture is below "stereo - enable" (you are right: that must be on) another option that is called "stereo - Anzeigenmodus", what you could translage with stereo - display mode. Here you have to choose "generic active stereo (with nvidia)", as you see it in the picture in that German publication:

http://www.slashcam.de/artikel/Test/Sony-Vegas-Pro-10---Multitalent-auf-Speed--Nvidia-Quadro-4000.html

That seems to be missing in your driver, since it comes between "stereo - enable" and "stereo - swap eyes" - but there is nothing. No idea why that is missing.

I have to come back to you with the information what quadro driver I run - I am not at home until the weekend.

Desktop: PC AMD 3960X, 24x3,8 Mhz * GTX 3080 Ti * Blackmagic Extreme 4K 12G * QNAP Max8 10 Gb Lan * Blackmagic Pocket 6K/6K Pro, EVA1, FS7

Laptop: ProArt Studiobook 16 OLED (ProArt Studiobook 16 OLED (i9 12900H with i-GPU Iris XE, 32 GB Ram. Geforce RTX 3070 TI 8GB) with internal HDR preview on the laptop monitor. Blackmagic Ultrastudio 4K mini

HDR monitor: ProArt Monitor PA32 UCG, Atomos Sumo

benredstar wrote on 3/16/2012, 6:31 AM
Hi Wolfgang

The article is outlining a procedure for Vegas 10. We don't have a problem with Vegas 10 in terms of stereoscopic playback. It is Vegas 11 that doesn't work. Unfortunately without the GPU acceleration of 11 the software is pretty much unusable for us.

The option for "stereo - Anzeigenmodus" or "stereo - Display mode" does exist in our driver settings, it just lives above the "stereo - Enable" option instead of below. see: http://www.redstar3d.com/temp/settings.jpg

I would be most interested to know which version of the quadro driver you are running, and which OS and if there are any settings you have particularly enabled/disabled within Vegas 11 - GPU accelleration springs to mind.

Many thanks!
Jan.
Wolfgang S. wrote on 3/17/2012, 6:56 AM
I am running in my system both a nvidia Quadro 2000D and a nvidia Geforce GTX570 (the later for CUDA supported rendering).

I had to install FIRST the Geforce driver - at the moment it is 285.62. But there is no monitor connected to that system.

In a second step - so after the Geforce driver - I installed the Quadro 2000D driver - that is 285.58 at the moment.

Since you use a Quadro only, I would try to use the Quadro driver 285.58.

I run Win7 64 bit, so all drivers are the Win7 64 bit version here.

I see that there are new driver for BOTH the Quadro and the Geforce availabel - 295.73. But I have not tested that yet. Given that I run two cards I tend to be conservative here (never touch a running system :) - or I have a backup of the system at least with Trueimage).

Settings in nvidia system settings are:
- stereo enable: on
- strereo display mode: generic active stereo (with nvidia 3D vision)
all other settings are on global mode

Settings in Vegas Pro 11 build 595 64 bit:
- preferences/view
dynamic ram preview: 0 (since then Vegas is more stable)
GPU acceleration of video processing: off (since my i7 2600K is stronger then even the GPU acceleration of the Geforce 570 - the Quadro 2000D is even weaker)

- preview device (I use a 120 Hz 3D Asus monitor with nvidia 3D vision, connected via DVI - hdmi does not work for that hardware)
device: windows graphic card
stereoscopic 3D mode: left and right

Frankly spoken, I see no difference between Vegas Pro 10 and Vegas Pro 11. The same settings work both for 10 and 11, beside the fact that SCS had in Vegas Pro 10 the device "Stereoscopic 3D Graphic card", what was integrated by SCS with Pro 11 in "windows graphic card". Here Vegas Pro 10 works fine beside Vegas Pro 11 on the same PC.

Settings in Vegas 7 64 bit:

Desktop: PC AMD 3960X, 24x3,8 Mhz * GTX 3080 Ti * Blackmagic Extreme 4K 12G * QNAP Max8 10 Gb Lan * Blackmagic Pocket 6K/6K Pro, EVA1, FS7

Laptop: ProArt Studiobook 16 OLED (ProArt Studiobook 16 OLED (i9 12900H with i-GPU Iris XE, 32 GB Ram. Geforce RTX 3070 TI 8GB) with internal HDR preview on the laptop monitor. Blackmagic Ultrastudio 4K mini

HDR monitor: ProArt Monitor PA32 UCG, Atomos Sumo

cybercom wrote on 3/17/2012, 11:26 AM
Actually they have released v296.10 WHQL

http://www.geforce.com/Drivers/Results/42438

HTH<

<")%%%><(
Wolfgang S. wrote on 3/17/2012, 1:19 PM
Yes I know - but it must not be true that the latest driver are the best choice.

Desktop: PC AMD 3960X, 24x3,8 Mhz * GTX 3080 Ti * Blackmagic Extreme 4K 12G * QNAP Max8 10 Gb Lan * Blackmagic Pocket 6K/6K Pro, EVA1, FS7

Laptop: ProArt Studiobook 16 OLED (ProArt Studiobook 16 OLED (i9 12900H with i-GPU Iris XE, 32 GB Ram. Geforce RTX 3070 TI 8GB) with internal HDR preview on the laptop monitor. Blackmagic Ultrastudio 4K mini

HDR monitor: ProArt Monitor PA32 UCG, Atomos Sumo

Wolfgang S. wrote on 3/18/2012, 9:30 AM
Just another hint - IMPORTANT: off course, you have to run the setup for 3D from the nvidia pannel - otherwise you will have a black monitor for the 3D preview.

I have also tried to install the latest quadro driver version 295.73 - that works fine here too. After the installation of the new driver I had to run the nvida setup of the 3D function again - as said above.

The only issue I see - but that is my specific setting only with two nvidia cards - is that I am not able to install the latest driver for BOTH cards. So in my case I have installed the latest Quadro driver 295.73 only, and stay with the nvidia Geforece driver 285.62.

Desktop: PC AMD 3960X, 24x3,8 Mhz * GTX 3080 Ti * Blackmagic Extreme 4K 12G * QNAP Max8 10 Gb Lan * Blackmagic Pocket 6K/6K Pro, EVA1, FS7

Laptop: ProArt Studiobook 16 OLED (ProArt Studiobook 16 OLED (i9 12900H with i-GPU Iris XE, 32 GB Ram. Geforce RTX 3070 TI 8GB) with internal HDR preview on the laptop monitor. Blackmagic Ultrastudio 4K mini

HDR monitor: ProArt Monitor PA32 UCG, Atomos Sumo

benredstar wrote on 3/26/2012, 7:05 AM
Hi Wolfgang!

Apologies for the delay in getting back to you, I was away last week blissfully ignorant of all Vegas related obstacles!

Many thanks for your advice, we have now solved the problem. It sounds ridiculous now but it was down to running the 'enable stereoscopic' wizard. I had assumed this was an automated way of setting the already exposed nvidia 3D parameters but it appears that it does something behind the scenes that Vegas 11 hooks into. The confusion was that Vegas 10 doesn't require this wizard to be run. Plus the way nvidia have set up the wizard makes it appear as if it's only necessary for openGL/games.

Anyway the long and the short of it is (a little embarrassingly!) that to get 3D output on a secondary display in Vegas 11 you have to run the 'enable stereoscopic 3d' wizard. For anyone having the same issue...

1 Install the driver (it works with the latest (295.73) quadro driver
2 Make your secondary display (ie projector) the only system display
3 Run wizard (it doesn't see multiple displays and will pick the primary)
4 Enable multiple displays and set primary display back to desktop

Many thanks again.
Wolfgang S. wrote on 3/26/2012, 8:59 AM
Well, fine that it works now. I also was not really aware any more that you have to run the setup of the wizard again when you install a new version of the driver - but I saw it when I tested the new 295.73 quadro driver, and the new driver is working fine here too. Beside the fact that it does not work with another tool (the PD10).

But Vegas is fine with that driver, and that is nice to know.

Desktop: PC AMD 3960X, 24x3,8 Mhz * GTX 3080 Ti * Blackmagic Extreme 4K 12G * QNAP Max8 10 Gb Lan * Blackmagic Pocket 6K/6K Pro, EVA1, FS7

Laptop: ProArt Studiobook 16 OLED (ProArt Studiobook 16 OLED (i9 12900H with i-GPU Iris XE, 32 GB Ram. Geforce RTX 3070 TI 8GB) with internal HDR preview on the laptop monitor. Blackmagic Ultrastudio 4K mini

HDR monitor: ProArt Monitor PA32 UCG, Atomos Sumo