Vegas 12 triped at the starting gate

nickntime wrote on 10/5/2012, 2:45 PM
Just ordered and downloaded V12 upgrade.
It downloaded and installed OK and accepted the new serial #'s
and registered online.
When trying to open however it will "stop responding" with the following
details:

Problem Description
Application Name: Vegas Pro
Application Version: Version 12.0 (Build 367) 64-bit
Problem: Unmanaged Exception (0xc0000005)
Fault Module: C:\Windows\system32\aticfx64.dll
Fault Address: 0x000000006242A2FF
Fault Offset: 0x000000000002A2FF

Fault Process Details
Process Path: C:\Program Files\Sony\Vegas Pro 12.0\vegas120.exe
Process Version: Version 12.0 (Build 367) 64-bit
Process Description: Vegas Pro
Process Image Date: 2012-09-14 (Fri Sep 14) 17:31:36

I tried to send this to tech support but my login will not work and the password reset is not functional. I realy feel rejected. Do I need to call them? I see from other post that they do not respond well to quires.

Comments

nickntime wrote on 10/5/2012, 2:59 PM
More info on above issue.
Watching the progress bar on loading I noticed thst Vegas crashes when it
tries to load the GPU processors. Is there a way to dissable that without opening Vegas?
I have a NVIDA GeForce 9400 GT card
WillemT wrote on 10/5/2012, 3:13 PM
Something funny here.

The exception is a very common one for all sorts of problems.

The faulty module is aticfx64.dll, after a very cursory Google search, seems to be some HDMI driver software for an ATI graphics card. Why you have that I cannot explain - something has its nickers in a knot, to quote a phrase.

Yet you are using an NVIDIA graphics card??

Willem.
monoparadox wrote on 10/5/2012, 4:13 PM
Not that this will solve your problem, but it could make a difference: go into the nVidia setup program and make sure that the Vegas 12 application is assigned to use the nVidia card for graphic processing.

This could be a factor if you have integrated video on your motherboard or perhaps a leftover ati file trying to grab your card and Vegas on program startup.

tom
nickntime wrote on 10/5/2012, 4:19 PM
Hi Willem,
I have on board ATI graphics that I thought was disabled when I installed the
NIVDIA card. There is nothing in my device manager or in system information
referencing ATI.
Is there other places I should look?
Gene.
diverG wrote on 10/5/2012, 4:27 PM
Can you remove the ati driver via control panel?

Sys 1 Gig Z370-HD3, i7 8086K @ 5.0 Ghz 16gb ram, 250gb SSD, 2x2Tb hd,  GTX 4060 8Gb, BMIP4k video out. (PS 750W); Vegas 18 & 19 plus Edius 8WG DVResolve18 Studio. Win 10 Pro (22H2) Bld 19045.2311

Sys 2 Gig Z170-HD3, i7 6700K @ 3.8Ghz 16gb ram, 250gb SSD, 2x2Tb, hdd GTX 1060 6Gb, BMIP4k video out. (PS 650W) Vegas 18 plus Edius 8WG DVResolve18 Studio Win 10 Pro (22H2) Bld 19045.2311

Sys 3 Laptop 'Clevo' i7 6700K @ 3.0ghz, 16gb ram, 250gb SSd + 2Tb hdd,   nvidia 940 M graphics. VP17, Plus Edius 8WG Win 10 Pro (20H2) Resolve18

 

fordie wrote on 10/5/2012, 4:39 PM
Disable the on board grahics in BIOS.
WillemT wrote on 10/5/2012, 4:41 PM
Historically when a separate graphics card was installed the onboard graphics was automatically disabled. I do not think that is the case anymore with new mother boards. They nowadays seem to allow concurrent running as mutliple options (mine certainly does).

I think having two entirely separate manufacturer's drivers installed is asking for trouble, that is if they can coexist. My initial guess is, as things stand seem to stand, that Vegas is not making the right decisions as to what to use.

See if you can disable the onboard graphics in the bios. Maybe even temporarily remove the NVIDIA and start Vegas with the onboard only - see if it initializes correctly. Other than that I have no idea what to suggest.

Willem.
nickntime wrote on 10/5/2012, 4:47 PM
The only place I see an ATI reference is in system devices.

ATI/O Communications processor PCI Bus Controller
ATI/O Communications processor SM Bus Controller

There is nothing in Device Manager.

Is it safe to disable these?

rmack350 wrote on 10/5/2012, 4:58 PM
Last I looked into it, Windows would not allow two GFX drivers to run. At that time you could run multiple ATI or NVIDIA cards but not a mix of the two since that would require an ATI and an NVIDIA driver (aka two drivers).

This doesn't seem to be the case anymore, since you can run with an Intel driver and a driver for a discrete ATI or NVIDIA card. I'm sure the same goes for onboard ATI graphics.

Soooo...this could be a source of a lot of crashing if systems have more than one graphics driver active when Vegas starts. In fact, a lot of new motherboards ship with LucidLogix Virtu which is specifically supposed to help you automatically switch between onboard and discrete graphics all on the same output port. So, it seems quite possible to me that Vegas may detect one set of graphics features at startup and then have something else available once it gets running. That's my guess.

It was suggested to disable your onboard graphics in your BIOS. If you can do that it might make a difference.

Rob
nickntime wrote on 10/5/2012, 5:14 PM
Looked at BIOS and the onboard graphics is grayed out and the PCI card is enabled. My Vegas 10 64bit runs fine by the way.
Any other suggestions?
TheHappyFriar wrote on 10/5/2012, 5:19 PM
Uninstall your ATI drivers, make sure you "new" card is the one the system uses & that you're monitor isn't plugged in to the "old" card's display port. Make sure the "new" one is the primary display.
nickntime wrote on 10/5/2012, 5:27 PM
Where do I uninstall the drivers? ATI is not listed in device manager or anywhere else that I can see Nothing is pluged into the on board graphics ports.
monoparadox wrote on 10/5/2012, 6:05 PM
You may have to remove your nVidia card, activate your ATI and then uninstall the drivers to get a clean uninstall. Then, reinstall your nVidia card. Reboot, go into bios setup right away and make sure your ATI is off. Start windows and reinstall your nVidia drivers.

I've had to do that a few times when switching out video cards.
Kimberly wrote on 10/5/2012, 6:08 PM
@NicknTime:

Here is a workaround that might help:

Opened your Nvidia control panel.
Select your integrated graphics card for Vegas Pro 12.
Launch Vegas Pro 12.
Open Options/Preferences/Video.
Change “GPU acceleration of video processing” to your Nvidia card.
Close Vegas Pro 12.
Re-launch Vegas Pro 12.
Re-enable GPU acceleration at your discretion.

Not sure if that will help but I hope so.

Regards,

Kimbelry
nickntime wrote on 10/5/2012, 7:01 PM
Thanks Kimberly - V12 still crashes when it is opening at the point of loading
GPU acceleration. I loaded new drivers for Nivida but that didn't help either.
"Catch 22" comes to mind.
Gene
TheHappyFriar wrote on 10/5/2012, 11:13 PM
Do what mono said. You've got to get those ATI drivers off. Better yet, remove the Nvidia ones, remove that card & see how everything works with the built in ATI. If that works, then remove the drivers for the ATI, install the Nvidia card & install it's drivers.
Doug A. wrote on 10/6/2012, 12:40 AM
There is a program to clear out any trace of old drivers.

http://phyxion.net/

The program was called Driver Sweeper, they recently changed the name to Driver Fusion.

There are a bunch of online tutorials for Driver Sweeper, a program used a lot by gamers that change video cards and drivers.

Doug
Chris B wrote on 10/6/2012, 1:27 AM
I had more or less this issue when I installed VP11. I used to have an ATI card (changed to Nvidia) and there was residue of the old driver left. I think I ended up manually deleting the files from my windows system directories in the end - once I'd done that Vegas started.

Driver sweeper would be a good start though.
nickntime wrote on 10/6/2012, 2:56 PM
Thanks everyone - Driver Sweeper did the trick.
Hopefuly I will be one of the "chosen" to have a crash resistent hardware/software combination for V12. Will know soon.
Gene
Tim20 wrote on 10/7/2012, 5:19 AM
Glad you figured it out but the easy way would be in the uninstall program section and for ATI is called: AMD Catalyst Install Manager.

An uninstalled devicer and/or driver will not show in the device manager.
nickntime wrote on 10/7/2012, 9:33 AM
Thanks -- Learned a few things - AMD and ATI are related products and that
this forum beats Sony's tech support by a mile.
Doug A. wrote on 10/7/2012, 1:33 PM
Glad you were able to sort it out nickntime.

I wonder if users with stability issues might benefit from Driver Sweeper?
I'm no computer guru but residual driver "stuff" might be causing problems. Just a thought.

Im running Vista and a ATI/AMD(now) 4870x2 GPU and have had very few Vegas Pro 11 issues, even with NBT.