Vegas 4.0 won't open, what gives?

Studio_de_Lara wrote on 2/14/2003, 6:58 PM
So, I upgrade to 4.0, install (after removing demo), click on the exe file, the splash screen comes up, then.........nothing, Yeah!!

Try Vegas 3.0, no problems.

Try Vegas 4.0.........nothing, Yeah!!

Using XP, Athlon XP1800+, 1gig ram, M-Audio R-Bus

Anyone else having start up issues, what about "the disappearing Vegas trick" as I like to call it. The beta would just shut down, and go bye bye. Anyone?



Studio_de_Lara wrote on 2/14/2003, 7:53 PM
This is really weird. I can't get Vegas 4.0 to open at all.
I uninstalled everything, re-installed, and still no Vegas 4.0.
I can't believe once again, more bugs. Ugh.
Ben  wrote on 2/14/2003, 8:03 PM
I don't think it's a bug, or a lot of people would be coming on here reporting the same problem. Could perhaps be some sort of registry problem?

I'd suggest you call tech. support but - aghhh - I guess they're not around now until Monday. How about you try V4 on another machine?

Studio_de_Lara wrote on 2/14/2003, 8:30 PM
Thanks for the response.
No go with another machine. I need to get my serial number from SoFo, I did a remove and re-install, and Vegas 4.0 is asking for the serial number again (which I accidently deleted from my email).
What is really weird about this, is that Vegas did run, once. But it did shut down on its own for no reason at all. Vegas 4.0 won't run in demo mode either.
Oh well, guess I wait.
StepD wrote on 2/15/2003, 2:53 AM
Are you running Logic 5? If you are, you have to pull the XSKey or Vegas 4 won't launch. It's been reported to SF.
Studio_de_Lara wrote on 2/15/2003, 4:46 AM
Thank you so much. Well, I guess using Logic for midi and Vegas for audio at the same time is out.
So I guess this is a bug.
Started up with no problems. Now I have to re-register.
pwppch wrote on 2/15/2003, 4:51 PM
There appears to be a problem with the Logic USB dongle and Vegas. We have tried endlessly to contact Emagic on this, but so far they have not repsonded in kind.

We believe it has something to do with the USB dongle using the DirectInput API for its driver model. We are not sure.

This has bitten a number of users causing us all kinds of havoc. We are on it and as soon as we have a solution - other than pulling the dongle, we will post a fix.

Studio_de_Lara wrote on 2/15/2003, 6:17 PM
Nice response time. Now only if someone could email me my serial number :)
StepD wrote on 2/15/2003, 11:44 PM
My guess is the dongle is conflicting with Vegas' support for joysticks, since that probably uses the DirectInput API too. Vegas looks for joysticks on startup, runs into the dongle and freaks out. Maybe you can write some code to ignore the dongle.
pwppch wrote on 2/16/2003, 4:11 PM
Exactly the problem : We have joystick support for the surround panner in Vegas.

We never considered testing against a USB copy protection dongle here. We had no idea that this would even be an issue.

Again, we are working on a solution.

Rednroll wrote on 2/16/2003, 4:21 PM
The solutions should be for Logic to get rid of that damn dongle copy protection that doesn't work anyways....or you should look for a cracked version of the program that doesn't look for the dongle. :-) Good luck getting Logic to address this, they've gone to the dark side now (Mac only), I doubt they'll be addressing many bug fixes on the PC side now.
pwppch wrote on 2/16/2003, 7:34 PM
Once we get a dongle in house, we should be at least able to figure out what is crashing us.